How to burn android image to BPI-M3 EMMC

1,download android 5.1.1 image from download page:

2,if your PC is windows OS, please download tooling to burn if your PC is Linux OS, please download Linux 32bit or Linux 64bit tooling

example: burn android image to EMMC on windows.

1,install PhonenixSuit. 2,running PhonenixSuit. chick “one key to burn” choose your android image file .

3,press on BPI-M3 uboot key. and plug in micro USB data line.

4,press on Power key to boot BPI-M3.

5,press Yes to burn image:

6,if all is ok , try to boot from eMMC , if any issue ,just need try again.

@sinovoip I know you are just graduated student, but this shall be no excuse not to use your brain. I don’t know who you are, but you do know that posting in forums tend to disapear, if new postings are written, right?

So why the heck do you write this here and do not ask @projectbananapi to put this on the website? What is going on in your brain - or did your boss tell you to do so? I don’t understand something like this. Really I don’t this is so not smart.

Beside, the screenshots. Make two (2) instructions, one (1) in english with english screenshots, one (1) in chinese. This is sooooo easy, just think before you start.


´You already provide corrupted images on your various download locations. For every download you prepare, create at least a SHA1 and MD5 checksum and publish them together with the files to download. And explain how to verify checksums after downloads.

Everyone on this planet that provides software for download does so since decades. And it saves you and your users from so much trouble.

And posting ‘instructions’ somewhere inside a forum is just moronic. But this seems also part of your ‘company culture’ that is the real source of all the mess SinoVoip customers experience again and again.

1 Like

I will post a link to this post on the website.

Why? It’s still incomplete unless they also prepare a guide how to flash an Android image to SD-card. And as long as SinoVoip delivers broken images and doesn’t provide SHA1/MD5 checksums the whole process is just a waste of time. :grinning:

People download a few corrupted GB from the net, burn them on SD-card or to eMMC. And then booting fails and all @sinovoip provides is the recommendation to “just need try again”. Are they kidding?

It should at least look like that: (version information, date, checksums to verify broken downloads) or maybe like that:

There MD5 sums are provided together with broken images. And an “admin” not knowing what’s wrong with broken images:

The download links here miss even the checksums so that novice users have no clue at all why OS images provided by @sinovoip don’t work. Last example: BPI-M3 new image:bpi-m3-ubuntu15.04 image beta 1.0 update (broken download, no one cares – best user exprience ever)

1 Like

Do you think i can apply to any banana pi m3 os? or it is just for the android os only?

this tooling only for android , we now try let it support linux image burn also ,we coworker with allwinner now.

Currently i am using 50pcs of Raspberry Pi on my system and i am very satisfied on their durability and stability Since it’s my first time to use banana pi, (M3) i am so much disappointed on the results of my test :

  • always hangup
  • always corrupt my sd card class10 OS (raspbian, debian, ubuntu)
  • network always disconnected

My banana Pi m3 has it own heat sink at high speed blower fan i buy it 69USD + 15USD for shipping + custom tax and now it become useless I am not sure if the OS came from your website are not yet stable or the possible the hardware defective I hope that you fix the problem before you start selling on the market.

You shouldn’t confuse the original Banana Pi with the incompatible boards SinoVoip produced later.

They use the brand ‘Banana’ now to sell nearly everything, some stuff with the same form factor (being incompatible due to different SoCs and a vendor that has clearly not the slightest idea about software and support) some totally different and not even running Linux/Android at all. Please compare with:

1 Like

The images are already corrupted. They provide only broken download links. And they started just yesterday to fix important stuff: :joy: therefore even if one of the images would not be corrupted important stuff won’t work.

The good news: I built successfully their so called “BSP” from github half an hour ago. It should be easy to combine this with a known working rootfs so when my BPi-M3 arrives I will combine it with a headless Armbian image and give that a try.

1 Like

Trying with a more recent version and hardfloat doesn’t work: :joy:

1 Like

I try to flash an android os using phoenixSuite and it works, but i need to use Raspbian or Debian for my system requirements. SinoVoip must need to provide with full working OS that works on Banana Pi M3 that i buy from them.

Please read what I’ve written to you 5 days ago: Banana pi m3 OS Server Download speed Problem

Android? Because it’s the only “OS” that will run flawlessly from the beginning…

And if you look into their github repo and see what has been fixed yesterday then you know that now even this is true. :joy:

It took several months until the OS images for the wrongly labeled “Banana Pi” M2 worked somewhat. But there the good news is: For the M2 with its A31s SoC there existed already good mainline kernel support so the community did the job. Now you can use the M2 without having to rely on weird software stuff from SinoVoip (rehashed stuff from Allwinner).

With the M3’a A83T it’s different. Mainline kernel support just started. And SinoVoip still has no clue how to become an open source community member. If they would donate 4-5 M3 to the linux-sunxi community things would improve a lot faster. But they prefer to sell hardware that can be either used with Android (using the software supplied by Allwinner) or as a paperweight (using the software supplied by SinoVoip).

I doubt we will see an M4. Until then they eventually managed to ruin the ‘Banana’ brand completely.

1 Like

Yes you are right, i am so much disappointed to Sinovoip because it lack of support. i will try that m2. Thanks

Yes, it’s really sad that they don’t even get the idea why both software and support matter

Be careful. Its SoC has been discontinued already (even before the product started to sell), support situation is as worse as with the M3, depending on your needs other boards provide a better performance/price ratio… and on top of that there exists a nice anecdote since a few days regarding the origin of both M1 and M2 :blush:

I would try to define your goals and ask for a recommendation here: (community project)

Install Android 5.1 on EMMC is everything ok ? You do not risk anything ? If something goes wrong as you can go back? Other systems can then start from the Micro SD with Android on board EMMC ?


Can someone give me step for step tutorial how I can load the Android image to the emmc. I tried the tutorial here but with no success. So I used PheonixSuit. Pressed the Uboot button (and hold it). Connected the USB Cable to my computer ( was connected to the OTG port of BPI). The red led turned on. But nothing happend. PhoenixSuit can’t find any device. So what made I wrong? Thank you for your help.


Please give us exact step of install Android 5.1.1 to M3 EMMC. YouTube movie of the installation would be great.


I’ve tried an old proven way using PhoenixCard 3.09 with an intermediate SDCard (just google by “PhonixCard” to get a lot of tutorials) and image flashed just fine.