Failed to find the right images for Banana pi M2 Zero

Hello all, I bought this week a Banana pi M2 Zero, and when I tested the card failed to start every time. I tried with several images and always the same issue, sometimes i got a different error after every reboot for the same image. You’ll find below the list of images I tried, and a logs for some error I got when I tried with armbian. -2020-04-28 update, Debian 9, Rasbian Stretch, Ubuntu 16.04 Mate Desktop -BPI-M2 Zero Armbian 5.41 3.4.113 (Debian Jessie, Ubuntu Xenial)

  • BPi-M2 Zero Armbian+ OV5640 + OpenCV SD image
    • 2020-04-10 update Raspbian Stretch, kernel 4.4
    • 2019-04-30 update Raspbian Stretch, kernel 3.4 - -Banana Pi new image: Ubuntu 16.04 with Allwinner BSP, use MPV play 1080P video,Allwinner BSP kernel 3.4 and many more, the only image that seems to work is 2020-04-10 update Raspbian but the screen freezed just after showing the desktop and the mouse. I use a Sd card 32GB classe10 from Kodak, and a mini hdmi (it seems that it worked well), and for flhing the sd card I use Balena Etcher. Can you help with this. Thank you so muchIMG20220608215505 IMG20220608224304 IMG20220608231927 IMG20220609013614

Also recently receive my m2z.

i was able to boot and ssh into the m2z with The 2020-04-10-raspbian-jessie-ap6212-bpi-m2z-sd-emmc image from The Getting Started Wiki and this forum post

Thank you Tearran for your answer.

I want share my experience here just in case someone has the same as mine, hope it will be helpful.

Well, my issue was different, I spent 3 days searching and testing many images, finally I managed to run Armbian buster on the BPI after I found the problem.

The cause of the problem is the power supply. I used a charger with 5V/1A, so even the Banana pi starts, it stacks somewhere before completing the installation. My advise, make sure you use a good power supply and a good quality of micro usb cable.

Thank you for sharing your solution.

1 Like