Banana Pi BPI-M2 Zero new image: 2020-04-10-raspbian-jessie-ap6212-bpi-m2z-sd-emmc image

Banana Pi BPI-M2 Zero new image: 2020-04-10-raspbian-jessie-ap6212-bpi-m2z-sd-emmc image

fixed wifi & BT issue.

image donload link:

google driver https://drive.google.com/file/d/1Xk86WchdJemKb4ltCX0AB9wRj5NJcZL1/view

baidu cloud: https://pan.baidu.com/s/1eKs85jMW3PS8pdX4jukLUQ PIN code:6W2M

@sinovoip Thank you for this updated image!

On the Overclock setting in the configuration menu the max is Turbo 1000MHz. Does this mean that this image can’t use the full 1200MHZ available to the M2Z?

Is there a workaround for this?

Thank you.

Great help having this Rasbian image thanks @sinovoip !

I am looking at how to use BPI-M2 ZERO with the Pimoroni Cluster HAT. The software required for a Rasbian based RPI ZERO is at the Cluster HAT support site.

Problems for porting the cluster hat code to BPI M2 ZERO include getting g_cdc kernel module to load and it’s lacking functionfs.

Would consider working with the Cluster CODE author to get Rasbian Jessie working as a cluster node please?

You can imaging how that would work in favour of BPI M2 ZERO over RPI ZERO because there are more cores for BPI M2 ZERO.

Cheers, A

can you share a build of kodi 19 for this device?

добрый день. подскажите как работать в этом образе с камерой?

Hello! thank you for the image @sinovoip . Can you share the default host, user and password please?

pi banana pi or root bananapi

The GCC inside is way too old. Compiled 10.1.0 for it. Have fun. Followed this link. https://solarianprogrammer.com/2018/05/06/building-gcc-cross-compiler-raspberry-pi/

I tried it but I have a problem. I can’t use the 1 wire protocol. Somehow the plugins and folder dosen’n exist. Can you please help me with this?

Hi, I tried this password for ssh but it’s not working is it [email protected]_ADDRESS with password banana?

In other images the password is: bananapi

try that

hello sinovoip,

Firstly thanks a lot for the Raspbian image. It worked like a charm on my banana pi zero. However I cannot get SPI work.Can you advice if you included the spi overlays?

I can see the “file” exists

[email protected]:~ $ ls /dev/spi*

/dev/spidev0.0

And SPI is ON in confifg.txt

#Uncomment some or all of these to enable the optional hardware interfaces

dtparam=spi=on

But I do not see it loaded when I try below command (no result)

lsmod | grep spi

Moreover, enabling SPI from dtparam, throws below message

sudo dtparam spi=on

mount: mount point /config/device-tree does not exist

  • Failed to mount configfs - 2

/config folder is actually empty when I check it.

Any hints will be appreciated

Thanks Sergi

For that you will need to upgrade to Armbian and use armbian-config-> system -> hardware

Hello igorpec,

Thanks for the comment. you mean to install armbian image instead if raspbian?

In fact I am looking at armbian archive now - https://armbian.tnahosting.net/archive/bananapim2zero/archive/

Is there preferred image version for Banana pi Zero?

Sergi