BPI-M2 Zero Armbian 5.41 3.4.113 (Debian Jessie, Ubuntu Xenial)

Older images keep breaking on me if i try to update, due to changes in the dt-file i think. So i build my own, maybe somebody else will get some use out of it.

Debian Jessie http://www.mediafire.com/file/rd58jqjp1vyx61e/Armbian_5.41_Bananapim2zero_Debian_jessie_default_3.4.113.img.zip

Ubuntu Xenial http://www.mediafire.com/file/lblc0l0c41c3cj8/Armbian_5.41_Bananapim2zero_Ubuntu_xenial_default_3.4.113_desktop.img.zip

I build both images with default config and patches for M2 zero. As I just needed a recent image for some quick testing I did not change anything.


very cool ,thank you share this image.

For me it works ok. The only problem is the display configuration, possible only by the command h3disp. Is it possible change by setting menu?

Hi g33k,

Do you have source for the creating the boot FAT image I have been trying to do this but have not had time to complete it. If you could share it on ideally on GitHub or post or send me some instructions - [email protected]



@ronfa I only ran it in a headless setup, but since the patches for M2 zero are applied i would expect to work out of the box or by using armbian-config.


Check out compile.sh for how its done. https://docs.armbian.com/Developer-Guide_Build-Preparation/

@g33k - I tried the M2 with 8-core mod Armbian build a while back but it did not produce a VFAT partition only the EXT3 one in the image.

Now I see where you are coming from. I am not able to check right now, but I guess it’s ext4 which uboot is able to read. No need for vfat partition.

Hi g33k,

After cloning why the wlan0 is getting renamed to wlan1?

Hi All, what’s the default user password? Can’t seem to get any of the usuals to work.


No Worries. root / 1234 worked eventually. Fat fingers??

Did you manage to get USB-OTG working with any input device, preferably as USB host (so that hubs etc. work)? I built Armbian on my own, based on Ubuntu 18.04, twice so I could test with both recent kernels (5.1 and 4.19), and this is the only part of BPI-M2Z which doesn’t work for me. No trace in dmesg of any plugging-unplugging, usb devices get the power (pwr light on passive usb hub) but nothing beyond that. And I’d like to be able to use it other than with just ssh.

All right, works as USB Host, needed a change in dr_mode from “otg” to “host” and all usb peripherals now work as expected. The required steps for recent Armbian are (all as root):

cd /boot/dtb
cp sun8i-h2-plus-bananapi-m2-zero.dtb sun8i-h2-plus-bananapi-m2-zero.dtb.old # backup
dtc -I dtb sun8i-h2-plus-bananapi-m2-zero.dtb -O dts -o sun8i-h2-plus-bananapi-m2-zero.dts
nano sun8i-h2-plus-bananapi-m2-zero.dts # change dr_mode from "otg" to "host"
dtc -I dts -O dtb -o sun8i-h2-plus-bananapi-m2-zero.dtb sun8i-h2-plus-bananapi-m2-zero.dts

I am stuck at choosing OS I have tried Raspbian on my banana pi m2 zero ,but the ssh server doesn’t come pre installed , so I managed to install it externally . I have decided to move on to different OS suggest me one and also Am I going to get i2C support in other OS and A CSI support , I will be using python to write script will any OS support python SMBUS and python picamera library.