[bpi-r4] nvme+i2c

Beware of NVME M2 key M. In the electrical circuit there is an I2C bus.

I got in trouble for this.

My disk is Miсron 2200 512GB.

As soon as I install it, the entire I2C bus goes down. Not a single device is detected.

I had to cover these 2 pins with Scotch tape to solve this.

5190v7R+GxL.AC_SL1200_1

2 Likes

I still suggest to not populate R228 and R230 in future runs of the board. See also my post:

1 Like

Hi vasya, Sorry, this is our poor consideration, causing you trouble.

These two PINs should be 1.8V, but our design is 3.3V. This may be the reason why your SSD cannot be used.

As Daniel said, remove R228 and R230 will solved this.

2 Likes

This sounds like it can damage ssd,right?

It’s OK. This is why we buy these boards, to make them better together.

By removing the resistors you mean desoldering them, right?

And then the ssd and the i2c bus will work again?

Can you share a picture,where location of these 2 resistors are shown? Or is location same as on v1.0 and i can share this part of assembly pdf?

The two resistors are here, which is the same as in the previous version.

However, because the positions of many other components have been changed, the V1.0 version may cause trouble to other users, so it has not been made public.

Also, this shouldn’t cause any harm to the SSD, I think :smiley:

3 Likes

YES!desoldering them all will work.

Cool, thanks. I will look for a desoldering tutorial and give it a try. :sweat_smile:

Just out of curiosity, what is the purpose of those resistors? And what happens electrically when I remove them? I had some lectures about analog circuits in my studies, but I can’t remember how to read the schematics.

It will not have any issue.

It is not used for SSDs. When we first designed it, we tried some self-defined adapter boards to control/set up through I2C.

Yes i know,but it is the only version i have the assembly file :slight_smile: maybe you can send me assembly file for 1.1 or publish on wiki. But position of these 2 resistors seem same.

Will these resistors removed in future versions (if any planned)?

Done. With a little help I was able to remove those two resistors with a common soldering iron. (I’m so glad it wasn’t the even tinier ones to the right that had to be removed :smiley:)

After that the NVME SSD was still detected, as expected, and the i2c bus was also still visible using i2cdetect.

Though I’d still prefer if there was a version 1.2 though, that doesn’t have them soldered in the first place. :wink:

Edit: that is how it looks after the desoldering. Added the bag with the resistors to show how small they are.

o

3 Likes

The assembly file of V1.1 has been arranged to be put on the wiki. It should be available in a few days.

I noticed that some people reported the PCIe card problem. I will collect more information and test it to see if the hardware needs improvement, and then decide when to modify it.

Imho these are different issues…on one side the i2c issue where removind the resistors fixing it and on the other side the problem with atheros cards like on r64 where tx capacitors (filter signal) were missing and or resistors wrong (voltage limit).

They are indeed two different issuses.

But we only received this feedback that I2C will affects SSD recognition.

Therefore, if the PCIE compatibility issuses can be solved together, the hardware will only need to be upgraded with one version.

Imho ssd is recognized but brings i2c bus down,so sfps are not recognized if ssd is inserted and resistors are still in

1 Like

I tested the Kioxia and it is OK, the SFP I2C can also be used.

It should be that some SSDs will cause I2C bus down.

Because it is not the main topic, I try to make it short: During the last years, I had problems to find out which version of the Board suppliers offer.

It was not clear for me because none of the seller wrote it in the specs description. :melting_face:. I had this problem for R3 and now for R4. I found no single shop offer which mentioned it (Taobao, Aliexpress, Joom)!

Of course, I tried to find out by looking at the picture. Some pictures didn’t have a good enough resolution. I couldn’t recognize the version! And additionally it became clear to me too that there is a possibility that the sellers picture are not true. They may use the first released pictures with V1.0 and sell V1.1 which is bad for their buiseness too because the “knowing people” will not buy there! I also doubted by myself because I thought maybe banana pi sold the first unofficial boards to a third party which is selling them on Alibaba. I think this situation causes a lot of email traffic and takes time away! If you are releasing a 1.2 version of R4 these problems are getting worse :neutral_face:.

My suggestion:

  • please provide good pictures with high resolution for the sellers. The URL should be on the backside of R4 package.
  • extend the nomenclature: for example BPI-R4-V1.2
  • try to make the version number on the PCB as big as possible

Thank you :slightly_smiling_face:

2 Likes

Thank you for your suggestions, I will feed these back to sales and other technical teams.

If have other questions, you can also contact our sales judy ([email protected]), or you can leave your contact information and I will ask her to contact you.