BPI M2Ultra images - problems with each one

Hi there,

I have tested many of the images available for download for the BPI M2U. With all of them I have a specific problem or issue.

1° ARMBIAN hangs at first boot at line 5 or 6 (scanning btfrs (or something)) 2° DEBIAN has no working wireless network connection

3° UBUNTU 16, this does the job with networking and seemed to work just fine. Just until I wanted to install ZULLU JDK…it is probably me but after a week of trying all routes that I can find for installing ZULU…no luckl

4° RASPBIAN, both work buster and jessie seem to work. If there was a lite server-version available then I would probably go for one of them but at this stage I don’t want to spend diskspace on soft- and desktopware that I will never ever use.

Actually I don’t really care about which distro is on the banana but I need at least ZULU JDK11 on it working. Any thoughts?

Regards, Mario

Here they say it’s working:


Hi Igorpec,h

Nice to read from you again (see BPI M2 Ultra -- cant get it up and running nu)

I have never gotten the ARMBIAN up on this board. The only working images were then and now again the UBUNTU server and the RASPBIAN desktop. The board has been working with UBUNTU server for several months without issues. I used it as a sort of homemade NAS.
Now I wanted to migrate my OPENHAB from RAspPi3 to the M2U. Unfortunately I cannot get the ZULU installed (not even from fresh setup) I have a plain ubuntu-laptop were there is no issue installing ZULU from repo or tar. So after more than a week of trail and error. I do believe something is not compatible. That is why I wanted to go to another OS with all the problems/issues described above.

About the ARMBIAN, I saw this thread :Banana pi config? Is it still not supporting the emmc? If that is the case I will not use it because that was just the point why I wanted to migrate from raspberry to banana.

regards, Mario

Armbian works perfectly fine with latest build, boot from emmc, tested: http://ix.io/3n5W https://forum.armbian.com/clients/donations/

Other problems are unrelated to Armbian. https://docs.armbian.com/#what-is-armbian

1 Like

Hello, I last week I made a patch to activate audio in the edge branch, currently I keep that image installed in a sata ssd and starting from mmc with the armbian-config utility

I’m going to upload the image to gdrive and share the link here for you to test it

HI all,

since last week I have only worked on the Raspbian and Ubuntu img(since these are the only ones that work) I succeeded to install Zulu11 on the Raspbian-img and with that knowledge tried the same method to a fresh UBUNTU image(and not the route described on the Zulu website) And guess what …installation successful. Unfortunately now I tumble in some errors at installation of OPENHAB. I will try the ARMBIAN21.08.0 buster…I’m really curious if my board will boot. I will keep you informed.

@juanesf, thanks for all the efforts but I just want to let you know that this image also hangs at first boot at the message "Begin : Running /scripts/localpremount … Scanning for Btrfs filesystems

Just as all my trys with ARMBIAN images so far have done on my BPI 2MU board.

I appreciate yours and @igorpec 's support and I don’t doubt the ARMBIAN images do there job on a million other boards and probably also on most BPI M2U boards…but they don’t work on mine.

I’m going forward with the UBUNTU image and hope to find why the OPENHAB won’t install properly!! If somebody could help me on this one…don’t hesitate. (but than again we are with three on this forum :slight_smile: that is maybe why the board will end up in the bin. I all case this is my first and last bananapi)

regards, Mario