BPI M2 Ultra -- cant get it up and running nu


After having played around succesfully with Raspberry 1,2, 3 and zero I decided to try a BANANA PI M2 Ultra. I recieved it two weeks ago. I’m now at attempt 20 or so with different SD-cards(that work perfectly on raspPi) and with all the images available to get this thing working…no luck so far.

My question: Do I have to use BPI-tools to copy the downloaded image? I’m used to using etcher (or Win32diskimager) but like i said…no luck so far.

When I boot the BPI with a newly burned SD-card the only thing that happens is a quick blue led flashing one’s and then nothing.

I must be doing something wrong…what?

Greats, Mario

I wonder if there is somebody on this forum?

Try this image: https://www.armbian.com/bananapi-m2u/ and use this docs: https://docs.armbian.com/User-Guide_Getting-Started/

Its without support, which means probably nobody will help you in case of troubles, but its wort trying since it most likely works. Remember that not all features are supported, but you should use it for something.

Hi @igorpec,

First of all many thanks for the support. I’ve been playing around with the armbian version but again without succes.

I’m giving it another few trials. If the board won’t start working it wil end up in the bin. If you have other ideas than please!

@igorpec, do you have a banana pi yourself? Does it work? Do you like it?

Did you read everything on that link? SD cards, power supply …

Its one of 200+ boards that I have here in the lab. It worked last time I tried.

Yes, I’m using a SANDISK A1 SD and ran it through SD Formatter. (I normally use GPARTED on Linux) I tried two powersupplies both 5V and 2,1Amp resp 2Amp, both over OTG Tried different USB cables…

I have been trying to set it up headless and connected over ethernet. In other words the only way to see whether it is running is by checking it actually recieved an IP-adres. I can see that the network connecter is blinking during boot but after a while the whole board goes dead. Exept fo the RGB leds that keep on blinking. Unfortunately I can’t find any information on these LED’s in the documentation…in other words I have no idez what the blinking is for.

I have hooked it up to a monitor over hdmi just to be sure that maybe it is waiting for some input on the screen but …no signal over hdmi thoughout the whole boot (and after)

Oh well, I have enough of this. I will try to return it! (lossed my faith in the banana :slight_smile:)

Thanks @igorpec, It was nice to be with us two on this forum…I guess you will be alone again soon.

Grts, Mario

You don’t power via power connector??

I checked this board yesterday and it boots perfectly fine. You are doing something fundamentally wrong - or the board is dead.

Hi Mario, I would never suggest banana pi to anyone,it is one of a worst board.it is having wifi issue. U can check urself.I brought 2 no’s banana pi m2 zero for a project .both had the wifi issue I tried with different OS and all other manual wifi ssid and pwd setting method ,but no use. And if u raise a query to them via mail or forum there tech support is not ready to reply back or help u on the issue.I have mailed more than 3 times ,still I didnt get any reply from them .I was working on a project where I had a requirement for more number of banana pi .after experiencing their customer support .I would suggest not to buy bpi. Their customer support is very worst. they don’t have courtesy to reply to a customer’s problem.its been more than a month.still is no reply.

And coming to the OS there are lot issue with the all versions of their os. If u want to just experience the bpi ,pls follow the link . BananaPi BPI-M2Z(H2+) New Image Raspbian & Ubuntu Release 2018-07-09 for m2 zero

https://drive.google.com/open?id=0B_YnvHgh2rwjR0JsaUltalFXanc for bpi m2 ultra

I went through the same thing, and finally succeeded when I tried Raspbian For Banana PI: http://www.lemaker.org/product-bananapi-download-23.html

The only reason I went with the Banana PI was the SATA port. I wanted to build a NAS Backup “Cloud”. It works fairly well. I use it to back up my Win10 Desktop using SAMBA, and two Raspberry PI test servers. I have a 3T harddrive connected to the SATA port.

And I don’t rely on WiFi [flaky]. I have the Banana wired to the router via Ethernet/CAT-5 through a switch.

Seriously? Using some 6 years old unsupported OS made by another group of amateurs :slight_smile: ?

Rather start with a serious OS and you will be amazed how much faster it will work. And which still receives update.

There is nothing wrong with bpi m2 zero and m2 ultra, please explain in details what is the “wifi issue” you have.

I have ultra bpi m2 connected to my AP which is 20 METERS away. Working well for 60 days. Although there is not much load or wifi traffic through.

 20:55:03 up 60 days, 20:25,  1 user,  load average: 0.22, 0.16, 0.11

It is important to choose the best wifi channel to connect the board to, a good wifi antenna, and choose the best OS with a modern kernel where you can get support and fixes. Start with Armbian and if you have some kernel knowledge you can tune it to get the best performance or experiment with new kernels.

If you can explain your issue in detail someone can try to reproduce it and fix if there is a solution to your problem.

Small boards as BPI M2 Zero are prone to heat the wifi chip when you don’t cool the board right.

1 Like

Hi There, Me again.

I found a PSU with 5 V 3Amp output and that made the BPI M2 Ultra work!

Next problem. I like to work headless and start the system headless. I installed the Debian Jessie lite OS which has SSH enabled but what is the default username and password???

Really hope somebody can help!

Grts, Mario

and then there is me again.

Root / bananapi did the job!

Grts, Mario