BPI-M3 new image:ubuntu-mate-16.04 beta V1.0 2016-04-25


(bpi team) #1

2016-04-25-ubuntu-mate-16.04_Xenial_gpu_mpv_1080p_bt-bpi-m3_beta-sd-emmc.img.zip

BPI-M3 kernel 3.4

  1. BPI-M3 kernel 3.4
  2. username & password: pi/bananapi , root/bananapi
  3. support HDMI 1080P & 720P
  4. support GMAC
  5. support WIFI
  6. support bpi-bootsel cmd can switch to (bpi-m3 & bpi-m2 & bpi-m2p)
  7. support uEnv.txt to fatload script.bin & uImage
  8. support uEnv.txt to set video 1080P & 720P & 480P …
  9. support video play 1080p with vdpau (mpv, vlc, smplayer)
  10. support BT (default off, sudo bpi-bt-on)
  11. support GPU PowerVR SGX544MP (glmark2-es2)
  12. chromuim default turn on webgl (chrome://gpu, modify /etc/chromium-browser/default)
  13. support youtube video play
  14. support flash video play.
  15. support scratch 2.0

Google Drive: https://drive.google.com/file/d/0B6FbwMfcqfFZY0I4SUZ2QlhQYUk/view?usp=sharing

MD5: 887f87dc7ca48dfac65aedcf6547a360

Note: please use 16G micro SD for this image.

chromium support webgl

BT 4.0:


BPI- M3 Ubuntu 16.04 LTS coming soon
H.264 hardware encoding in tvheadend
(Bjørn) #2

Hi @sinovoip , when will we see a newer kernel in the images?

This image has the following services listening on all interfaces by default: sshd, xrdp, minidlnad, apache2, vsftpd. On the loopback interface the following services are listening by default: mysqld, dnsmasq, xrdp-sesman, cupsd.

Also, the image is provided with a lot of obsolete packages. If you really have to provide images, it’s at least good practice to clean up first.

The following packages were automatically installed and are no longer required: apg apt-clone archdetect-deb dpkg-repack fonts-roboto fonts-roboto-hinted geoclue-ubuntu-geoip gir1.2-json-1.0 gir1.2-timezonemap-1.0 gir1.2-xkl-1.0 gkbd-capplet gnome-bluetooth gnome-menus gnome-session-bin gnome-settings-daemon-schemas gnome-user-share indicator-datetime indicator-keyboard indicator-power libatk-wrapper-java libatk-wrapper-java-jni libbind9-90 libcec-platform1v5 libcec3 libck-connector0 libdbd-mysql-perl libdbi-perl libdebian-installer4 libdns100 libept1.4.16 libfstrcmp0 libgeonames0 libgnome-bluetooth13 libgnome-menu-3-0 libgnomekbd-common libgnomekbd8 libhdhomerun1 libisc95 libisccc90 libisccfg90 libjs-iscroll liblockdev1 liblwres90 libmicrohttpd10 libnfs8 libnih-dbus1 libpcrecpp0v5 libpgm-5.1-0 libpinyin7 libpulseeight-platform1 libsctp1 libsodium13 libterm-readkey-perl libtimezonemap-data libtimezonemap1 libunity-settings-daemon1 libzmq3 lksctp-tools mountall os-prober python-colorama python-distlib python-html5lib python-imaging python3-colorama python3-distlib python3-icu python3-pam rdate signon-keyring-extension u-boot u-boot-exynos u-boot-imx u-boot-omap ubuntu-system-service ubuntu-touch-sounds unity-settings-daemon

Also, as expected, the “load above 1” issue is still not fixed.


(bpi team) #3

we need finish all function at first. and optimize code. then everyone can join to help us, let it support for mainline kernel .


#4

Why do I get no display? Can only login remote.

What to do with this tool? It says:

usage: bpi-bootsel v1.0.2
       bpi-bootsel IMGFILE
       bpi-bootsel IMGFILE DEVICE

bpi images:
/usr/lib/u-boot/bananapi/bpi-m2/BPI_M2_720P.img.gz
/usr/lib/u-boot/bananapi/bpi-m2p/BPI_M2P_720P.img.gz
/usr/lib/u-boot/bananapi/bpi-m3/BPI_M3_720P.img.gz

Why do you say 16Gb card is needed when the image is only using 6.9GB? Why isn’t the partition larger?

root@bananapi:/media/pi/BPI-BOOT/bananapi/bpi-m3/linux# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root       6.9G  6.2G  298M  96% /
devtmpfs        750M     0  750M   0% /dev
tmpfs          1006M  236K 1006M   1% /dev/shm
tmpfs          1006M   20M  987M   2% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs          1006M     0 1006M   0% /sys/fs/cgroup
/dev/mmcblk0p1  256M   51M  206M  20% /boot
tmpfs           202M   32K  202M   1% /run/user/1000
/dev/mmcblk1p1  256M   44M  212M  18% /media/pi/BPI-BOOT
/dev/mmcblk1p2  6.9G  3.1G  3.5G  47% /media/pi/BPI-ROOT

Why are that many services running? Why are that much obsolete packages installed? Why does apt-get segfault?

root@bananapi:/media/pi/BPI-BOOT/bananapi/bpi-m3/linux# apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  apg apt-clone archdetect-deb dpkg-repack fonts-roboto fonts-roboto-hinted geoclue-ubuntu-geoip gir1.2-json-1.0 gir1.2-timezonemap-1.0
  gir1.2-xkl-1.0 gkbd-capplet gnome-bluetooth gnome-menus gnome-session-bin gnome-settings-daemon-schemas gnome-user-share indicator-datetime
  indicator-keyboard indicator-power libatk-wrapper-java libatk-wrapper-java-jni libbind9-90 libcec-platform1v5 libcec3 libck-connector0
  libdbd-mysql-perl libdbi-perl libdebian-installer4 libdns100 libept1.4.16 libfstrcmp0 libgeonames0 libgnome-bluetooth13 libgnome-menu-3-0
  libgnomekbd-common libgnomekbd8 libhdhomerun1 libisc95 libisccc90 libisccfg90 libjs-iscroll liblockdev1 liblwres90 libmicrohttpd10 libnfs8
  libnih-dbus1 libpcrecpp0v5 libpgm-5.1-0 libpinyin7 libpulseeight-platform1 libsctp1 libsodium13 libterm-readkey-perl libtimezonemap-data
  libtimezonemap1 libunity-settings-daemon1 libzmq3 lksctp-tools mountall os-prober python-colorama python-distlib python-html5lib python-imaging
  python3-colorama python3-distlib python3-icu python3-pam rdate signon-keyring-extension u-boot u-boot-exynos u-boot-imx u-boot-omap
  ubuntu-system-service ubuntu-touch-sounds unity-settings-daemon
0 upgraded, 0 newly installed, 77 to remove and 11 not upgraded.
After this operation, 90.0 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 240622 files and directories currently installed.)
Removing apg (2.2.3.dfsg.1-2ubuntu1) ...
Removing apt-clone (0.4.1ubuntu1) ...
Removing archdetect-deb (1.117ubuntu2) ...
Removing dpkg-repack (1.41) ...
Removing fonts-roboto (2:0~20160106-1) ...
Removing fonts-roboto-hinted (2:0~20160106-1) ...
Removing geoclue-ubuntu-geoip (1.0.2+14.04.20131125-0ubuntu2) ...
Removing gir1.2-timezonemap-1.0 (0.4.5) ...
Removing gir1.2-json-1.0:armhf (1.1.2-0ubuntu1) ...
Removing gir1.2-xkl-1.0:armhf (5.4-0ubuntu2) ...
Removing gkbd-capplet (3.6.0-1ubuntu2) ...
Removing gnome-user-share (3.14.2-2ubuntu4) ...
Removing gnome-bluetooth (3.18.2-1ubuntu2) ...
Removing gnome-menus (3.13.3-6ubuntu3) ...
Removing gnome-session-bin (3.18.1.2-1ubuntu1) ...
update-alternatives: using /usr/bin/mate-session to provide /usr/bin/x-session-manager (x-session-manager) in auto mode
Removing unity-settings-daemon (15.04.1+16.04.20160209-0ubuntu1) ...
Removing gnome-settings-daemon-schemas (3.18.2-0ubuntu3) ...
Removing indicator-datetime (15.10+16.04.20160406-0ubuntu1) ...
Removing indicator-keyboard (0.0.0+16.04.20151125-0ubuntu1) ...
Removing indicator-power (12.10.6+16.04.20160105-0ubuntu1) ...
E: Sub-process /usr/bin/dpkg received a segmentation fault.

Why don’t you answer bruberg’s question? Why don’t you fix the load issue?


#5

On the first boot this image froze after a couple of seconds. Now it froze again (no leds blinking any more).

Can you recommend a working OS image for M3?


#6

Your images aren’t working. I spent some hours testing through all of them and they fail. Read also through the forums and I got the impression I bought a paperweight. :frowning:

Only OS image running so far flawlessly is this here (not made by you?): BPI-M3 new image:bpi-m3 Ubuntu 16.04 Beta Mate

Will ask Armbian devs now why they do not support M3.

EDIT: Found it: http://forum.armbian.com/index.php/topic/474-quick-review-of-banana-pi-m3/page-2

Too bad you call M3 Banana Pi. Not compatible, worst software, no support.


BPI-M2+ new image:Raspbian Jessie(debian 8) BPI-M2P (20160408)
(bpi team) #7

this is default for BPI-M3, just burn it to SD card or EMMC,it will working.


(bpi team) #8

we know this issue ,this setting is for OTG under linux , if we fixed this issue, many OTG function can not use on linux . now ,on linux ,you can use OTG connect your PC. same as andriod. mikey & DK now check this .


#9

What are you talking? I did that and none of your images worked ok. Either no free space, booting stops, processes crash. Seems you’re so busy releasing new images that you have no time to test.

How should I burn an image that needs 16GB on 8GB eMMC on M3? I’m glad I found this Armbian image in another thread. Resized automatically to eMMC size after burning :slight_smile:

Sorry? What are you talking? Who are ‘mikey & DK’? Should I know them?

Is this really the official Banana Pi support channel?


(bpi team) #10

Only OS image running so far flawlessly is this here (not made by you?): BPI-M3 new image:bpi-m3 Ubuntu 16.04 Beta Mate

victor is banana pi leader :slight_smile: but this image is not support GPU&1080P&BT.

.


#11

Hu, what are you talking about all the time?!

I spoke about tkaiser’s Armbian image. That’s the only one that worked for me and now I don’t want to try out anything from any victor, DK, mikey or whoever you think I should know.

By reading through this forum I already got the idea what to expect from you… unfortunately.


(bpi team) #12

i know what you say ,but armbian not support BPI-M3 now.


#13

Do you read the threads you link to? Can you explain to me why it looks like this when I use this image:

 ____                                  ____  _   __  __ _____ 
| __ )  __ _ _ __   __ _ _ __   __ _  |  _ \(_) |  \/  |___ / 
|  _ \ / _` | '_ \ / _` | '_ \ / _` | | |_) | | | |\/| | |_ \ 
| |_) | (_| | | | | (_| | | | | (_| | |  __/| | | |  | |___) |
|____/ \__,_|_| |_|\__,_|_| |_|\__,_| |_|   |_| |_|  |_|____/ 
                                                              

Welcome to ARMBIAN Debian GNU/Linux 8 (jessie) 3.4.39-BPI-M3-Kernel 

System load:   0.06            	Up time:       17 hours		
Memory usage:  12 % of 2011Mb 	IP:            192.168.178.21
CPU temp:      67°C           	
Usage of /:    47% of 6.9G

PBI-M3 new image:ubuntu-mate-16.04-desktop-armhf-raspberry-pi-bpi-m3-sd-emmc.img 2016-07-21
#14

Hey: this is the best image to this day. Your are getting better:laughing:. Worked for me out of the box in FullHD. Audio jack issue is still there, just let some staff fiddle with alsamixer as I told you in December 15 on the ubuntu 15.10 download page…

Update: For one year, I updated this image regularly, now on chromium 55 and flash player 20, works well. So, take this image, remove clutter (sudo apt-get autoremove) and let the system update do its work. If you want flashplayer 20 for arm, google helps or ubuntu mate for raspi information in the welcome MATE screen.

Update: Working audio jack alsa setting were published here:

Update: Bluetooth, see post below. Don’t use that fancy script bpi-bt-on :wink:


BPI-M3 new image:debian-8-jessie-mate_gpu_mpv_1080p-bpi-m3 beta V1.0 2016-4-27
#15

Good news on the Bluetooth and A2DP front, hifi lovers now should be able to connect their devices. I wrote a script and published it on github. Please check this, I have tested it successfully with UE Roll bluetooth speaker: