PBI-M3 new image:ubuntu-mate-16.04-desktop-armhf-raspberry-pi-bpi-m3-sd-emmc.img 2016-07-21

Do you have any cards that have not been touched with win32diskimager?


no, all my card have been used with win32diskimager. until now, i have always used this software.


i have the same problem. I cant boot any OS except Andoid. I use an 2.1 Amp Power Supply. I burnt the images with Win32 Disk Imager. I burnt Android with Phoenixcard and its work. But every OS i burnt with Win32 Disk Imager it never boot up. I can only see shortly the bpi Screen at the beginning. Pls can u help me

Greetz kapiusers

Look at all the hints and tips in this thread, and also check this thread. If you can’t figure out what wrong with all of that, I might be able to make something out of your u-boot output. Other than that, I can probably not help you.

Hello, i have installed the image and after apt update && apt upgrade it shows the following error … fontconfig (2.11.94-0ubuntu1.1) wird eingerichtet … Regenerating fonts cache… failed. See /var/log/fontconfig.log for more information. dpkg: Fehler beim Bearbeiten des Paketes fontconfig (–configure): Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück Fehler traten auf beim Bearbeiten von: fontconfig E: Sub-process /usr/bin/dpkg returned an error code (1)

/var/log/fontconfig.log … /usr/share/fonts/type1: caching, new cache contents: 0 fonts, 1 dirs /usr/share/fonts/type1/gsfonts: caching, new cache contents: 35 fonts, 0 dirs /.local/share/fonts: skipping, no such directory Re-scanning /usr/share/fonts: fc-cache: symbol lookup error: fc-cache: undefined symbol: FcDirCacheRescan

This Thread

didn’t solve the problem


sd full? df -h


Do you have any link to download “Phoenixcard” English version for Windows 10? I have tried two different version of Phoenixcard provided on bpi’s manuals; but none of them is working in windows 10. No response while trying to execute an application file.

Please help me out guys. Language of software does not matter, as long as I can execute the software.

We really need an open source version of that utility. Alas, this is not the right place to ask for it :frowning:


I have same problem too. And, I can not solve this problem.

https://androidmtk.com/download-phoenixcard-tool <-- The 3.1.xx version.

This one works for me on Windows 10. The “product” mode is not working with the M3 (or it seems so, I only tried with an android image, it shows the animation while “flashing”, then stops. ). The startup mode works.

Hello, Thank you for the image. I would ask twoo question.

  1. How can I connect with a BT keyboaurd to the integrated interface?
  2. The WiFi doesn’t work smoothly. It disconnects and reconnect periodically. Is it somethong setup or software error?

And a third one. I have a Waveshare 5inch HDMI (B) lcd. Unfortunately with firmware 1.1. Is there a driver or any trick to use this?


Hi everyone. I’ve successfully installed this ubuntu on my sd card. It’s running and all, but in the terminal i cannot do stuff, because i don’t know the password. I’ve tried everything that came into my mind, especially ten thousands times “bananapi” (without “”), copy pasting even the password, but still i get for “pi@bananapi:~$ passwd:”: passwd: Authentication token manipulation error passwd: password unchanged

Some help would be really appreciated… I’m a total noob at linux stuff…

EDIT: Nevermind, I’ve swapped to Debian, it works fine now, yay.

I soved it

cp /usr/lib/arm-linux-gnueabihf/libfontconfig.so.1.9.0 /usr/local/XSGX/lib/libfontconfig.so.1.8.0

Dear guys,

when I check OTG, it is not work.

firstly, I used script.bin.otg with modified uEnv.txt. secondly, I modifid sys_config.fex and made script.bin. [usbc0] usb_used = 1 ;change USB0(microusb) from OTG to host only ;usb_port_type = 2 ;usb_detect_type = 1 usb_port_type = 2 usb_detect_type = 1

All of case is not worked.

What is the probem ?

Hello, I have problems with the sound: first: I can not change volume second: I can not set the hdmi audio sounds preferences doesn’t react to changes Thanks

Burned this image with gnome-disks in ubuntu 14.04 Bluetooth (no adapter found) and regular sound not working at all (HDMI, jack: no devices)

1080 works via uEnv.txt glmark2 Score: 270

The debian jessie image

worked better for me and finally I went back to the start: works best out-of-the box.

For headless server endeavors (and more with minimal memory foorprint !) I recommend DietPi, it compares better and quite comfy as a server to Raspian Light: Diet vs Rasp

Can who send compiled modules: /lib/modules/3.4.39-BPI-M3-Kernel/kernel/sound for this image? I try build from https://github.com/BPI-SINOVOIP/BPI-M3-bsp but after copy compiled modules from /sound to BPI is wrong:

root@bpi-iot-ros-ai:/# insmod /lib/modules/3.4.39-BPI-M3-Kernel/kernel/sound/usb/snd-usb-audio.ko

insmod: ERROR: could not insert module /lib/modules/3.4.39-BPI-M3-Kernel/kernel/sound/usb/snd-usb-audio.ko: Invalid module format

root@bpi-iot-ros-ai:/# dmesg | tail -n1

[20555.539515] snd_usb_audio: disagrees about version of symbol module_layout

I solved my problem. Instruction: How to : Use bpi-update command to update kernel image


Maybe this helps :wink: