Raspian-Jessie & Ubuntu Mate: Could'nt find emmc device

Hello, I was able to install and boot the linux images that are being offered (2016-07-21-ubuntu-mate…, 2016-07-13-raspbian-jessie…) successfully by using a sd-card. But in all of my tries the transfer to the internal emmc flash memory failed. I couldn’t find any emmc-device (neither jessie nor ubuntu)! fdisk -l or lsblk showed only /dev/mmcblk0 (my sd-card) and its partitions (mmcblk0p1, mmcblk0p2). Is there a way to fix this? Thx

They use wrong settings. They simply copied everything from Pine64+ and so it’s no wonder that some things don’t work. Seems to apply to Wi-Fi too according to CNX: http://www.cnx-software.com/2016/07/12/bpi-m64-development-board-is-the-first-64-bit-banana-pi-board/#comment-536767

Oh, that’s pretty bad. I tried iwconfig and no wireless extension came up. Not even a kernel module for Broadcom was visible with lsmod. So it really seems that some important hardware of the board isn’t working with the images provided. What next? Try to send back the faulty stuff to Aliexpress or better being patient and wait for some updated images?

Can you use a TTL uart and log a boot without SD card inserted? Ouch, sorry, i mean if you can flash Android onto eMMC someway.

Without SD card inserted I wasn’t able to log anything. Blank Screen… With SD-Card I recieved the following log:

bootlog_bpi-m64.txt (13,6 KB)

Sorry, so far I haven’t any experience with android on bpi-m64.

There has been some improvement, eMMC is usable as storage device at the moment.

Read: https://forum.armbian.com/index.php/topic/3169-request-for-banana-pi-m64/?p=23560

I have the same problem, what should I do?

I am about to finish / testing the installation instructions, will release it today hopefully. You can monitor this:

I just finished initial instructions, please try and see if it works for you.


After you install the image and verify that it works, you can install MATE typing: sudo apt-get update sudo apt-get dist-upgrade sync sudo apt-get install ubuntu-mate-desktop

I just finished installation. After inserting SD card and bootting I don’t see any LXDE. Trying tipe startx - errror, comand not found. And about LAN, DHCP realy works and the speed is fine, I can ping my router and desktop, but I cannot ping any Internet IP adr. And when I’m trying to get update like “sudo apt-get update” - nothig appears, only tiping “apt-get update” without “sudo”, it tryes to start update, but cannot resolve the host.

Please, check the troubleshooting section: https://github.com/avafinger/bpi-m64-firmware#troublehooting

This symptoms is typically described when you have a bad SD CARD. Please, get another SD card, 16GB preferable , find a good and trusted brand and start over following instructions verbatim.

And make sure you:

I’m not using DVI to HDMI and my monitor is 1080P60 capable. SD Card 16Gb is Brand New 10 Class and I have another SD Card also 10 Class 32Gb. On both SD Cards - the same errors. Also I’m using PSU 3A 5V.

Can you print a complete boot log? If you can attach a TTL debug and grab the complete boot log we could then analize and try to help.

Counterfeit SD cards are also Brand new SD cards.


Please try to run flash_sd.sh /dev/sdX appended with ’ 2>&1 > log.txt (without the quote) and use gist or pastebin to show the log

flash_sdcard seems to be OK.

If you can attach a TTL serial debug and grab the complete output would help to find what went wrong. Sorry, with this image i could not see where the problem is.

Check if Xorg has tried to start, see the contents of: cat /var/log/Xorg.0.log

start LXDE again with: startLXDE and print cat /var/log/Xorg.0.log

Update: seems you are on Ram disk only, kernel has not been loaded. Still thinking you have SD CARD issues.

Can you make Image of your firmware?

I will try to make image if i can. i am afraid of doing a ‘dd’ to SD CARD and that possibly will not work for the same reason.

Please, try to clone the files again (the scripts were fixed recently), try with a new/different SDHC card reader (if possible) and start over again. There are some BAD SDHC card reader out there and will trash your trusted SD CARD.