PBI-M3 new image:ubuntu-mate-16.04-desktop-armhf-raspberry-pi-bpi-m3-sd-emmc.img 2016-07-21


  1. based on ubuntu 16.04 mate from https://ubuntu-mate.org/download/
  2. BPI-M3 kernel 3.4
  3. username & password: pi/bananapi , root/bananapi
  4. support HDMI 1080P & 720P(default)
  5. support eMMC
  6. support GMAC
  7. support WIFI
  8. support SATA
  9. support bpi-bootsel cmd can switch to (bpi-m64 & bpi-m3 & bpi-m2 & bpi-m2p & bpi-m1-m1p-r1)
  10. support uEnv.txt to fatload script.bin & uImage
  11. support uEnv.txt to set video 1080P & 720P & 480P …
  12. support power max. up to 2.5A ~ for DC-IN.
  13. fix rootmydevice issue
  14. support video play 1080p with vdpau (mpv)
  15. support GPU PowerVR SGX544MP (glmark2-es2)
  16. support BT (default on, command only, can hcitool scan)
  17. support nodejs
  18. support node-red
  19. thanks to ubuntu-mate.org

google drive:

MD5: ef066f2bd78eeadbf7b2675197d3124d

note : this image is from ubuntu 16.04 for raspberry pi version ,we let it support banana pi. support mali GPU and powerVR gpu function.

So, can anyone tell me where I can find the sources for this build? I wanna play around with them to tweak to my own taste.


doesn’t work for me. Auto power off at boot up. Tried on several memory card with more than 8 gb.

maybe i do something wrong.

Is your board getting enough power? I’ve seen mine in reboot loops because the power supply was insufficient to power up all cores in one go.

i think yes. I use à 2.5A power supply. That work well with older images downloaded.

Hm, that really should suffice. I occasionaly use a lab power supply and the amperage never goes over 1A with this image (I tried it out twice). Soo, that looks like you may have a faulty image or suffer from recurring bad media. Or there’s a problem with the hardware writing the image to media for you. What you might try is to check the checksum of the downloaded zip image (with “md5sum </path/to/image>”) to what’s here at the top of the page. And if that checks out, generate an md5sum of your unzipped image (you did unzip it did you?) and then md5sum your media with: dd if=/dev/<your media root partition> bs=1M count=7456 | md5sum - Mind you, that will take a while, depending on how fast your card and card reader are. And then check if those last two match up.


Thank you for your help.

For the MD5 of the Zip file, it’s OK. For the unzipped file (image), i obtain this MD5 : 29d58237686680f916b7a78eef39549c For the MD5 of the media, i obtain : 0a68e45007fdab89ccf461d45c6f3d2b

I have tried with two SD card.

Okay, I just checked this here for myself. Looks like your card is the problem. I copied the image to a card I’ve used for a custom install image and did the same I told you to do. And the card yielded the same md5sum as the unzipped image file (same md5sum as you got off your unzipped file).

So, that leads me to the question as to how (with which command(s)) you copy the image to your sd card? For me, I used (as user root): dd if=2016-07-21-ubuntu-mate-16.04-desktop-armhf-raspberry-pi-bpi-m3-sd-emmc.img bs=1M of=/dev/sdc Which ends with printing out: 7456+0 records in 7456+0 records out 7818182656 bytes (7.8 GB) copied, 275.051 s, 28.4 MB/s

I use Win32DiskImager on win 7. Maybe it not work correctly.

I will try with ubuntu. If it works I’ll let you know.

I try this : sudo dd if=2016-07-21-ubuntu-mate-16.04-desktop-armhf-raspberry-pi-bpi-m3-sd-emmc.img bs=1M of=/dev/mmcblk0

And i have this on result : 7456+0 enregistrements lus 7456+0 enregistrements écrits 7818182656 bytes (7,8 GB, 7,3 GiB) copied, 775,056 s, 10,1 MB/s

But same problem. Auto shut down after 3 seconds (bpi logo screen)

And the md5sum of the card? If you still don’t get 29d58237686680f916b7a78eef39549c then I’m afraid your card(s) is(/are) defective or somehow incompatible.

This time i have à new MD5: 7456+0 enregistrements lus 7456+0 enregistrements écrits 7818182656 bytes (7,8 GB, 7,3 GiB) copied, 527,64 s, 14,8 MB/s 4ea5788eab3542609b2f74625fc90088

It’s strange, my two cards are defective or incompatible. Until now the other release works fine with this cards.

I will try with older release

I had someone in another thread using win32diskimager and it might be he also somehow broke his SD card for the BPi. But the jury is still out on this…


I have tried with 7 different images, on 3 different SD cards. Copied with ‘dd’ or ‘win32diskimager’. None has functioned.

Perhaps my BPI is defective, or they are my 3 cards. For information, the MD5sum cards do not match to the MD5sum image.

I tried to do a low level format on the cards, with no result.

My cards work correctly on other devices. And this cards work well with my BPI in the past (several image tested).

I no longer see what to do. Someone there an idea?

Do you have any cards that have not been touched with win32diskimager?


no, all my card have been used with win32diskimager. until now, i have always used this software.


i have the same problem. I cant boot any OS except Andoid. I use an 2.1 Amp Power Supply. I burnt the images with Win32 Disk Imager. I burnt Android with Phoenixcard and its work. But every OS i burnt with Win32 Disk Imager it never boot up. I can only see shortly the bpi Screen at the beginning. Pls can u help me

Greetz kapiusers

Look at all the hints and tips in this thread, and also check this thread. If you can’t figure out what wrong with all of that, I might be able to make something out of your u-boot output. Other than that, I can probably not help you.

Hello, i have installed the image and after apt update && apt upgrade it shows the following error … fontconfig (2.11.94-0ubuntu1.1) wird eingerichtet … Regenerating fonts cache… failed. See /var/log/fontconfig.log for more information. dpkg: Fehler beim Bearbeiten des Paketes fontconfig (–configure): Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück Fehler traten auf beim Bearbeiten von: fontconfig E: Sub-process /usr/bin/dpkg returned an error code (1)

/var/log/fontconfig.log … /usr/share/fonts/type1: caching, new cache contents: 0 fonts, 1 dirs /usr/share/fonts/type1/gsfonts: caching, new cache contents: 35 fonts, 0 dirs /.local/share/fonts: skipping, no such directory Re-scanning /usr/share/fonts: fc-cache: symbol lookup error: fc-cache: undefined symbol: FcDirCacheRescan

This Thread

didn’t solve the problem


sd full? df -h