BPI-M3 new image:Debian-8-jessie-mate-gpu-bpi-m3-sd-emmc.img 2016-5-16


  1. BPI-M3 kernel 3.4
  2. username & password: pi/bananapi , root/bananapi
  3. support HDMI 1080P & 720P(default)
  4. support eMMC
  5. support GMAC
  6. support WIFI
  7. support SATA
  8. support bpi-bootsel cmd can switch to (bpi-m3 & bpi-m2 & bpi-m2p)
  9. support uEnv.txt to fatload script.bin & uImage
  10. support uEnv.txt to set video 1080P & 720P & 480P …
  11. support power max. up to 2.5A ~ for DC-IN.
  12. fix rootmydevice issue
  13. based on armbian rootfs, thanks for armbian
  14. support GPU PowerVR SGX544MP (glmark2-es2)

Google Drive:

MD5: 14fd10f8985b2882269128f9bdd6d100

1 Like

Hello, great job!, it runs smoothly in sd and emmc. Is there any way to run Kodi in this or in another linux image?


kernel 3.4, we not plan to run kodi on it now . it is a hard work.:slight_smile:

It works fine, thanks. I had to install dmz-cursor-theme package to fix mouse cursor issue.

How i can chance the resulution to HDMI 1080P? Do you have a Terminal Code for me? Thanks for help :slight_smile:

Just comment-and-uncomment the lines that defines the resolutions in the file /bananapi/bpi-m3/linux/uEnv.txt of the boot partition.


I have burned this into 32gb SD. When i turn my bpi-m3 on then the green, blue and red led go on. Banana pi logo get displayed on the screen via direct hdmi connection. few seconds later the screen become black and the leds green and blue turn off, but the red led remain on then again banana pi logo get displayed on the screen and the green and blue leds also turn on. It get keep doing that… please help me…

You have a BPi M3 from the first batch with Micro USB for DC-IN? Welcome to the club, your issue is called under voltage!

For a solution read through the link and look a few posts before. You need a hardware fix (ultra short USB cable with low resistance might be enough)

i just want tell you ,our R&D all use BPI-M3 with micro USB adapter to do development. :joy:

@annax: This is what the vendor feels if he hears that another user ran into the Micro USB trap. Unfortunately @sinovoip is simply not able to understand that Micro USB encourages users to use insufficient PSUs and crappy cables. The problem is less the connector itself but the stuff between connector and PSU and most often the PSU (crappy phone chargers or ‘smart chargers’ for example will limit their output to 500mA which can also lead to the problem you’re running into).

The whole problem is well known since ages but @sinovoip doesn’t give a shit as usual and laughs about customers running into this problem. Or maybe @sinovoip is really not able to look at his products from a customer’s perspective?

you are not a customer . so you can go away.

Hi and thanks everybody,

tkaiser, the usb charger from apple have this information printed:

Output 5.1v , 2.1a

the BPI-M3 i have does have micro power option and dc power option. I have tried to install Ubuntu Mate 15.10 from here: http://bananapi.com/index.php/download?layout=edit&id=90 and it worked with the same micro usb power… i’m lost and dont understand why it does not work when i use the images on this website. I bought 7 BPI-M3 and now i feel i cant use them so i have lost a lot of money.

you need use ubuntu 15.10 ??? we have optimize power management code at later image , maybe we need update a new image for ubuntu 15.10.

or you can test other image ?? NOTE: do not use OTG port to power BPI-M3,maybe power not enough

That image is quite old, they made a couple of fixes in the meantime that affect both power requirements as well as consumption peaks. And as already written: check the gauge rating of your USB cable. You need AWG24 or less otherwise resistance is too high which leads to voltage drops when load increases (load peaks): Look at these tables to get the idea: http://goughlui.com/2014/10/01/usb-cable-resistance-why-your-phonetablet-might-be-charging-slow/

In case you use now the USB OTG port (Micro USB) try to use the barrel plug instead.

1 Like

You’re too funny! He said that this old image works. In case you update that it won’t work for sure. You really aren’t able to understand the needs of your customers. And you’re the responsible support muppet here. It’s unbelievable :slight_smile:

No sinovoip, i needed Debian 8, but it did not work like i have described above so instead i have tested ubuntu 15.10 and it worked. I already have tested all your images and the same problem happens on them. I’m going try to not use OTG port, but the other port use small dc input which i dont have around at moment.

Yes tkaiser the image is not the newest, but i was almost forced when there is no other options that worked…i’m going test the barrel plug and report back when done how it went.

Thanks to both of you :slight_smile:

sorry , i make a mistake.


what image are you use ???, we will help you to fixed this issue.

I’m using this image: Debian 8 Mate(GPU 1080P) which you can download from here: http://www.banana-pi.org/m3-download.html and also this page.

This will work for sure (just added an explanation to the wiki). And then you run into the next round of issues called ‘software’ :wink:

But that’s a different story and if you’re smart and looked through the BPI-M3 forum here you already know what to expect :slight_smile: