How to Install/Port WiringPi

I have look into LeMaker and WiringPi and BPI-WiringPi. can’t find a compatible version.

now i can’t test if GPIO is working on BPI-M64.

We’ll support wiringpi to BPI-M64 as soon as possible.

Hello *. any news about wiringPI for M64?

I tried to activate via /sys/class/gpio … root@bpi-m64:/sys/class/gpio# echo 29 > export

root@bpi-m64:/sys/class/gpio# ls -al gpio29/direction -rw-r–r-- 1 root root 4096 May 11 03:41 gpio29/direction

root@bpi-m64:/sys/class/gpio# echo out >gpio29/direction -su: echo: write error: Unknown error 517

Linux bpi-m64 3.10.102 #2 SMP PREEMPT Sat Jan 28 19:29:56 BRST 2017 aarch64 aarch64 aarch64 GNU/Linux Linux version 3.10.102 (ubuntu@apps) (gcc version 5.4.1 20160904 (Ubuntu/Linaro 5.4.1-2ubuntu1~16.04) ) #2 SMP PREEMPT Sat Jan 28 19:29:56 BRST 2017

could anybody help me to find a solution ?

Problem is solved. I found out the port addresses Examble: CON2-P40 = Function2: GPIO ==> PL8

L = 12.character in alphabet
( 12 - 1 ) * 32 = 352
 352 + 8 = 360

 echo 360 >/sys/class/gpio/export
 echo out >/sys/class/gpio/gpio360/direction
 echo 1 >/sys/class/gpio/gpio360/value

we have update wiringpi on github ,it support BPI-M64, please test it .

Hello *,

sorry, but it doesn’t work :frowning: download and compile

root@bpi-m64:~/wiringPi/gpio# ./gpio -v gpio version: 2.44 Copyright © 2012-2017 Gordon Henderson This is free software with ABSOLUTELY NO WARRANTY. For details type: ./gpio -warranty

Unable to determine hardware version. I see: Hardware : sun50iw1p1 ,

  • expecting BCM2708, BCM2709 or BCM2835. If this is a genuine Raspberry Pi then please report this to [email protected]. If this is not a Raspberry Pi then you are on your own as wiringPi is designed to support the Raspberry Pi ONLY.

root@bpi-m64:~/wiringPi/wiringPi# cat /proc/cpuinfo Processor : AArch64 Processor rev 4 (aarch64) processor : 0 processor : 1 processor : 2 processor : 3 Features : fp asimd aes pmull sha1 sha2 crc32 CPU implementer : 0x41 CPU architecture: AArch64 CPU variant : 0x0 CPU part : 0xd03 CPU revision : 4

Hardware : sun50iw1p1

I am facing same issue , downloaded and installed wiring pi but it says unable to determine board revision from /proc/cpuinfo , How to fix this issue?

I also have the same issue for BPI-R2.