HDMI BPI-Zero Not Working

I recently purchased the Banana Pi Zero. I used Etcher to flash this image: BPI-M2+ new image:ubuntu-16.04-mate-desktop-beta-bpi-m2p-sd-emmc-2017-07-14 onto the SD card. I am using a mini-HDMI to HDMI adapter that I know works (as I tested with another device). However, when booting up the Banana Pi, I can only get a No signal from the monitor. Any ideas?

Try this image (is more new) , and read this : Android for banana pi m2 zero imagem not boot (fix problem boot) (resolved) , this : Android for banana pi m2 zero imagem not boot (fix problem boot) (resolved) and this H3Droid Android development on allwinner H3 chip project .

I’m having this issue on mine, the red light just stays solid. I wrote the image, powered on, nothing showed on screen. After about 20 tries I had two successful boots. Retropie Jessie was the only one to boot at all, but I haven’t been able to get a signal since. I wrote this to the two other sd cards just now and still no hdmi signal. I also tried Ubuntu Xenia but it never booted.I also tried other various armbian distros for the BPI M2 chipset, not specific to the zero.

The device does appear to be running, the light starts dim and gets a little brighter after a few seconds, the chip generates heat, I just cannot get any video out other than those one or two boots sometime yesterday. 50 tries and 5 distros installed on 3 cards later and I still haven’t gotten a signal. The cables all work as I have a PiZero that each cable works on without issue.

Any ideas?