BPI-M2+ new image:ubuntu-16.04-mate-desktop-beta-bpi-m2p-sd-emmc-2017-07-14


  1. based on ubuntu 16.04.2 LTS Mate Desktop
  2. support BPI-M2+ kernel 3.4
  3. username & password: pi/bananapi , root/bananapi
  4. support HDMI 1080P & 480P & 720P (default)
  5. support GMAC
  6. support WIFI
  7. support BT (with bluetoothctl can setup)
  8. support UART
  9. support I2C
  10. support eMMC (support boot from eMMC)
  11. support IR (getevent can test) 11 support power key (getevent can test)
  12. support OTG & adbd (default off)
  13. support CAMERA ov5640 (guvcview / cap / ffmpeg-3.2.1 support video H.264 hw encode)
  14. support uEnv.txt to fatload uImage
  15. support bpi-bootsel to set HDMI (720P & 1080P & 480P)
  16. support bpi-copy to write SD/eMMC with img.zip file
  17. support video play 1080p with vdpau (mpv)
  18. support wiringpi 2.44 (https://github.com/BPI-SINOVOIP/WiringPi , thanks to http://wiringpi.com/ & https://github.com/WiringPi/WiringPi
  19. support rpi.gpio 0.6.3 for python (https://github.com/BPI-SINOVOIP/RPi.GPIO ,, thanks to https://sourceforge.net/projects/raspberry-gpio-python/
  20. Thanks for linux-sunxi community (http://linux-sunxi.org/
  21. Special thanks for Alex support with camera functions (https://github.com/avafinger

Google Drive:

baidu cloud:


MD5: 036bb7a88c7dd06c5d41e50f1538a6fa

how do you start GUI? when loaded from SD card it never loads on GUI, already tried the following:

sudo systemctl enable lightdm

and reboot;

echo “/usr/sbin/lightdm” | sudo tee /etc/X11/default-display-manager > /dev/null

and reboot;

sudo dpkg-reconfigure lightdm

and reboot

I tried the image, The CPU frequency is locked between 648Mhz to 720Mhz. no matter which CPU governor is chosen.

I tested with “userspace”, “performance”, “interact” , all the same, CPU has 720Mhz as maximum frequency.

hi everyone i downloaded this image. the size of “.img” file is 7.28 but my sd card is 7.21 what should i do to boot this image on my sd i use win 10 in my laptop and i have a bpi m2+ thanku

Received a little Banana Pi Zero UMPC with this image installed on a 32GB microSD card.

Works well overall, but no ethernet LAN support.

Would be great to have ethernet support so I can connect to network that way with my USB ethernet adapter. It uses ASIX AX88179.

Is there a way to add it to this image or do we need an updated image?