Frequent freeze-ups of M2U

Come on, hopefully a kernel update will fix this right? I bought this board so I can had a 24/7 NAS box . Raspberry Pi3 is rock solid but has slow network connection :frowning:

Do people here think a kernel fix will sort this out or is it a hardware issue?

Seems that small voltage tweak could resolve this issue. I’ve increased dcdc2_vol, dcdc3_vol, dcdc4_vol and dc5ldo_vol and set dram frequency at 480 MHz. Memtester does not show any errors anymore and it is stable running memtester + cpuburn for 1 day. Still in progress of finding minimal voltage changes which would make it possible to run at DRAM full speed.

!DISCLAIMER! Changing voltages could physically damage your device and probably will void your warranty. Be extra careful changing any voltages of frequencies and do it at your own risk. This change do lead to some rise of chip temperature. Voltage default working dcdc2_vol 1001160 1001280 dcdc3_vol 1001100 1001150 dcdc4_vol 1100 1160 dc5ldo_vol 1100 1200 dram_clk = 480

Hi, I have got a new BPI M2U and memtest works fine (it will see in next several days), so I think that our problematic M2U are waste. :frowning: So what can we do with that? It was bought on Aliexpres. I hope for my money return.

It works with dram frequency up to 648 Mhz with those voltage adjustments for 2 days now, no signs of memory corruption. Both BT and WiFi is on, memtester + cpuburn + iperf (GbE + WiFi) + dd to continiously read mmc + BT to continuously read from phone. Seems that this issue is closed.

Hello, I’m new here. Can you here write please where and how to set this values? Thank you very much. Sorry for my English.

Hi! First of all you should check that your board have the same issue with memory corruption. Get any system image, like 2017-01-20-debian-8-jessie-lite-beta3-bpi-m2u.img.zip from this post: BPI-M2 Ultra new image:ubuntu-16.04.1-mate-desktop-preview3-bpi-m2u-sd-emmc.img 2016-11-29 . Install it as usual, install memtester package ("sudo apt install memtester"), check memory with "sudo memtester 1000M 10" and see that you really have failed tests.

!DISCLAIMER! Changing voltages could physically damage your device and probably will void your warranty. Be extra careful changing any voltages of frequencies and do it at your own risk. This change do lead to some rise of chip temperature.

If you do have memory corruption you can compile a new kernel (for instance [quote=“avaf, post:11, topic:2823”] dan-and ( https://github.com/dan-and/BPI-M2U-bsp ) kernel 3.10.104 [/quote]) with corrected sys_config.fex at the desired configuration. For 1080p HDMI video output it would be /trunk/target/allwinner/azalea-m2ultra/configs/BPI_M2U_1080P/sys_config.fex. you should change [power_sply] and [dram_para] sections:

[power_sply]
dcdc1_vol                  = 1003300
dcdc2_vol                  = 1001280
dcdc3_vol                  = 1001150
dcdc4_vol                  = 1160
;dcdc5_vol                  = 1500
aldo1_vol                  = 2800
aldo2_vol                  = 1001500
aldo3_vol                  = 1003000
dc1sw_vol                  = 3000
dc5ldo_vol                 = 1200
dldo1_vol                  = 3300
dldo2_vol                  = 3300
dldo3_vol                  = 3300
dldo4_vol                  = 2500
eldo1_vol                  = 2800
eldo2_vol                  = 1500
eldo3_vol                  = 1200
gpio0_vol                  = 3300
gpio1_vol                  = 1800

[dram_para]
dram_clk      = 480

This kernel could be cross-compiled for M2U arm from any regular x86 Ubuntu or other linux installation ( more info here https://github.com/dan-and/BPI-M2U-bsp/blob/master/REQUIREMENTS.md ). Just run ./build.sh at the bsp source root, choose 1, then 6 and you’ll have compiled images at ./SD. Copy them to your M2U Linux installation and use bpi-bootsel to apply them to your system.

Hi, looking for his new beta 3 of Debian mentioned. Went to the link and it’s still the old November release. Has anyone got the link?

Debian beta3 is available at google drive link from this post [BPI-M2 Ultra all image] google download link

Thanks Pavel. I’ve clicked on that link before, and when I checked again, the last updated image was in December, I just can’t see the file you mentioned… 2017-01-20-debian-8-jessie-lite-beta3-bpi-m2u.img.zip Will check on my PC at home tonight. Is that the IMG you are using? How are you finding your M2U?

Click on the link inside the post - https://drive.google.com/open?id=0B_YnvHgh2rwjR0JsaUltalFXanc . The last file is 2017-… .I’m using 2016-11-29-ubuntu-16.04.1-mate-desktop-preview3-bpi-m2u-sd-emmc.img.zip with the kernel from

Now with voltage tweak it is rock solid. Only 2 problems left: HDMI issue HDMI outout shift/corruption of first 4 lines and MALI GPU driver installation.

Seems my Google drive on Android doesn’t show the 2017 file, but on PC it does. Just downloading that. I have Ubuntu Mate 16.04 installed on an SD card.

I’d like to install the same dan-and kernal as you, but am completely new to this as I don’t use Linux. Can you break down the steps, into really clear steps once you’ve followed the requirement.md information. I am assuming it the compiled Kernel can be installed while using the m2u ubuntu mate image?

Just want a stable kernel / image so i can run my NAS and connect to a SATA HDD.

Appreciate all your help.

Yes, you could use that kernel with ubuntu-mate. I’ve uploaded precompiled bootloader, kernel and modules to https://www.dropbox.com/sh/3wj2924ut00qqra/AABrZwIdf0DQpixaNdPoUwS5a?dl=0 . You could unpack them and use bpi-bootsel to choose which resolution to use. My M2U is now stable for 19 days: 22:17:40 up 19 days, 21:21, 1 user, load average: 5.53, 5.48, 5.49

Thank you very much Pavel. I’ve just downloaded all 3 files. I’ll look around for documentation on how to unpack and use bpi-bootsel to choose this kernel and bootloader. I read on armbian forum that people are working on the kernel code also

https://forum.armbian.com/index.php/topic/2884-the-new-banana-pi-m2-ultra/

UPDATE

OK, i’ve copied the files across into a directory, and had a look at boot-sel. When I run it, it shows a list of images in the /usr/lib … directory. I don’t know how to select all 3 files so they are selected and installed as default. Can you help?

UPDATE 2

I did it ! (I think)

Welcome to Ubuntu 16.04.2 LTS (GNU/Linux 3.10.104-BPI-M2U-Kernel armv7l)

Copied the files you shared into the update_file folder that bpi-tools uses as is suggested by BPI. Changed the .conf file under the m2u section to point to the new kernel file name and it’s updated it. Also did a apt-get upgrade (hence the new version of ubuntu…

Many thanks

Hi, I’ve found strange thing.

I’ve installed my second banana pi m2u with image 2017-01-20-debian-8-jessie-lite-beta3-bpi-m2u.img. It was plugged in by HDMI into TV and USB Key/Mouse. It was working fine for 7 days and memtest also worked fine. After these 7 days I have unpluged it from TV and Key/Mouse and it froze after next 2 days. Is it possible that problem with freezing is caused by unplugged HDMI?

Hi all, After next 5 days my BPI M2U has frozen again with dan-and kernel 3.10.104. Mem test worked without any problems.

I have tryed to change power suply, but old one worked for 2 years with BPI M1. So we will see.

Any advise?

Are there any messages in the log files or on serial console? Is it stable under load (see chip temperature using cat /sys/devices/virtual/thermal/thermal_zone0/temp)?

I’ve tried to repeatedly plug/unplug HDMI and USB but as far it is still running nicely.

Linux bpi-iot-ros-ai 3.10.104-BPI-M2U-Kernel #11 SMP Sun Feb 5 17:38:59 MSK 2017 armv7l armv7l armv7l GNU/Linux

01:51:16 up 32 days, 54 min, 1 user, load average: 5.35, 5.45, 5.50

Hi and thaks for response, I have cooler on it so my temp is: cat /sys/devices/virtual/thermal/thermal_zone0/temp 43

I’ve already tested on full load on all 4 cores by pigz and all works fine. Temp on full load during 15 minutes is about 65°C

Everything stable.

But this is my second BPI M2U and previous has already stability problems, so I have tried to buy next one and still with same result. :frowning:

I have also 3,5 3TB SATA disk with 12/5V (5V for BPI) power suply, but now I have tried to connect BPI to another 5V 2A adapter.

20:07:46 up 1 day, 2:03, 1 user, load average: 5,66, 5,20, 3,38 Linux version 3.10.104-BPI-M2U-Kernel ([email protected]) (gcc version 5.4.0 20160609 (Ubuntu/Linaro 5.4.0-6ubuntu1~16.04.4) ) #11 SMP Sun Feb 5 17:38:59 MSK 2017

In logs is nothing, it is HW freeze,

Have you tried without SATA disk attached?

No, I have it as server, so without disk it is useless for me. But I can try it with my second BPI M2U.

Hi all, so as I said I have changed my power adapter and it looks hopefully also with HDD:

[email protected]:~# uptime

14:31:19 up 8 days, 20:27, 1 user, load average: 1,18, 1,15, 1,17