HDMI outout shift/corruption of first 4 lines

Hello! I’ve stumbled upon problem with HDMI output on BPI-M2U. The problem is with corruption or shift of the first 4 lines in 1080p mode in both console and X-window. This problem persists with both 1080p50 and 1080p60 modes and with different linux distributions (namely 2016-11-29-ubuntu-16.04.1-mate-desktop-preview3-bpi-m2u-sd-emmc.img.zip and 2017-01-20-debian-8-jessie-lite-beta3-bpi-m2u.img.zip) . I’ve checked my m2u with more then 10 different cables and monitors/tv’s so the problem is not with cables or monitors. To illustrate the problem I took two photos:

  1. Corruption and occasional flickering on some monitors (the small black box 2x4 pixels at the left upper corner):
  2. Shift of first 4 lines with occasional flickering:

On some monitors the image is unstable and flickers once/twice per second. Does anybody have a solution to this problem?

Same here on every image tested 11-22-16 and newer. Sooo, BananaPi support people, is this a hardware problem? A fex problem? Something you’re working on? Something you’re gonna fix?

This is unusable at 1080P. This never should have shipped. Is there a person there who is responsible there (foxxconn/bpi/sinovoip)? Anyone working to fix things or communicate with users or are you just content to sit around and collect your next paycheck.

Your organization and accountability suck.

Here’s hoping a kick in the butt will get you to do something…

Newest image dated 4/27/17 nothing has changed. I’ve now tried this on two monitors.

I am running M2-U with 1080P on my monitor without the corruption or flickering you are experiencing. Still have the 2x2 (2x4?) black pixel at the upper left corner though.

I have not done any research on this 2x2 pixel hole or tried to fix this.

Noee: i use LXDE, not MATE.

I was using a 2010ish monitor before. Just upgraded to a new acer today and now only get the black hole in the upper left as well. Seems 1080p isn’t big in China or their engineers would have caught this.

This 2x2 pixel looks like someone left some debugging / testing enabled on kernel… :slight_smile: