[BPI-R3] Which GPON ONU is working?

It’s already fixed at 2.5Gbps, I’m referring to ALCATELLUCENT

Did you try the second firmware as well?

root@OpenWrt:/# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan
192.168.20.0    *               255.255.255.0   U     0      0        0 br-wan
root@OpenWrt:/#

eth1 is still down and the bridge br-wan too

i’m going to do it now

i changed my /etc/config/network and did a /etc/init.d/network restart

that’s not enough ?

take a look onto “ip a”, eth1 needs to be up to receive packets (maybe you need a link there). also the bridge.

maybe it is easier to remove eth1 from the bridge and give the ip directly

can you tell me first if there is a command to do this from the shell ?

ip link set eth1 up
ip link set br-wan up

to remove eth1 from bridge

ip link set dev eth1 nomaster
ip a del 192.168.20.1/24 dev br-wan
ip a add 192.168.20.1/24 dev eth1
root@OpenWrt:/# ip link set eth1 up
root@OpenWrt:/# ip link set br-wan up
root@OpenWrt:/# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc mq state UP qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::7068:4dff:fe0f:ba92/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq master br-wan state DOWN qlen 1000
    link/ether 72:68:4d:0f:ba:93 brd ff:ff:ff:ff:ff:ff
4: wan@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-wan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:93 brd ff:ff:ff:ff:ff:ff
5: lan1@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
6: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
7: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
8: lan4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
9: sfp2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
17: br-lan: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd33:6451:7ce0::1/60 scope global tentative noprefixroute
       valid_lft forever preferred_lft forever
18: br-wan: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN qlen 1000
    link/ether 72:68:4d:0f:ba:93 brd ff:ff:ff:ff:ff:ff
    inet 192.168.20.1/24 brd 192.168.20.255 scope global br-wan
       valid_lft forever preferred_lft forever
root@OpenWrt:/#

mhm, seems it is still down because of the link…but maybe you can ping the bridge-IP and then the one from the ONT

root@OpenWrt:/# ip link set dev eth1 nomaster
[ 1657.560205] device eth1 left promiscuous mode
[ 1657.564654] br-wan: port 1(eth1) entered disabled state
root@OpenWrt:/# ip a del 192.168.20.1/24 dev br-wan
root@OpenWrt:/# ip a add 192.168.20.1/24 dev eth1
root@OpenWrt:/# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc mq state UP qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::7068:4dff:fe0f:ba92/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
    link/ether 72:68:4d:0f:ba:93 brd ff:ff:ff:ff:ff:ff
    inet 192.168.20.1/24 scope global eth1
       valid_lft forever preferred_lft forever
4: wan@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-wan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:93 brd ff:ff:ff:ff:ff:ff
5: lan1@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
6: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
7: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
8: lan4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
9: sfp2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
17: br-lan: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN qlen 1000
    link/ether 72:68:4d:0f:ba:92 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd33:6451:7ce0::1/60 scope global tentative noprefixroute
       valid_lft forever preferred_lft forever
18: br-wan: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN qlen 1000
    link/ether 72:68:4d:0f:ba:93 brd ff:ff:ff:ff:ff:ff
root@OpenWrt:/#

no…still no answer to the pings

root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd33:6451:7ce0::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'sfp2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'wan'

config device
        option name 'eth1'
        option macaddr '72:68:4d:0f:ba:93'

config device
        option name 'wan'
        option macaddr '72:68:4d:0f:ba:93'

config interface 'wan'
        option device 'br-wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'br-wan'
        option proto 'dhcpv6'

config interface 'ont'
        option proto 'static'
        option device 'eth1'
        option ipaddr '192.168.20.1'
        option netmask '255.255.255.0'

root@OpenWrt:/#

I removed ETH1 from the br-wan, and set the ONT interface with eth1, and still no ping after a /etc/init.d/network restart

let’s try the firmware posted by @dale here ? or you need more tests ?

maybe we need to wait till the other quirks are in (at least the waiting one)

can you do a

ethtool -m eth1
root@OpenWrt:/# ethtool -m eth1
/bin/ash: ethtool: not found

:sob:

@dale add ethtool in your firmware :sweat_smile:

Try installing via opkg, if it doesn’t require kmods it will work

i’m with the serial…

well, i just installed your latest firmware and here is the bootlog : https://pastebin.com/KUidtq7d

root@OpenWrt:/# logread | grep 'eth1'
Fri Sep  1 00:03:19 2023 kern.info kernel: [    1.118308] mtk_soc_eth 15100000.ethernet eth1: mediatek frame engine at 0xffffffc009680000, irq 136
Fri Sep  1 00:03:22 2023 kern.info kernel: [   21.334824] mtk_soc_eth 15100000.ethernet eth1: configuring for inband/2500base-x link mode
Fri Sep  1 00:03:22 2023 kern.info kernel: [   21.345379] br-wan: port 1(eth1) entered blocking state
Fri Sep  1 00:03:22 2023 kern.info kernel: [   21.350633] br-wan: port 1(eth1) entered disabled state
Fri Sep  1 00:03:22 2023 kern.info kernel: [   21.356423] device eth1 entered promiscuous mode
Fri Sep  1 00:03:22 2023 kern.info kernel: [   21.363034] br-wan: port 1(eth1) entered blocking state
Fri Sep  1 00:03:22 2023 kern.info kernel: [   21.368285] br-wan: port 1(eth1) entered forwarding state
Fri Sep  1 00:03:23 2023 kern.info kernel: [   22.176483] br-wan: port 1(eth1) entered disabled state


root@OpenWrt:/# logread | grep 'sfp'
Fri Sep  1 00:03:19 2023 kern.info kernel: [   11.824483] sfp sfp-1: Host maximum power 3.0W
Fri Sep  1 00:03:19 2023 kern.info kernel: [   11.829668] sfp sfp-2: Host maximum power 3.0W
Fri Sep  1 00:03:19 2023 kern.info kernel: [   12.164794] sfp sfp-1: module ALCATELLUCENT    G010SP           rev 10   sn ALCLFAB44018     dc 161205
Fri Sep  1 00:03:22 2023 kern.info kernel: [   21.302764] mt7530-mdio mdio-bus:1f sfp2: configuring for inband/2500base-x link mode
Fri Sep  1 00:03:22 2023 kern.info kernel: [   21.312733] br-lan: port 5(sfp2) entered blocking state
Fri Sep  1 00:03:22 2023 kern.info kernel: [   21.318016] br-lan: port 5(sfp2) entered disabled state
Fri Sep  1 00:03:22 2023 kern.info kernel: [   21.325791] device sfp2 entered promiscuous mode
Fri Sep  1 00:03:22 2023 kern.err kernel: [   21.449760] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:22 2023 kern.err kernel: [   21.574545] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:23 2023 kern.err kernel: [   21.688574] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:23 2023 kern.err kernel: [   21.800604] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:23 2023 kern.err kernel: [   21.912614] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:23 2023 kern.err kernel: [   22.024693] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:23 2023 kern.err kernel: [   22.136642] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:23 2023 kern.err kernel: [   22.251750] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:23 2023 kern.err kernel: [   22.364434] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:23 2023 kern.err kernel: [   22.481775] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:27 2023 kern.warn kernel: [   26.464576] sfp_soft_get_state: 37 callbacks suppressed
Fri Sep  1 00:03:27 2023 kern.err kernel: [   26.464594] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:27 2023 kern.err kernel: [   26.584567] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:28 2023 kern.err kernel: [   26.696548] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:28 2023 kern.err kernel: [   26.808555] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:28 2023 kern.err kernel: [   26.920555] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:28 2023 kern.err kernel: [   27.032554] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:28 2023 kern.err kernel: [   27.144553] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:28 2023 kern.err kernel: [   27.256525] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:28 2023 kern.err kernel: [   27.368523] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:28 2023 kern.err kernel: [   27.480543] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:32 2023 kern.warn kernel: [   31.544523] sfp_soft_get_state: 38 callbacks suppressed
Fri Sep  1 00:03:32 2023 kern.err kernel: [   31.544539] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:33 2023 kern.err kernel: [   31.664521] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:33 2023 kern.err kernel: [   31.776520] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:33 2023 kern.err kernel: [   31.888521] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:33 2023 kern.err kernel: [   32.000522] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:33 2023 kern.err kernel: [   32.112569] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:33 2023 kern.err kernel: [   32.232639] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:33 2023 kern.err kernel: [   32.344551] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:33 2023 kern.err kernel: [   32.456540] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:33 2023 kern.err kernel: [   32.568535] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:38 2023 kern.warn kernel: [   36.632521] sfp_soft_get_state: 38 callbacks suppressed
Fri Sep  1 00:03:38 2023 kern.err kernel: [   36.632536] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:38 2023 kern.err kernel: [   36.752521] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:38 2023 kern.err kernel: [   36.864524] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:38 2023 kern.err kernel: [   36.976520] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:38 2023 kern.err kernel: [   37.088520] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:38 2023 kern.err kernel: [   37.200520] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:38 2023 kern.err kernel: [   37.312520] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:38 2023 kern.err kernel: [   37.424543] sfp sfp-1: failed to read SFP soft status: -6
Fri Sep  1 00:03:38 2023 kern.err kernel: [   37.536536] sfp sfp-1: failed to read SFP soft status: -6

i created my ONT interface on eth1, and removed eth1 from the bridge.

root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd75:0574:8ab0::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'sfp2'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'wan'

config device
        option name 'eth1'
        option macaddr '9a:a6:82:d4:c2:52'

config device
        option name 'wan'
        option macaddr '9a:a6:82:d4:c2:52'

config interface 'wan'
        option device 'br-wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'br-wan'
        option proto 'dhcpv6'

config interface 'ont'
        option device 'eth1'
        option proto 'static'
        option ipaddr '192.168.20.1'
        option netmask '255.255.255.0'
root@OpenWrt:/#

Still no answer to the pings