[BPI-R3] Radio0 Generic unknown Device is not active

Hi, I would like to know how to activate wifi in openwrt with Bpi-r3 ? Screenshot%20from%202023-05-31%2015-48-22 Screenshot%20from%202023-05-30%2018-45-32

wifi status

{                                                                               
    "radio0": {                                                             
            "up": false,                                                    
            "pending": false,                                               
            "autostart": true,                                              
            "disabled": false,                                              
            "retry_setup_failed": true,                                     
            "config": {                                                     
                    "path": "platform/soc/18000000.wmac",                   
                    "cell_density": 0,                                      
                    "country": "BE"                                         
            },                                                              
            "interfaces": [                                                 
                    {                                                       
                            "section": "wifinet1",                          
                            "config": {                                     
                                    "mode": "ap",                           
                                    "ssid": "OpenWrt2.4",                   
                                    "encryption": "psk2",                   
                                    "key": "xxxxxxxxxxx",                 
                                    "mode": "ap",                           
                                    "network": [                            
                                            "lan"                           
                                    ]                                       
                            },                                              
                            "vlans": [                                      
                                                                            
                            ],                                              
                            "stations": [                                   
                                                                            
                            ]                                               
                    }                                                       
            ]                                                               
    },                                                                      
    "radio1": {                                                             
            "up": false,                                                    
            "pending": false,                                               
            "autostart": true,                                              
            "disabled": false,                                              
            "retry_setup_failed": true,                                     
            "config": {                                                     
                    "path": "platform/soc/18000000.wmac+1",                 
                    "cell_density": 0,                                      
                    "country": "BE"                                         
            },                                                              
            "interfaces": [                                                 
                    {                                                       
                            "section": "wifinet2",                          
                            "config": {                                     
                                    "mode": "ap",                           
                                    "ssid": "OpenWrt5",                     
                                    "encryption": "psk2",                   
                                    "key": "xxxxxxxxxxx",                 
                                    "mode": "ap",                           
                                    "network": [                            
                                            "lan"                           
                                    ]                                       
                            },                                              
                            "vlans": [                                      
                                                                            
                            ],                                              
                            "stations": [                                   
                                                                            
                            ]                                               
                    }                                                       
            ]                                                               
    }  
}                                  

cat /etc/config/wireless

config wifi-device 'radio0'                                                     
    option type 'mac80211'                                                  
    option path 'platform/soc/18000000.wmac'                                
    option cell_density '0'                                                 
    option country 'BE'                                                     
                                                                            
config wifi-device 'radio1'                                                     
    option type 'mac80211'                                                  
    option path 'platform/soc/18000000.wmac+1'                              
    option cell_density '0'                                                 
    option country 'BE'                                                     
                                                                            
config wifi-iface 'wifinet1'                                                    
    option device 'radio0'                                                  
    option mode 'ap'                                                        
    option ssid 'OpenWrt2.4'                                                
    option encryption 'psk2'                                                
    option key 'xxxxxxxxxxx'                                              
    option network 'lan'                                                    
                                                                            
config wifi-iface 'wifinet2'                                                    
    option device 'radio1'                                                  
    option mode 'ap'                                                        
    option ssid 'OpenWrt5'                                                  
    option encryption 'psk2'                                                
    option key 'xxxxxxxx'                                              
    option network 'lan'

System Log

Kernel Log

radio0 has no band, channel, mode, or counrtry. radio1 has no country - that may preclude channel 36 from working in HE80, since when no country is set OpenWrt defaults to only channels and power levels that are common to all.

The following is my config, which works well for me:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/18000000.wmac'
	option channel '11'
	option band '2g'
	option htmode 'HT20'
	option country 'CA'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'RadioActive 2g4'
	option encryption 'sae-mixed'
	option key 'xxxxxxxxxxxxxxxx'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wmac+1'
	option channel '157'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'
	option country 'CA'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'RadioActive 5g'
	option encryption 'psk2'
	option key 'xxxxxxxxxxxxxxxx'
	option network 'lan'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	option ieee80211w '1'

Thank you, but after change by your config still the same.
I think the problem is radio0 and radio1 aren’t activate. I don’t know to activate.

I apologize, I didn’t really look at the kernel log. I just noticed this:
[ 30.556843] mt7986-wmac 18000000.wmac: Failed to start WA firmware

This usually happens when an incompatible usb-to-serial adapter is used to connect to the device’s serial port, and it will prevent the AFE radio chips from powering up properly. Have you had something connected to the serial console? Check out this thread:

Hello VA1DER, I use serial uart to config my bpi-r3
PL2303 PL2303HX/PL2303TA,
I tried with ssh connection still same problem.

Can you recommend me an RS232 to connect me?

Once connect with ssh I have these errors
opkg update
opkg install luci luci-ssl
I have the following errors

Collected errors:

 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.114-1-5a722cf45c550583b4431a8b90e59ee3) for kmod-nf-reject
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.114-1-5a722cf45c550583b4431a8b90e59ee3) for kmod-nf-reject6
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.114-1-5a722cf45c550583b4431a8b90e59ee3) for kmod-nf-log
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.114-1-5a722cf45c550583b4431a8b90e59ee3) for kmod-nf-log6
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.114-1-5a722cf45c550583b4431a8b90e59ee3) for kmod-crypto-crc32c
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.114-1-5a722cf45c550583b4431a8b90e59ee3) for kmod-nft-core
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.114-1-5a722cf45c550583b4431a8b90e59ee3) for kmod-nf-flow
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.114-1-5a722cf45c550583b4431a8b90e59ee3) for kmod-nf-ipt
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.15.114-1-5a722cf45c550583b4431a8b90e59ee3) for kmod-ipt-core

The PL2303 is known to have problems with the BPI-R3. I recommend one by FTDI. This is the one I use: https://www.aliexpress.com/item/1005003691758881.html

Do you mean that the radio is still not working? Did you disconnect the serial cable and cycle the power?

This can happen for a number of reasons. In your case it could be a misconfigured /etc/opkg/distfeeds.conf. Yours should probably be the following:

src/gz openwrt_core https://downloads.openwrt.org/snapshots/targets/mediatek/filogic/packages
src/gz openwrt_base https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/base
src/gz openwrt_kmods https://downloads.openwrt.org/snapshots/targets/mediatek/filogic/kmods/5.15.114-1-5a722cf45c550583b4431a8b90e59ee3
src/gz openwrt_luci https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/luci
src/gz openwrt_packages https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/packages
src/gz openwrt_routing https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/routing
src/gz openwrt_telephony https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/telephony
1 Like

Thank you so much VA1DER, I think it was the serial cable.Screenshot%20from%202023-06-02%2009-54-50