BPI-R2 PRO Upload SD Card Image to EMMC

Hello, I have a BPI-R2 PRO. I used https://drive.google.com/drive/folders/1pnTxSquZL-7n0xx4Bx1xJl7LqEKfa71Y image for my project. Now I want to move my image from the SD card to emmc, but I do not know how will I do that. I asked a similar question before and I download zip file of my image under /root directory and I got disk size error . I asked this question in a new issue because I am confused and I want to move my image from sd to emmc via a command like

dd if=bpi-r3.img of=/dev/mmcblk1

or via RKDevTool.exe Best Regards

As i wrote in the other thread you can extract to stdout and write to emmc. I guess you have r2pro and using my image which is a gz file to use the right tool for uncompress

gunzip -c myfile.gz | dd of=/dev/mmcblkX bs=1M

Hello ,I tried your solution .Uploading process has done. But it dişd not worked . I think it is about fstab file. There is only one command in BPI-ROOT partition /etc/fstab file which is


what should i write in this file? Thank you best regards

In general You should have 2 devices:

  • /dev/mmcblk0
  • /dev/mmcblk1

One is for EMMC another is for SD (i don’t remember which one for what)

Likely in /etc/fstab You have something similar to:

/dev/mmcblkXpY / ext4 defaults 0 2

Where X is a number for a SD-card and Y is a root partition number.

So the 1st way to boot is to actualize the X: change 1 -> 0 (or 0 ->1)

Another way, it should work in case of usind dd, is to use UUID instead of /dev/mmcblkXpY:

it should look similar to:

UUID=3748ad4f-b444-43b9-a179-1ec73abdfc88 / ext4 ...

As I remember - the UUID of the root partition remains the same on cloning.

You may figure out yours by using: sudo ls -la /dev/disk/by-uuid

2nd way (imho) is more convenient/universal, the only ‘but’ in this case is - IDK which partition will be used in case if both EMMC and SD-card are present and have the same UUID.

P.S. You also probably will have to edit the extlinux.conf

I am new a t embedded linux. now Sinovip’s image (https://drive.google.com/drive/u/0/folders/1pFayiLS3cS0idClUlvHzaySaJMb_AOrB) works for sd card and emmc . Now I want to learn Is there any way use @frank-w 's image for emmc ? Because I use this image for my codes. Best Regards

In extlinux.conf file

append earlycon=uart8250,mmio32,0xfe660000 console=ttyS2,1500000n8 root=/dev/mmcblk0p3 rootwait rw

command was placed should I change it to the root=/dev/mmcblk1boot0(mmcblk1boot1)

Rootfs is still p3,but the other mmcblkX

should I add

/dev/mmcblkXpY / ext4 defaults 0 2 command /etc/fstab like /dev/mmcblk1p3 / ext4 defaults 0 2 ??? Best Regards

There is no devices like /dev/mmcblk1p3 but I tried it and it did not work. devices under /dev are image

What do you think for following command I changed to /dev/mmcblk0p3 -> /dev/mmcblk1boot1

append earlycon=uart8250,mmio32,0xfe660000 console=ttyS2,1500000n8 root=/dev/mmcblk1boot1 rootwait rw

Likely You’ve flashed a wrong image, please double check it. Probably if you’re burning a BPS image it may use some other than GPT partitioning. e.g. MTD.

Remember that partition table needs to re-read after flashing my image…best way is reboot

The partprobe command may help, but yes reboot is a most reliable way. Just keep in mind: the emmc has a higher than a sd priority during boot.

Could you give me more details ? I do not know how can I generate partition table ? I do not understand relation between reboot and partition table. Best Regards

You don’t have to create partition table it is there after you flashed image to emmc. But you have to read it again to access new partitions. Maybe partprobe is enough,maybe reboot is needed

After partprobe command I got this image

Ok,this looks good,you can fix this error with parted (write primary to backup)

I do not understand xould you give me more details I upload myimage file from .zip to emmc(unzip -c myimage.zip | dd of=/dev/mmcblk1 ) after it I wrote partprobe command.

Is the the proble msdos partition?Best Regards image

No,bootx partitions are hardware partitions. But mmcblk1 should be gpt like on sdcard,error with backup is normal,as this needs to be on end of disk and so missing


I got this what should I do?