BPI-M3 new image:ArchLinuxARM Lite for BPI-M3 (20151209)

ArchLinuxARM Lite for BPI-M3 (20151209)

  1. BPI-M3 kernel 3.4
  2. username & password: root/bananapi
  3. support HDMI 1080P & 720P
  4. support eMMC
  5. support GMAC
  6. support WIFI
  7. support SATA
  8. support bpi-bootsel cmd to switch mode

MD5

: 9123352d4fdb871ce959709f4eb39bc6

Google Drive:

https://drive.google.com/file/d/0B_YnvHgh2rwjTVRkT0hnaWVGZDQ/view?usp=sharing

Baidu Cloud:

http://yun.baidu.com/s/1kTXqzrD

too bad that M3 will never be supported on linux properly because there’s no linux drivers for the gpu it use

Not true, Actions Semi’s S500 also contains the PowerVR SGX544MP1 and there binary BLOBs are available to use the GPU with 2D/3D acceleration: http://wiki.linux-xapple.org/w/index.php/How_to_Install_GPU_binary_driver (you’ll never see that from SinoVoip).

But I would suspect you’re not talking about GPU but the video engine CedarX instead (HW accelerated video decoding)? Then also not true – see here for the H3 SoC for example: http://www.orangepi.org/orangepibbsen/forum.php?mod=redirect&goto=findpost&ptid=723&pid=7286

Unfortunately this is true but that depends more on SinoVoip being not interested in providing software/support for their hardware.

we coworker with allwinner , we try on linux GPU driver and video decode . next week ,we will get result

Hi, I have a problem running some programs under simple user. For exaple, programs like bsdtar getting killed at their start.

[[email protected] ~]$ bsdtar
Killed

However I can run them just fine under root. And there is nothing in dmesg about it. Why some programs are getting killed that way?

Please do a

cat /proc/sys/vm/mmap_min_addr

and report back.

Ok, to shorten this crap:

This is the problem and this applies to EVERY OS image ‘Team BPi’ provides. It’s a well known problem, it’s easy to fix but you made the mistake to buy hardware from a vendor that doesn’t give a sh*t about software issues. They only want to sell hardware and they even don’t test the crappy OS images they release every few days. They simply don’t care.

1 Like

Changed CONFIG_DEFAULT_MMAP_MIN_ADDR value to 4096 and recompiled BSP. The problem is gone now. Thank you tkaiser!

Congrats. You and me are the only 2 M3 users in the world that do not suffer from this limitation any longer (there are 3 more necessary fixes for kernel sources/sys_config.fex – but I won’t share since this is 'Team BPi’s strategy: Let their customers do all the work).

So now let’s have a look how long it takes until ‘Team BPi’ fixes their beginner’s mistake (can be also done in a running installation without recompiling the kernel).

I’ve got very weird behaviour. I don’t have WiFi device.

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether aa:6e:a1:b9:2a:3c brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.8/16 brd 192.168.255.255 scope global eth0
    inet6 fe80::a86e:a1ff:feb9:2a3c/64 scope link 
       valid_lft forever preferred_lft forever
3: tunl0: <NOARP> mtu 1480 qdisc noop state DOWN group default 
    link/ipip 0.0.0.0 brd 0.0.0.0
4: sit0: <NOARP> mtu 1480 qdisc noop state DOWN group default 
    link/sit 0.0.0.0 brd 0.0.0.0

How can i enable it?

2016-05-10-ArchLinuxARM-lite-bpi-m3.img.zip fix it :slight_smile:

It took half a year…