BPI-M3 as Wireless-Access-Point

Hello Guys,

is there any way to get the BPI-M3 working as Access-Point ? I’ve tried it with hostapd, the Onboard-Wifi and my external USB-Wifi-Adapter TL-WN722N - unfortunately without success. I also tried it with many different instructions - but nothing !

Hope someone can help me or can explain me where the problem lies. Maybe the BPI-Team has some information :slight_smile:

Thank you very much greetings root_Padi


I’ve spent two day for this. The trick is in module parametr:

# rmmod bcmdhd
# modprobe bcmdhd op_mode=2

Then I used create_ap:

# create_ap --no-virt wlan0 eth0 <AP_Name> <AP_Password>

Works for me on archlinux. You can add it here:

# cat /etc/modules-load.d/wifi.conf                                                                                                   
bcmdhd op_mode=2

Have a nice day.


Hello, thanks a lot for your answer, unfortunately my Banana-Pi-M3 is broken so I can’t work with it anymore… :frowning:

Have a nice day too