BPI-M2 zero new image:2017-12-04-Armbian-5.36-m2-zero-Ubuntu-xenial-next-4.14.3-desktop-preview-buildbybpi


armbian 1204 1

  1. based on ubuntu 16.04.3 LTS Xfce Desktop build with armbian’s work by bpi
  2. support BPI-M2 Zero (H3 / H2+) , u-boot 2017.11 , kernel 4.14.3
  3. username & password: root/1234 (armbian default)
  4. support HDMI (default)
  5. support WIFI
  6. support OTG (can support usb hub & usb ethernet)
  7. support DVFS (pmu type: gpio PL01 switch 1.1V / 1.3V)
  8. Thanks for linux-sunxi community (http://linux-sunxi.org/)
  9. Thanks to armbian’s work (https://www.armbian.com/)
  10. ref. patch files (https://github.com/BPI-SINOVOIP/BPI-files/tree/master/others/armbian)
  11. ref. https://github.com/BPI-SINOVOIP/BPI-M2Z-bsp
  12. ref. https://bananapi.gitbooks.io/bpi-m2-/content/en/

Google Drive:

baidu cloud:


MD5: 5827f42c79840378c980fb9794143c63

FILESIZE: 823252037 (~785MB)


Two quick questions:

1) Im trying this image on my Banana Pi M2 Zero and got a warning for bad CRC in the serial during setup, is this normal?

U-Boot SPL 2017.11-armbian (Dec 04 2017 - 08:16:05)
DRAM: 512 MiB
Trying to boot from MMC1
BPI: skip sunxi_mmc_getcd pin 166(1)

U-Boot 2017.11-armbian (Dec 04 2017 - 08:16:05 +0800) Allwinner Technology

CPU:   Allwinner H3 (SUN8I 1680)
Model: Banana Pi BPI-M2-Zero
DRAM:  512 MiB
BPI: skip sunxi_mmc_getcd pin 166(1)
*** Warning - bad CRC, using default environment     <<<<<-------

2) I’m trying to login through serial, however, it requests a new password which is not accepted. What am I doing wrong?

[e[0;32m  OK  e[0m] Started Daily apt download activities.
[e[0;32m  OK  e[0m] Started Daily apt upgrade and clean activities.
[e[0;32m  OK  e[0m] Reached target Timers.
[e[0;32m  OK  e[0m] Started LSB: Advanced IEEE 802.11 management daemon.
[e[0;32m  OK  e[0m] Started /etc/rc.local Compatibility.
[e[0;32m  OK  e[0m] Started LSB: disk temperature monitoring daemon.
[e[0;32m  OK  e[0m] Started Getty on tty1.
[e[0;32m  OK  e[0m] Started Serial Getty on ttyS0.
[e[0;32m  OK  e[0m] Reached target Login Prompts.
[e[0;32m  OK  e[0m] Started LSB: Start NTP daemon.
[e[0;32m  OK  e[0m] Started LSB: Armbian gathering hardware information.
[e[0;32m  OK  e[0m] Reached target Multi-User System.
[e[0;32m  OK  e[0m] Reached target Graphical Interface.
         Starting Update UTMP about System Runlevel Changes...
[e[0;32m  OK  e[0m] Started Update UTMP about System Runlevel Changes.

Ubuntu 16.04.3 LTS bananapim2zero ttyS0

bananapim2zero login: root

You are required to change your password immediately (root enforced)
Changing password for root.
(current) UNIX password: 

Authentication token manipulation error

Ubuntu 16.04.3 LTS bananapim2zero ttyS0

bananapim2zero login: 

Thanks in advance,


It’s also interesting that it writes “CPU: Allwinner H3” during load, and at least in my board it’s printed H2…

Just tried out this image. Thanks for providing it.

Just FYI - There appears to be a pretty significant video issue. As you move the mouse around the screen in the UI, the whole screen twitches pretty badly. I managed to use it enough to confirm WiFi works properly and to shut it down. This same TV has had like 20 different flavors of single boards and linuxes/androids attached without issues. Sorry I don’t have a solution to offer, I couldn’t come up with one. Thanks again.

Indeed same here, the glitching on the video signal is active on every graphic update, for me it was evident the image glitched when the menu was opened/closed and on e.g. animating wifi icons

you need to make a new user on login with root / 1234

but first type the old password before you want to enter a new one

@grit, I did try to change it!! But Ive got a Authentication token manipulation error!

@nerdofepic At least you got way further than I did. Sorry to ask, but how did you write the image to the SD, maybe thats where the difference is…


To burn the image, I used ImageWriter on Win10. Just selected the image file and the SD card and clicked Write. Honestly nothing fancy. :wink:

yes I also am getting severe video glitching with graphic updates

I also ran GLmark2-es2 to test performance, and it really messed up, it also thought it was running on a GLES3.0 system but the Zero has mali 400Mp2 so only GLES2.0 at most.

Is there a more stable OS?

Ummm anyone? Or is it going to be another example of the makers not actually caring about the software?

Video is much more stable at 720p

using a version from November which was the video version, it is more stable at 720p, GLmark2-es2 works on it, but only gives a score of 52

It’s not a solution, just a hint, looks like with this score mali is not in use so no hardware acceleration. Try the image with kernel 3.4.113 and if i recall correctly xorg.conf should have SwapbuffersWait set to false. Mind that i have not tried any image yet or have built any so far, so i could be wrong…

I don’t build my own OS, so I rely on whats made available. This version did report Mali 400 GPU’s as the target, and I also installed mesa drivers, but to no benefit.

I don’t really need superfast scores, but must say this image is far from a useable system. display at 1080 is unuseable also there is incomplete alsa support. I’m afraid the BPIZero’s are collecting dust here…

also - it’ is becoming more and more unclear which thread has the latest image for the BPiZero. Maybe the latest ‘OS experiment’ can be pinned or something.

Is there an Armbian Image without Ubuntu available?

Is there any new image, with working graphics yet?

I try use on banana pi m2+ zero , and i have error crc , not boot .

This image, for write on sdcard , i need use what program to flash on sdcard to work normally ?

I fix this problem , is cause by buffer after write sdcard , i need flush cache to finish write on sdcard , after this , work 100%

1 Like

I installed this image to microSD card and it worked good the first time I use it.

I shutdown my Banana Pi zero W UMPC.

Now, when I boot, I get the ‘Warning bad CRC’ message in console text. Then it continues to boot and I see the Armbian with penguin on the display. But it will not boot any further.

Any suggestion to fix this?

Not sure if what Carlos writes is same issue. If so, what does it mean to ‘flush cache to finish write on sdcard’ ?

Thank you.