BPI-M2 Ultra/BPI-M2 Berry new image : Armbian Bionic and Stretch

Preview images with modern 4.18.y kernel:


Boot logs: http://ix.io/1kVQ


Hi Igor,

thx for your image. But I have problem with it… there is some errors in logubuntu.txt (44,5 KB) In line “Started Raise network interfaces” whole system stop for a while.

HDMI not working. Lan OK - I can connect via putty from win machine.

Can you see on it? I am a linux newbie.


Preview development images come without support since this is waste of time and extremely expensive at this stage. Images were released since they are usable for certain applications and there are surely problems … which will eventually be fixed.

If you need some fixing or help, you need to do it alone or hire people who can. I am sorry.

Thank you very much for your effort. Armbian Stretch works flawlessly. Looking forward to AHCI support, to see how it performs in comparison to A10/A20.

I have a compiled image of ubuntu xenial with kernel 4.17.17 and uboot 2018.07. HDMI and Desktop working without problems, the only problem is the ethernet that does not work and instability with the wifi adapter, so I am using a usb wifi without problem, the system works perfectly. I have compiled Hyperion Ambilight and I have loaded codes with the Arduino IDE without problems. links: https://1drv.ms/f/s!AknGQkrSSFMagXdoNlpf-3afM29L https://1drv.ms/u/s!AknGQkrSSFMagXioPLz3RBphU0TY

You need to use current DEV branch with 4.18.y and also ethernet will work, wifi instability is unrelated … it depends which one you use.

I have tried to compile 4.18.y but the compiler gives error and the armbian versions do not have graphical interface and when installing the desktop appears but can not be used

Compiling the kernel by using https://github.com/armbian/build works!, tested at this moment just to be sure. If you do that on hand, you have to know what you are doing. Which compiler and patches to use …

Desktop worked last time I tried that. Pay attention at the login. You need to create a normal user, otherwise you won’t have a desktop. HDMI is experimental in both cases, 4.17 and 4.18 … it can be dead sometimes.

SATA don’t work on m2 berry.

Yes, known problem … but it will soon be working.

armbian have support BPI-M2 Berry/Ultra compile armbian

SATA is fixed. Do apt update & apt upgrade + reboot in about 12h from now.

1 Like

Is the DVFS support on the plan? It’d be great if you can let me know your the schedule.


There is no schedule since this is amateur based development.


I cant’ eth0 with nmtui. I have the following message :

Could not activate connection: 
Connection 'Ethernet connection 1' is not available on the device eth0 at this time.

So, I have to use a wifi usb key .

I try also with Armbian-config but it’s not better.

“ip addr” displays that :

 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: dummy0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 0a:7c:42:2b:9c:0e brd ff:ff:ff:ff:ff:ff
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 02:53:0b:7e:82:e8 brd ff:ff:ff:ff:ff:ff
    inet6 2a02:8434:875:1e01:53:bff:fe7e:82e8/64 scope global dynamic mngtmpaddr 
       valid_lft 3069607492sec preferred_lft 3069607492sec
    inet6 fe80::53:bff:fe7e:82e8/64 scope link 
       valid_lft forever preferred_lft forever
4: wlx1caff7646ca9: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 1c:af:f7:64:6c:a9 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute wlx1caff7646ca9
       valid_lft 3069607492sec preferred_lft 3069607492sec
    inet6 2a02:8434:875:1e01:1d0a:557d:2843:41cd/64 scope global temporary dynamic 
       valid_lft 3069607492sec preferred_lft 3069607492sec
    inet6 2a02:8434:875:1e01:c9e1:25de:701:fe11/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 3069607492sec preferred_lft 3069607492sec
    inet6 fe80::d6bc:b508:e6f8:40b4/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

I’m using “Linux bpi-berry 4.18.13-sunxi #341 SMP Wed Oct 10 22:55:04 CEST 2018 armv7l armv7l armv7l GNU/Linux”

If I’m unplug and plug the network cable, dmesg displays near the end :

[ 1419.894394] dwmac-sun8i 1c50000.ethernet eth0: Link is Down
[ 1422.145140] dwmac-sun8i 1c50000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx

And i have a lot of error message if I’m trying to insert brcmfmac module for internal wifi.

Can somebody help me to activate eth0 ?

This build is not an official Armbian so this is pretty off topic. Where did you download it?

Downloaded from


Of course, alter install as root : apt update && apt upgrade and change hostname.

It’s not your mine ?

I have resolved my problem with changing /etc/network/interfaces like this :

source /etc/network/interfaces.d/*
# Network is managed by Network manager
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

Aha, sorry. OK.

Than this seems to be problems with the Network manager application. I notice that sometimes takes some time that network is initialised, but at least it never happen to me to fail completely. Since we reuse Debian package base, there is little what can be done. If bug is there, bug is in Armbian as well.

Bottom line. Problem is solved.

I have an issue with i2c port

“i2cdetect -y 0” works as expected but “i2cdetect -y 1” until “i2cdetect -y 3” are wrong.

They take a long time for giving a wrong answer. I have connected a 0.96" OLED and it’s expected on port #2 at 0x3c address but it’s not found.

I check the connection with kernel 3.10.108

What I can see :

jpierre@bpi-berry:~$ dmesg | grep i2c
[    3.813177] i2c /dev entries driver
[    3.813302] mv64xxx_i2c 1c2ac00.i2c: could not find pctldev for node /soc/pinctrl@1c20800/i2c0-pins, deferring probe
[    3.944221] axp20x-i2c 0-0034: AXP20x variant AXP221 found
[    3.958471] input: axp20x-pek as /devices/platform/soc/1c2ac00.i2c/i2c-0/0-0034/axp221-pek/input/input0
[    3.973758] axp20x-i2c 0-0034: AXP20X driver loaded

   jpierre@bpi-berry:~$ ll /dev/i2c*
crw-rw---- 1 root i2c 89, 0 oct.  13 23:20 /dev/i2c-0
crw-rw---- 1 root i2c 89, 1 oct.  13 23:20 /dev/i2c-1
crw-rw---- 1 root i2c 89, 2 oct.  13 23:20 /dev/i2c-2
crw-rw---- 1 root i2c 89, 3 oct.  13 23:20 /dev/i2c-3

  jpierre@bpi-berry:~$ lsmod
Module                  Size  Used by
zstd                   16384  4
lz4                    16384  16
lz4_compress           53248  1 lz4
zram                   20480  5
input_leds             16384  0
axp20x_adc             16384  0
axp20x_battery         16384  0
axp20x_usb_power       16384  0
industrialio           49152  3 axp20x_usb_power,axp20x_battery,axp20x_adc
evdev                  20480  2
w1_gpio                16384  0
wire                   20480  1 w1_gpio
uio_pdrv_genirq        16384  0
uio                    16384  1 uio_pdrv_genirq
sch_fq_codel           20480  2
ip_tables              20480  0
x_tables               20480  1 ip_tables
hid_logitech_hidpp     24576  0
hid_logitech_dj        16384  0
pwrseq_simple          16384  1
realtek                16384  1

Any idea ?

How can I have the green led blinking as kernel 3.10.108 ?

I change /etc/apt/sources.list.d/armbian.list file like this :

# deb http://beta.armbian.com bionic main bionic-utils bionic-desktop
deb https://apt.uk.armbian.com bionic main bionic-utils bionic-desktop

Probably ports are not enabled. That’s all. Since we didn’t develop overlay support for Allwinner R40, this is not plain simple. You can’t use armbian-config -> hardware configuration menu driven utility but you need to edit boards hardware description file (DTB) … which you need to invest some time to understand.

Editing DTB again (probably works also from userspace - use search for details and try):

user-led {
			label = "bananapi:green:user";
			gpios = <&pio 7 21 GPIO_ACTIVE_HIGH>;
+                      default-state = "heartbeat";

Those ideas are theoretical. I don’t know if they work since this board has no support. We just provide image as is. You are on your own to find out how to do this and that. It is similar as on other Allwinner boards. Make use of huge knowledge base: https://www.armbian.com/search

apt.uk.armbian.com is a mirror of apt.armbian.com … since there are no stable builds for this board, this is pointless.