BPI-M2+ new image:Raspbian Jessie(debian 8) BPI-M2P (20160408)

Raspbian Jessie(debian 8) for BPI-M2P (20160408)

  1. BPI-M2P kernel 3.4
  2. username & password: pi/bananapi , root/bananapi
  3. support HDMI 1080P & 720P(default)
  4. support GMAC
  5. support WIFI
  6. support bpi-bootsel cmd can switch to (bpi-m3 & bpi-m2 & bpi-m2p)
  7. support uEnv.txt to fatload script.bin & uImage
  8. support uEnv.txt to set video 1080P & 720P & 480P …
  9. support node-red


BT4.0 driver not work . camera driver not work.

Google Drive: https://drive.google.com/file/d/0B_YnvHgh2rwjQWxMSUlmMnR6Rjg/view?usp=sharing

MD5: fd7f873e732e512f2646a57a593e2a24

Hi,thanks for this.Gpu support is done?

Wow, I thought, give it a try, maybe ‘Team BPi’ learned in the meantime how to do it better. Just to realize that it’s as bad as always.

After flashing the image you can’t do literally anything since there are ZERO BYTES free:

Filesystem      Size  Used Avail Use% Mounted on
/dev/root       3.9G  3.7G     0 100% /
devtmpfs        373M     0  373M   0% /dev
tmpfs           501M   68K  501M   1% /dev/shm
tmpfs           501M  6.9M  494M   2% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           501M     0  501M   0% /sys/fs/cgroup
/dev/mmcblk0p1  256M   45M  211M  18% /boot
tmpfs           101M  4.0K  101M   1% /run/user/1000
/dev/mmcblk1p1  7.2G  145M  6.7G   3% /media/pi/3684f9bd-1ea5-4cd0-a75b-b47af6147d77
tmpfs           101M     0  101M   0% /run/user/0

Why don’t you implement auto fs expansion?

Then you managed to f*ck up throttling settings and with this combination of kernel + sysconfig.fex maximal cpufreq is limited to 1008 MHz. Then your THS settings are really crappy since they lead to killed CPU cores. I’m currently running your insane Raspbian image with a typical Phoronix benchmark and already two CPU cores are killed:

root@bananapi:/# grep -c processor /proc/cpuinfo 
root@bananapi:/# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq 
root@bananapi:/# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq 

Using Rasbian is already crap (slow ARMv6 code!) but with your THS settings on top this ensures to get the slowest H3 device in the world. Running Armbian instead of your crappy Raspbian image the M2+ might perform over twice as fast (since with Armbian you have a quad core SBC running at 1.2GHz and with this horrible Raspbian thing only a dual core SBC running at 1GHz).

C’mon: Why don’t you test the stuff you’re working on? It’s unvelievable that you spend time on producing such a mess.

And this is how it looks like then:


The multithreaded tests suffered from 2 CPU cores killed due to wrong THS settings and 1008 MHz maximum cpufreq.

Finally got the 2016-03-18 raspbian build to work and left it to update and the went to bed. The day after i read in forum that it is set to 2Ghz no matter what. With an open pcb(no housing or coolers and definately no fan) - one night later and ciruits had burned up! Over heating is a bitch! My most expensive paper weight ever… (no I really don’t use paper weights but it a good expression) Powering up now only leaves a red LED to shine in the dark. Really bad 95$ spent. Wouldn’t reccomend it to anyone.

Should you buy a BPI-M3 build you own OS from scratch, or if you cannot - buy another product.

this is a M2+ thread. I guess you didn’t get 2 GHz out of it :slight_smile:

dear BJEagle67, please show your bad board picture on forum, i will show it to lion. we maybe can send a free sample to you.

hope you can do some cool development on it .

Oops, my bad posting BPI-M3 on wrong thread. Just got lost amongst all details that might explain my broken board. I’m struggling here trying to find the menu for uploading pics. Ahh, got it - here they are front and back

LOL, you cannot power through USB !!

exactly,only dc in or gpio 5v!!!

Hello Tido It worked fine and should also work fine as long as you dont have anything connected that draws power - wich I didn’t. Try it yourself and you will see. Power you BPI-M3 with micro USB only and press hold the power button. I trust yours will also start running, where as mine does’nt anymore.

Well, using USB-Micro to power is just worst-case-szenario. Leaving a dev board running over night without touching parts for heat and knowing about the software…

I have an: R1 - with some HW design flaws (Media Player, personal clould, and so on) M2+ not running yet, cable ordered Lemaker Guitar (with software support from the supplier running smooth) RPi 2 Arduino Mega2560 about to arrive with 37 IN 1 BOX SENSOR KITS :smiley:

Why the heck would I order an M3 - because it has only one GPU core :slight_smile: Use case ?

In retrospective I would agree. I was tempted by the 4 plus 4 core solution and missed the fact that they’ve moved the SATA connection via a USB2.0 connection instead of as they had on the old M1 direct to the CPU(much faster than USB2.0). Not knowing all details surrouding the A83T it might not even have that possibility.

Am I to intrepid your response above that the Banana-Pi is not built to run a full 24 hours? I was of the understanding that it’s use is for also building projects that is supposed to run for days weeks and years! Strange if the supplier of the hardware also supply OS that would wreck the device… As far as I recall all other builds I have worked on are always set to minimum or low processor speed and you can yourself - if your environment allows it - set it to higher speed. That have for sure saved most other boards that have been sent out to market: raspbery ardunio, beagle and others. Now I will repeat what I’ve stated before. It was runing OS only on the open PCB, no housing and also no coolers nor fan, but could not imagine that the OS supplied from the manufacturer of the board would wreck the device if not equipped with coolers or fan. I for sure have not read that anywhere in manual for BPI-M3 or releasnotes for the OS images that are provided for download.

And also my BPI-M3 has no core at all, so you’re right, why would you order one :slight_smile:

maybe he just get a free sample .:slight_smile: we send some free sample to user , hope eveyone can help this project.

Can confirm that this works. But not with the OS images provided in the download section (did not found a single one that ran without hassles or at all). I found one made by a community member that works fine: BPI-M3 new image:ubuntu-mate-16.04 beta V1.0 2016-04-25

You should try to use the barrel plug to power before declaring the board dead.

And this is not even BIGlittle architecture ! All 8 are the same :frowning: IIRC, the A83T has no SATA and the bridge chosen by SinoVoip’s dev is the slowest available.

Well, in opposite to Lemaker the SinoVoip didn’t adjust to sane GHz for the CPU, when the software is not ready. Killing CPU-Core’s instead of throttling and so on (see M2+ if you like) Appart from that, they are not investing enough time to pick-up all the supporting-idea’s from the forum. There are so many tipps to make users happy, instead most complain.

Did you have a use case in mind for your M3? Have you tried power it with the DC-in ?

Yepp, tried that (DC powering) as soon as it wouldn’t start. Project in mind was quite simple as a matter of fact and a standard solution tried and tested by many. Webbserver with large storage capabilities. A few minor webbased extra features on the side such as vpn wol and no desktop environment. It all seems a bit far now that data has to pass USB 2.0 to reach the harddrive so speed would suffer… But we’ll see maybe there’s a M4 in the near future!

It’s not just USB 2.0, it’s the chip used on the board that is ultra slow according to http://linux-sunxi.org/Banana_Pi_M3#SATA

And after the experiences made with everything past M1/M1+ I’m already done with any more M’s from here. They really should stop calling their boards Banana Pi since they are all different and incompatible. And I doubt that any M2, M3, M2+ or M4 will be faster than M1 for your use case.

eMMC here you find a step by step how to - read first all lines