Raspbian Jessie(debian 8) 2016-03-18 for BPI-M3 (20160408)

Raspbian Jessie(debian 8) 2016-03-18 for BPI-M3 (20160408)

  1. BPI-M3 kernel 3.4
  2. username & password: pi/bananapi , root/bananapi
  3. support HDMI 1080P & 720P(default)
  4. support GMAC
  5. support WIFI
  6. support bpi-bootsel cmd can switch to (bpi-m3 & bpi-m2 & bpi-m2p)
  7. support uEnv.txt to fatload script.bin & uImage
  8. support uEnv.txt to set video 1080P & 720P & 480P …
  9. support node-red

Google Drive:

MD5: 9f59fbe4f81d60b9b8eff0e1fa9b22e4

1 Like

Thanks sinovoip,

just installed the image on 32GB SD with Win32DiskImager:

/usr/bin/mandb: can’t write to /var/cache/man/1476: No space left on device Setting up htop (1.0.3-1) … root@bananapi:~# df -h Filesystem Size Used Avail Use% Mounted on /dev/root 3.9G 3.8G 0 100% /

Any Ideas?

Avoid crappy OS images? I tried out the same image with M2+ today and was really shocked: BPI-M2+ new image:Raspbian Jessie(debian 8) BPI-M2P (20160408)

The load average goes down from 1.

top - 23:15:09 up 9 min, 2 users, load average: 1.04, 0.93, 0.53 Tasks: 126 total, 1 running, 125 sleeping, 0 stopped, 0 zombie %Cpu(s): 0.1 us, 0.2 sy, 0.0 ni, 99.6 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st KiB Mem: 2060148 total, 448792 used, 1611356 free, 15128 buffers KiB Swap: 102396 total, 0 used, 102396 free. 311688 cached Mem

Is compatible, as long as you read the following Forum what is seen to be incompatible with this image?


My best regards.

Really? That was a great late start.

It’s quite the opposite since the issue is still ignored by SinoVoip. What you see above is 1m, 5m and 15m load. So your board starts with a load below 1 just to exceed 1 after an uptime of just one minute.

And the reason is still: SinoVoip don’t giving a sh*t about problems being easily solvable: https://github.com/BPI-SINOVOIP/BPI-M3-bsp/issues/3

Instead of fixing the issue finally (easy) they ignore it (even more easy since their customers don’t care)

Hello 22101

This might be a late warning unless you read tkaisers respond below. I installed the same image and also found out the size is too small. Forums inform us that you have to put your memory card in another computer to use GParted and manually expand the size to whatever size you want. As many of us do, I did this late at night and was pleased to see that I actually was able to run update. Having booted up with my larger image I found it to be rather hot. It was running i free air without cooling or fans - I belive it is supposed to do just that. Left it to update and went to bed. Next morning it wasn’t running! Strange! and no matter what I did it wouldn’t boot up. Jessie, Fedora 23 or any of the cards i had. All that comes up is an annoying red LED indicating that there is power… Anyhow, on one of the M2 threads i read that sinivoip build their images without the expand feature we find in raspbian “raspi-config”, But not only this - they are run on maximum processor speed. So that would explain the high temperature. Any other build I’ve used for my numerous raspberrries beagle board and others have a default setting to low proseccor speed so that I can choose the appropiriate according to the environment where I run my board The only conclusion I can draw from this is that this immage will run your BPI-M3 to the grave. Unless you mount coolers or add a fan - USE ANOTHER IMAGE. The “Raspbian Jessie(debian 8) 2016-03-18 for BPI-M3” will over heat your processor so that it will be “a very expensive paper weight”. Having followed up many forums I notice tkaisers many threads and strong critism. I understand the frustration when there is no response. I must say though that I did get a response that sugested that wit a picture of my dead board I might be eligable for a “free sample”. Trust me, should that come to a reality I will run the board wit coolers and fan. //Yours trueky