BananaPi M1-M1P-R1 New Image : android and ubuntu sever Release 2018-07-28

hi, i’ve a problem after this command:

apt-get upgrade

the sshd service not start and i cannot loggin with ssh.

Did it happen to someone already? How can I solve? thanks

Due to systemd bug. You need this patch:

HI, the Google drive URL for BP1-R1 is not opening here. And I can´t download from Baidu, as they need an app, etc.

Could you please confirm the BP1-R1 image from Google Drive is ok?

Hello, I have confirmed, I could download, please check again.


if you still could not open google or baidu, try this link:

Hello, Thanks for your answer, I downloaded image and I get following error from Etcher in a MAC:


But I tried other images from your download link like: and worked very fine.

Anyway, what I really need is an R1 image that makes easier to configure the other ethernet ports in board, or at least provides the smoothest path to it. Which one of these images is recommended?

I am checking the desktop demo above and it mounts only eth0 as default (and wlan0), I need to mount other ports to make a private network inside board and output results to external world from eth0. I am trying now the available utilities in image to see if there is one that provides route/bridge configuration. Any hint is very welcome.

Thank you,

Hi there, I have BPI-M1+. Do you guys have link for image of android 4.4 or higher? Thanks!

please see wiki page:

But there is wrong URL - not redirected to android image but to ubuntu server image

Hi Alvin. To solve the disallowed root login via ssh, do the following:

  1. Login as user “pi” via ssh

  2. sudo nano /etc/ssh/sshd_config

  3. change Authentication section to:

    #LoginGraceTime 120

    PermitRootLogin yes

    #StrictModes yes

  4. Save the updated /etc/ssh/sshd_config file.

  5. Restart the SSH server: “service sshd restart”

  6. restart ssh session and login as “root” with pw “bananapi”

That’s it.

1 Like