BananaPi M1-M1P-R1 New Image : android and ubuntu sever Release 2018-07-28

I think this could be related to some generic Ubuntu problem.

Thanks for the reply. I mounted the sd with the image to my main machine and followed the steps but since I could only change files I modified the rc.local to load the new service ( systemctl enable create-ssh-dir.service ) but still my ssh attempts are failing. I created the file with sudo nano create-ssh-dir.service and then copy pasted the below code and gave right permissions. What could go wrong here in that case ? Anyway I am still in search on how can I actually take control over the debug console.

[Unit] Description=Creates sshd directory Before=ssh.service

[Service] Type = oneshot ExecStart=mkdir -p /var/run/sshd



So i found a spare usb cable and cut it to make the connection. It has 4 inner wires, red, blue, white and yellow. Chances someone can responsibly provide with some info which wire should I connect to which pin on the board ?

This image isn’t very helpful as it has different colors than mine and can’t understand the exact pins I should connect.

Thank you

hello, if you use ssh, please try “username: root, password: bananapi” :slightly_smiling_face:

if you use M1, pins definition you could see this:


you could find it here:

That’s the combination I am giving but cannot connect. I will try with the usb cable but do I have to plug the dc input as well or it’s just fine wiring only the 3 wires ? And finally, from my usb cable that has blue, red, white and yellow wire which one should be connected to which pin ?

You need something like this

Oh my, excuse me for my ignorance. I though it was a common usb cable. I will purchase one of these but until it arrives any other way i can access debug console? As my ssh attempts keep failing and the link you provided could solve my case. Thank you.

How they are failing? At least on Armbian, board gets IP via DHCP and then you login with root / 1234 More details:

That’s what I get from nmap

Nmap scan report for
Host is up (0.00017s latency).
Not shown: 998 closed ports
22/tcp   open  ssh
3389/tcp open  ms-wbt-server

And here you can see my ssh attempts giving “bananapi” as a password (also tried “1234”, “root”, “banana” “toor”)


So what am I missing?

This is not Armbian, so I can’t tell.

It’s Ubuntu 16.04 Desktop image for banana pi-m1


So, i finally managed to get access over ssh. I did some tricks over /etc/ssh/ssh_config and manually added my private key to the banana machine so it won’t ask the password again. But I am not sure what happened with the next commands I gave through ssh as root user:

root@bananapi ~ # apt-get install pv
root@bananapi ~ # curl -sL | sudo -E bash
root@bananapi ~ # bpi-bootsel /usr/lib/u-boot/bananapi/bpi-m1/u-boot-2018.01-bpi-m1-legacy-8k.img.gz

And that’s the output I got while I am pretty sure something failed over the execution.


Now I can’t even see the kernel loading and nothing is displayed via hdmi. I know I have tired you with my problem these days :confused:

Good day, tell me someone managed to place a" boot “partition on the microSD memory, and” / " on the hard drive via the SATA interface (SSD) ? (Ubuntu server16.04 HDMI version)


how can I flash the zip archive for the Banana Pi R1?

When I extract it, I only get a data image, but in Windows 10 I can not flash it.

Any help would be appreciated.

if you use windows, you could use “Win32DiskImager.exe” to flash this xxx.img on sd card.

1 Like

Thanks for the information, I didn’t know that I have to extract it twice to get the img file. My bad, it works now. Thank you for your help though!

I bought two BPI-M1 boards more than a year ago. Tested them with an Android image and then put them away. Today I tried to play with it. I tried many images I downloaded from the Download area, none of them worked, including raspbian stretch desktop, raspbian stretch lite, armbian, CentOS, etc. I also tried the image relased in this thread, specifically the Ubuntu Server. It started and then shut itself off. If I stopped the autoboot, I saw IoT> but didn’t know what to do next.

Can someone either point me to one image that will work or tell me why the ubuntu image just shut itself off in the midst of booting?

Could be your AC adapter, specifically not output enough power. Use a bigger power output like 2A or more.

Dead on! Thanks man! Both ubuntu server and armbian work now. Don’t know why raspbian (lite or desktop) still won’t work. Won’t even boot at all.

Hi all, please can you help me, we wants to use BPi M1 for the touch panels with OS Android.

What is the goal?

  • Create a image to install Android, or directly Android image. We need ideally to have a higher version of at least 5, ideal 6 or 7.
  • Anyway, on HW we want to have all the peripherals that are available - a priority
  1. Display together with touch - the display via LVDS, the touch pad is via I2C
  1. Ethernet
  2. Wifi
  3. Audio and mic

Please, create somebody image with Android (according the description), I like to pay someone for this.

Sorry about the noob question, but I’m trying to compile a module and ‘make’ gives the error :

make ARCH=arm CROSS_COMPILE= -C /lib/modules/3.4.112-BPI-M1-Kernel/build M=/home/pi/Downloads/rtl8188eu  modules
make[1]: *** /lib/modules/3.4.112-BPI-M1-Kernel/build: No such file or directory.  Stop.
Makefile:151: recipe for target 'modules' failed
make: *** [modules] Error 2

So, I tried to apt-get linux-headers, but I can't find the exact version for my system, the closest were : 

pi@bpi-iot-ros-ai:~/Downloads/rtl8188eu$ sudo apt-get install linux-headers-3.4.0-  <press tab>
linux-headers-3.4.0-1-hammerhead  linux-headers-3.4.0-5-flo
linux-headers-3.4.0-4-goldfish    linux-headers-3.4.0-7-mako

I’m not sure where to find the source, can anybody help me?

1 Like