BananaPi M1-M1P-R1 New Image : android and ubuntu sever Release 2018-07-28

This Release is for three boards BPI-M1,BPI-M1P,BPI-R1:

  1. About this release
  • BananaPi BPI-M1 Android 4.4 & Ubuntu Server 16.04 New Images Release
  • BananaPi BPI-M1P Ubuntu Server 16.04 New Images Release
  • BananaPi BPI-R1 Ubuntu Server 16.04 New Images Release

BPI-M1 Android 4.4 image

BPI-M1 Ubuntu Server16.04 image

BPI-M1P Ubuntu Server16.04 image

BPI-R1 Ubuntu Server16.04 image

2.BPI-M1 Features Map

3.BPI-M1P Features Map

4.BPI-R1 Features Map


This looks like exactly what I need. Thank-you! :sunglasses:

…what are the username and password though?

Hello, they are: Username: root Password: bananapi

I tried all combinations of banana and bananapi, but didn’t think to try root user. :roll_eyes:

Thanks =)

when will this support ov5640 camera module?

Hi there, I own a Bpi M1, downloaded and flashed the 2018-08-06-ubuntu-16.04-mate-desktop-preview-bpi-m1-sd-emmc.img image. When I boot it, the screen gets completely blank after the line “Starting Kernel”. So the board leds work and it appears that everything is running, while the screen (external monitor Samsung T23C350 connected via HDMI) is completely blank. Please help

Also [CTRL]+[ALT]+[F1] does not bring me to terminal, nor any other combination [F2], [F3], …

Hello, Please do this command in your debug console terminal:

bpi-bootsel /usr/lib/u-boot/bananapi/bpi-m1/u-boot-2018.01-bpi-m1-legacy-8k.img.gz

Jackzeng, please advise on how to enter the debug console terminal.

Hello, you can see here :

if you have any questions, please let me know.

Hello, Could you please try these commands to open camera?

  1. install gnome-mplayer
  2. echo “nolirc=yes” > .mplayer/config
  3. modprobe videobuf2_core
  4. modprobe videobuf2_memops
  5. modprobe videobuf2_vmalloc
  6. modprobe su4i_csi0
  7. mplayer tv:// -tv device/dev/video0

Hello, thanks for the new Image, but I have on Problem: my mouse is not working in the ubuntu Desktop. I installed the “Ubuntu Desktop 16.04 HDMI Version” and had to activate the HDMI Output by using: sudo bpi-bootsel /usr/lib/u-boot/bananapi/u-boot-2018.07/u-boot-2018.07-bpi-m1-8k.img.gz

Now, I can see the Ubuntu Mate Desktop, but my mouse Cursor is not moving. I have a Logitec wireless mouse with a usb-dongle. I plugged the usb dongle in all available ports, but the mouse is not moving. (it works fine on my PC).

If I look at the Output from dmesg, it seems it does not attach a usbhid device to the usb-device. There should also be device files listed in output form hwinfo. I think the usbhid module in the kernel is somehow broken. The modprobe error Points to a path that does not exist on my Image!

How can I enable the usbhid for my mouse to get it working?

Here is some Information:

	pi@bpi-iot-ros-ai:~$ hwinfo --mouse
10: USB 00.1: 10503 USB Mouse
  [Created at usb.122]
  Unique ID: sjcF.x2LcURBGx5F
  Parent ID: zPk0.Msj6MUiWa9B
  SysFS ID: /devices/platform/soc@01c00000/1c1c400.usb/usb4/4-1/4-1:1.1
  SysFS BusID: 4-1:1.1
  Hardware Class: mouse
  Model: "Logitech Unifying Receiver"
  Hotplug: USB
  Vendor: usb 0x046d "Logitech, Inc."
  Device: usb 0xc52b "Unifying Receiver"
  Revision: "12.05"
  Compatible to: int 0x0200 0x0001 "Generic USB Mouse"
  Driver: "usbhid"
  Driver Modules: "usbhid"
  Speed: 12 Mbps
  Module Alias: "usb:v046DpC52Bd1205dc00dsc00dp00ic03isc01ip02in01"
  Driver Info #0:
	XFree86 Protocol: explorerps/2
	GPM Protocol: exps2
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #12 (Hub)

pi@bpi-iot-ros-ai:~$ lsusb
Bus 004 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


dmesg after pluggin in USB donlge for wireless mouse:

[   91.658177] usb 4-1: USB disconnect, device number 2
[  678.369145] usb 4-1: new full-speed USB device number 3 using ohci-platform
[  678.650057] usb 4-1: New USB device found, idVendor=046d, idProduct=c52b
[  678.650078] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  678.650088] usb 4-1: Product: USB Receiver
[  678.650099] usb 4-1: Manufacturer: Logitech

pi@bpi-iot-ros-ai:/sys/bus/usb/devices$ tree
├── 1-0:1.0 -> ../../../devices/platform/soc@01c00000/1c14000.usb/usb1/1-0:1.0
├── 2-0:1.0 -> ../../../devices/platform/soc@01c00000/1c1c000.usb/usb2/2-0:1.0
├── 3-0:1.0 -> ../../../devices/platform/soc@01c00000/1c14400.usb/usb3/3-0:1.0
├── 4-0:1.0 -> ../../../devices/platform/soc@01c00000/1c1c400.usb/usb4/4-0:1.0
├── 4-1 -> ../../../devices/platform/soc@01c00000/1c1c400.usb/usb4/4-1
├── 4-1:1.0 -> ../../../devices/platform/soc@01c00000/1c1c400.usb/usb4/4-1/4-1:1.0
├── 4-1:1.1 -> ../../../devices/platform/soc@01c00000/1c1c400.usb/usb4/4-1/4-1:1.1
├── 4-1:1.2 -> ../../../devices/platform/soc@01c00000/1c1c400.usb/usb4/4-1/4-1:1.2
├── 5-0:1.0 -> ../../../devices/platform/soc@01c00000/1c13000.usb/
├── usb1 -> ../../../devices/platform/soc@01c00000/1c14000.usb/usb1
├── usb2 -> ../../../devices/platform/soc@01c00000/1c1c000.usb/usb2
├── usb3 -> ../../../devices/platform/soc@01c00000/1c14400.usb/usb3
├── usb4 -> ../../../devices/platform/soc@01c00000/1c1c400.usb/usb4
└── usb5 -> ../../../devices/platform/soc@01c00000/1c13000.usb/

pi@bpi-iot-ros-ai:/lib/modules$ modprobe usbhid
modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.14.55-BPI-Kernel/modules.dep.bin'
modprobe: FATAL: Module usbhid not found in directory /lib/modules/4.14.55-BPI-Kernel
pi@bpi-iot-ros-ai:/lib/modules$ ls
3.4.112-BPI-M1-Kernel  3.4.112-sun7i

hi, is there HDMI image for android 4.4?

hello, could you please try this image, I have tested it with my logitech mouse:

I will figure out this problem.

sorry, now we only have LCD version for android 4.4.

Help me pls, BPI-M1 Ubuntu Server16.04 not started openssl-server after install


Hi, am just about to get the BPI-M1 running with the 16.04 Mate image in combination with a 7 inch tft touch panel. So I used the bpi-bootsel /usr/lib/u-boot/bananapi/bpi-m1/u-boot-2018.01-bpi-m1-legacy-8k.img.gz comman in order to get the HDMI output working.

Now I am stuck with the touch panel. I think I need to use gt9xx driver as described here for the 3.4.112 Kernel. But this Image has the 4.14.55 Kernel: uname -a Linux bpi-iot-ros-ai 4.14.55-BPI-Kernel #1 SMP Mon Jul 16 23:35:40 CST 2018 armv7l armv7l armv7l GNU/Linux

point is, there is not a single modlue for the kernel available, so even depmod -a return an error message: pi@bpi-iot-ros-ai:~$ sudo depmod -a depmod: ERROR: could not open directory /lib/modules/4.14.55-BPI-Kernel: No such file or directory depmod: FATAL: could not search modules: No such file or directory

Only the modules for the 3.4.112 Kernel are available.

How can I get the Modules for the 4.14.55 Kernel with the above image?

BR Arne +

My openssl-server installation error was an error, SSL works …

Please, how can I change U-BOOT to accept the ROOT directory on / SDA1?

thank you very much


I face the same problem as Lucas but don’t have such usb-serial connection cable. Is there any other way i can enter to the debug console terminal and fix my blank display issue? Thank you


I tried to connect via ssh to check if I can fix it from there but it seems I cannot even establish a connection with the banana

[email protected]’s password:

Permission denied (publickey,password).

I type as password “bananapi” without quotes but failed to login