Banana PI BPI-M64 New Images :Debian 9.5 AARCH64 Release 2018-11-02

BPI-M64 New Image Debian 9.5 Release 2018-11-2


1.About this release

  • This release is for banana pi M64 board which is based on Allwinner A64, We release two Images, Debian 9.5 AARCH64 is based on kernel 3.10 & kernel 4.4.

2.M64 Debian 9.5 AARCH64 Kernel 3.10

  1. Features Map
  1. Image Links:

3.M64 Debian 9.5 AARCH64 Kernel 4.4

  1. Features Map
  1. Image Links:


  • How-to use ubuntu system to support lcd7?
  1. “vi /media/pi/BPI-BOOT/bananapi/bpi-m64/linux/lcd7/uEnv.txt”
  2. If you use HC070TG lcd7 screen, change “touch=gt9xxnew_ts” But if you use S070WV20 lcd7 screen, you don’t need to change.
  3. “bpi-bootsel /usr/lib/u-boot/bananapi/bpi-m64/u-boot-with-dtb-bpi-m64-lcd7-8k.img.gz”
  4. reboot image
  • Audio Codec has problem?
  1. See Here: Banana PI BPI-M64 New Images :Ubuntu16.04 & Android 6.0 Release 2018-09-18

Waiting for Google Drive …

I am in Australia and I can’t download this image, Could you please provide another link, or give us a brief on how to download the file from Baidu. Thanks

I’ve lost 3 hours today trying to setup the bananapi I just bought. The “old” google drive links seem to no longer work, the new baidu links are pretty much useless outside china (I’ve tried almost any trick available on the internet and I’ve been unable to download anything). The best I’ve been able to find is a github repo with some images gziped and splitted in several different files. And the readme file states there are quite a few things not working, like 2D and 3D acceleration.

What use can I have for a powerfull raspberry pi alternative if I can’t get the software to use it?

Right now, the bananapi is just a paperweight. And not even a good one at that.

Takeaway: don’t buy a bananapi unless you live in china.

Hi Dani, I see you are very frustrated like myself. Since yesterday that I posted my comment here, I actually made a good progress. If you go to the download page for BPI M64 and download the Raspbian Jessie and install it on your SD card, then once youre all set up and connected to the internet, use the guide in the following link, to upgrade your Raspbian Jessie to Stretch. This way we no longer need the Baidu link and don’t need to wait for someone to upload the image to Gdrive. Hope this helps you as well.

Thanks for the info Alex!

I’m not going to try it now since I’ve already spend 8hrs trying to get this board to work today. I managed to download armbian image and boot it. Problem is it’s mainline based (kernel 4.*) and there’s no 2D / 3D acceleration, so things like Kodi won’t even launch.

I’ll try your method, but I’m affraid I’ll end up with part of the hardware not working again.

I was expecting software maturity and support to be worse than raspberry’s… but this is way worse than I thought.

kernel 4.4 GoogleDrive link: md5sum : f3c2391b0232178018fda7ebfd64b14c

Hello,I have update google link.

sorry for the late reply, please check the google link.

A year ago also an image was made available for openSUSE Tumbleweed, which uses the openSUSE repository for the aarch64 architecture to provide packages on top of the kernel. I would appreciate to receive some information on how this kernel and associated packages are generated in order to upgrade the kernel and associated data with the newest available source code.

Hello,Do you mean you want to update your image with new kernel and packages?

Upgrading packages is not necessary. The packages on top of the kernel and kernel dependent packages can be done by using the repository for the aarch64 architecture for the Raspberry Pi 3B for Tumbleweed. I did this upgrade and it worked. Also a new kernel, 4.18, was generated for the Raspberry Pi 3B, but this one was not placed in mmcblk0p1. So the system with the new packages is still using the original kernel from the image of a year ago. So I am only upgrading what is in the partition mmcblk0p2 of which what goes into /boot is not used. I don’t know if this old kernel is loading newly generated kernel modules from this repository. I don’t think so. At least for my use this has no ill effects.

So my question is about renewing/upgrading what is in the partition mmcblk0p1. I have been looking around on githup for any clues how this kernel and associated elements have been generated, but I did not find anything usable for me with my knowledge. I need to see an example and will try to replace what needs to be replaced to generate what is in partition mmcblk0p1 with the newest kernel source available. Somebody must have generated that openSUSE image a year ago. I am looking for the example how this is done. Maybe I can start a project in OBS of SUSE to do that.

So I have downloaded the new Image now on my SD card and installed it on my BPI M64. However i realised that i am not able to manage the WIFI adn Ethernet connection anymore. I can see the Available Wifi around me, but can’t connect to them. And also when i use the ethernet cable, It will use a DHCP address despite the fact that I set an static address in the network manager for the ethernet connection. Could someone please help? thanks

Just an update, I was able to edit the /etc/network/interfaces file and get the static IP address for both my eth0 and wlan0 by adding these lines for both of the interfaces

source /etc/network/interfaces.d/*

The primary network interface

allow-hotplug eth0 iface eth0 inet static address netmask gateway

The secondary network interface

allow-hotplug wlan0 iface wlan0 inet static address netmask gateway

However, when i look at the network manager in the GUI it still shows me nothing and doesn’t acknowledge that the pi is connected to the network!

Same issue here, got Ethernet and WiFi working with a config something like /etc/network/interfaces

auto eth0
allow-hotplug eth0
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto lo
iface lo inet loopback

(take care you only have one iface declaration per interface) and /etc/wpa_supplicant/wpa_supplicant.conf

        # proto: listing of accepted protocols (RSN means Robust Security Network aka WPA2)
        # key_mgmt: listing of accepted authenticated key management protocols (WPA2/WPA3 still uses WPA-PSK key management but with different protocol and encryption)
        # CCMP means Counter Mode CBC MAC Protocol using AES encryption
        # pairwise: listing of accepted pairwise ciphers for WPA
        # group: listing of accepted group ciphers for WPA

Note that I had to use the hex digit representation for the password as mine include some special characters.

see also

But I indeed have the same issue, that the GUI now does not show any network (it did without this configuration but then did not allow me to properly connect, most likely due to the special characters)

Does anybody have WiFi working on the image? I have not. While it works on previous Debian image (Debian 8, as far as I remember). I’ve compared kernel boot messages and found only one significant difference (IMHO): previous Debian writes

bcmsdh_oob_intr_register OOB irq=4 flags=4084                                                                      

while the new writes

bcmsdh_oob_intr_register OOB irq=10 flags=0x4                                                                                                                                                       

And then after few similar lines I see:

Old Debian

wl_android_wifi_on: Success                                                                                        
dhd_open: Exit ret=0                                                                                               
Connectting with b0:4e:26:d9:0c:cb channel (6) ssid "MyHomeWLAN", len (10)                                         
wl_iw_event: Link UP with BSSID=B0:4E:26:D9:0C:CB                                                                  
wl_bss_connect_done succeeded with b0:4e:26:d9:0c:cb                                                               
wl_bss_connect_done succeeded with b0:4e:26:d9:0c:cb                                                               

New Debian

wl_android_wifi_on: Success                                                                                                                                                                         
wl_create_event_handler(): thread:wl_event_handler:7f2 started                                                                                                                                      
tsk Enter, tsk = 0xffffffc067d61a70                                                                                                                                                                 
CFG80211-ERROR) wl_update_wiphybands : error reading vhtmode (-23)                                                                                                                                  
dhd_open: Exit ret=0                                                                                                                                                                                
dhd_stop: Enter ffffffc057e37000                                                                                                                                                                    
dhd_set_mcast_list_handler: interface info not available/down                                                                                                                                       
dhd_set_mcast_list_handler: interface info not available/down                                                                                                                                       
wl_event_handler: was terminated                                                                                                                                                                    
wl_destroy_event_handler(): thread:wl_event_handler:7f2 terminated OK                                                                                                                               
CFGP2P-ERROR) wl_cfgp2p_disable_discovery :  do nothing, not initialized                                                                                                                            
CFGP2P-ERROR) wl_cfgp2p_deinit_priv : In                                                                                                                                                            
wl_android_wifi_off in 1                                                                                                                                                                            
wl_android_wifi_off in 2: g_wifi_on=1, on_failure=1                                                                                                                                                 
bcmsdh_oob_intr_unregister: Enter                                                                                                                                                                   
dhd_txglom_enable: enable 0                                                                                                                                                                         
dhd_conf_set_txglom_params: swtxglom=0, txglom_ext=0, txglom_bucket_size=0                                                                                                                          
dhd_conf_set_txglom_params: txglomsize=0, deferred_tx_len=0, bus_txglom=-1                                                                                                                          
dhd_conf_set_txglom_params: tx_in_rx=1, txinrx_thres=-1, dhd_txminmax=1                                                                                                                             
dhd_conf_set_txglom_params: tx_max_offset=0, txctl_tmo_fix=1                                                                                                                                        
sdioh_set_mode: set txglom_mode to multi-desc                                                                                                                                                       
dhd_bus_devreset:  WLAN OFF DONE                                                                                                                                                                    
wifi_platform_set_power = 0                                                                                                                                                                         
======== PULL WL_REG_ON(-1) LOW! ========                                                                                                                                                           
wl_android_wifi_off out                                                                                                                                                                             
dhd_stop: Exit                                                                                                                                                                                      

WiFi Firmware version is the same. WiFi driver versions are 1.363.59.144.10 ® now and (r506368) in old Debian.

iwconfig says wifi interface has no wireless extensions, while in old Debian everythig is good.

Any ideas how to start WiFi?