Armbian Buster 10 updated (2019-09-02)

I’ve made a updated and fixed image for BPi-R1.

Download link

Account credentials:



It’s updated and has the same features as the previous one, only fixed:

  • A fault with armbian.list. It’s fixed now.
  • armbian-firmware kepted back, otherwise it breaks the system.


  • DNSMasq on LAN after second reboot (WiFi is working fine). Then it doesn’t work. Maybe someone knows a fix for that.

Link to previous version:

New updated version with new kernel

1 Like

Hi, thank you, image is great … 1/ I updated configuration, remove all X+ packages to keep it as a base image
2/ I removed --purge old unconfigured packages (dpkg -l | grep ^rc)
3/ I removed obsolete packages from jessie except 2
4/ I moved base installation to HDD + tuned HDD (Hitachi Travelstar 5K320) + tuned armbianEnv.txt to point HDD
5/ Wifi was disabled (I don’t need router, only switch + board with sata disk)
6/ I made cleanup of all network settings, disabled RA + some additional security stuff etc…

TODO : disable log2ram, repair cgroups

But my question is simple, about packaging …
root@bpi-r1:/etc/init.d# dpkg -l | grep lamobo
ii linux-jessie-root-next-lamobo-r1 5.31 armhf Armbian tweaks for jessie on lamobo-r1 (next branch)
ii linux-u-boot-lamobo-r1-next 5.31 armhf Uboot loader 2017.05

I don’t know anything about this two packages, I am afraid to remove it in “next-boot” case and update u-boot to standard distro u-boot. Do you have more info about this packages ?

P.S : I know, this packages must be hold : …
armbian-firmware linux-dtb-next-sunxi linux-headers-next-sunxi linux-image-next-sunxi

root@bpi-r1:/etc/init.d# journalctl --priority 3 | tail -n 5
– Reboot –
Dec 22 16:23:13 bpi-r1 kernel: /cpus/cpu@0 missing clock-frequency property
Dec 22 16:23:13 bpi-r1 kernel: /cpus/cpu@1 missing clock-frequency property
Dec 22 16:23:13 bpi-r1 kernel: bcm53xx stmmac-0:1e: failed to register switch: -517
Dec 22 16:23:13 bpi-r1 kernel: cgroup: cgroup2: unknown option “nsdelegate”
root@bpi-r1:/etc/init.d# systemctl is-system-running
root@bpi-r1:/etc/init.d# lsblk
sda 8:0 0 149.1G 0 disk
├─sda1 8:1 0 1G 0 part
├─sda2 8:2 0 4G 0 part [SWAP]
├─sda3 8:3 0 45G 0 part /
├─sda4 8:4 0 1K 0 part
└─sda5 8:5 0 99G 0 part
└─bpidg-journald_log 254:0 0 2G 0 lvm /var/log/journal
mmcblk0 179:0 0 14.5G 0 disk
├─mmcblk0p1 179:1 0 3.9G 0 part
└─mmcblk0p3 179:3 0 10.7G 0 part


Hello rexxor!

I’ve just read your post. I don’t really know for sure what’s happening when you delete the packages. I made this image some time ago from the official website (the image doesn’t exist any more on the Armbian website). If I’m correct, some packages broke the installation when I was trying to remove them, that’s why I kepted it back. It sounds interesting what you made now. Are the LAN ports now working? After some reboots, it won’t work any more (when I was trying to make it work). Anyway, I suggest you to make a backup image with dd and optionally shrink them with pishrink. If you run Linux you can back it up with dd if=/dev/sdX of=myimage.img where X is your drive letter. sd is only used when it’s a usb port and not a card reader builtin, for example, a laptop. The second thing is trying to remove the packages. I advise you to first test the backup on another micro sd, before removing the packages. The only thing I’m not sure about is that you used your installation to the hdd. I can try to build a new image based on this image and test it. But I don’t know when I make that image. This is the information I have at the moment. By the way, did you try to search the problem on Google?

Have a nice day! mhog

Hi, I have no problem with image, or transfer it to HDD, its already done. Everything works.
I have copy of original OS ( because this OS is on flash disk mmcblk0, I modified only HDD copy.)
LAN ports : all ports (1 - 5) are fully working as a switch with default vlan, aka vlan1 …
WIFI : is disabled (‘blacklist rtl8192cu’ in /etc/modprobe.d/rtl8192cu.conf) + servicies.
HDD : lvm2 installed, updated ramdisk (update-initramfs -c -k $(uname -r)) and layout is up (i reserved first partition to some tests). Copy of OS was provided on my notebook with dd from your image mmcblk0 to sda3. Then resize2fs on mounted /dev/sda3, and change UUID with (tune2fs /dev/sda3 -U random; blkid; and after boot on bpi : update /etc/fstab with correct UUID, and /boot/armbianEnv.txt)
root@bpi-r1:/etc/init.d# cat /boot/armbianEnv.txt
(please update this on mmcblk0p1 too…)
root@bpi-r1:/etc/init.d# cat /etc/fstab
#UUID=1a3062ee-4086-4432-8d19-f5d673d5cdd6 / ext4 defaults,noatime,nodiratime,commit=600,errors=remount-ro 0 1
UUID=11c97085-c6cd-4a41-8a64-fbae776113f5 / ext4 defaults,errors=remount-ro 0 1
tmpfs /tmp tmpfs defaults,nosuid 0 0
UUID=c5179778-05a2-4eeb-aeb3-17dd172d347f swap swap pri=10 0 0
UUID=c219805f-27c0-4a73-b614-49334ff3a791 /var/log/journal ext4 defaults 1 1

and run updateramdisk again to write it to ramdisk.
etc … if you are courious I am able to describe it somewhere … but you know, I am not a native speaker to write some public howtos :wink:
There is some another tunning like :
root@bpi-r1:/etc/init.d# tail -n 5 /etc/hdparm.conf

/dev/disk/by-id/wwn-0x5000cca5e5c99262 {
spindown_time = 120
apm = 127

If you need some additional info or create dd copy of instalation, please write me to my nick at seznam dot cz. Have a nice day f.

Thank you for providing info! I will make a new image in future!

By the way! Here’s a link about someone who has problem with updating: he kepted back the next-root package also.

I will remove some “stuff” like a logging into separate partition and I will provide you my image to compare it … because there is still no additional sw, only clear server OS without gui and disabled all old stuff … I will provide some text what were changed (or better I will keep all logs.) You can check it with diff.
Next thing is what is wanted … if image where wifi+eth0.1 are bridged in same vlan as LAN, eth0.2 in different vlan as WAN, I can try it … My config is eth0 on “virtual port 6” in same vlan as port 1…5 (LAN1,2,3,4+WAN). WIFI is disabled.
I don’t need wifi, because I have separated ASUS AP and this BananaPi-R1 is LAN switch with Debian on SATA disk, prepared for HomeAssistant (a lot of logging - reason for SATA disk) and another ‘write sensitive’ services. For vlan+switch I need to read kernel documentation because I saw both kernel drivers active. I have disabled bridging and vlan tagging, then everything is on one segment with one eth card on system. f.

I’ve just made a ‘clean’ Armbian image without dnsmasq and hostapd installed. eth0 is set to dhcp. That’s because everyone then has a clean image to make what they want.

Your idea sounds interesting. I tried the SATA disk some time ago, but then the LAN ports stopped working. I’ve read somewhere that you need some code. But first a clean image to work with, then I can try some things to make it work better. Maybe I make a desktop GUI with IceWM and xrdp. The idea of ‘a router with remote connection’ sounds interesting. But the main thing is that I want the Banana Pi to work as a router and that’s difficult without physically seperated LAN ports. But I like to hear more from your image. Maybe you can upload it on the forum if you want? Tomorrow I will upload a new ‘clean’ image.

Ok, please provide me a clean image of OS without any graphical installation without any additional sw, like dhcp, wifi management, Network Manager etc. I will try to configure DSA switch with and I will try to change aging of fdb table records, STP on port etc. We will see if we are able to have functional “router” with sata disk on banana pi r1 :wink: I will backup my image (based on your) first and I will upload it here.

Hello rexxor,

I’ve made a new, more clean image based on this image. Link to topic: Armbian Buster 10.2 for Lamobo R1 - 2019-12-23


Hello mhog :wink:
I have made dump of my image (based on your previous image), it is simple dd of /dev/sda3 (/ ) partition. Switch is in ‘silly mode’ switching between all ports on one vlan.
br0 has IP … ssh is enabled. Logins are same …
14 days to download it, it is not in production state … I will try your new image.

Net config in /etc/network/interfaces is commented.


Thank you! I will test it out…