2020-04-21: Armbian Buster (4.19.62-sunxi) Preview/Test-image - Lamobo/Banana Pi R1

Hello (B)Pi-fans!

Recently I tried to do a clean installation of Armbian and upgrade and tweak it. I think its kernel crashed after 30 mins (upgrading from old to new kernel and upgrading old image), because I did Armbian packages on hold. It now has an uptime from 1 hour and 27 minutes! My question is: Can somebody test this image and report what works and what not works?

Thank you in advance!


Website: www.mhog.nl


Regular user: pi/bananapi

Super user: root/bananapi

Download link: https://www.mediafire.com/file/m3602lp9wt2ryc1/2020-04-21-armbian-buster-lite-k419.img.zip/file


This version seems stable, did not had a crash (yet) and I have done some stuff on it (apt update, upgrade, installed transmission torrent client). Max uptime before shutdown was about 3 hours.

As I have mentioned the other prost for Bullseye testing, I am trying to compile the Ralink RT5572 but linux headers on this version seem to be partially present (it cannot find modules.h) or I am doing something wrong (just downloaded the driver and ran “make”). I also had to uninstall “armbian-firmware” and “armbian-jessie-tools” packages to get to this error.

I remember having random freezes on other linux versions but it was due to poor power supply. Now I am using the battery connector with a short cable (under 1 meter) and a 60W AUKEY power brick which is a bit exagerated. The mircoUSB is used just as a button to start the device as I have a case with no easy access to the two buttons, after which I unplug the microUSB and rely only on the battery connector.

I’m an idiot. I’we found the wifi interface, it was listed as “wlx38a…” (loaded by the included module “rt2800usb”) no need to compile anyhting anymore (think it was the same name on the Bullseye build also). Was expecting to see something like “wlan0” like on older debian versions.

WiFi works good, Anyway, I have tried installing a desktop environment (like LXQT) but when issuing a startx, it says:

(==) Log file: "/var/log/Xorg.0.log", Time: Sat Nov 14 18:49:13 2020
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
gbm: failed to open any driver (search paths /usr/lib/arm-linux-gnueabihf/dri:\$${ORIGIN}/dri:/usr/lib/dri)
gbm: Last dlopen error: /usr/lib/dri/sun4i-drm_dri.so: cannot open shared object file: No such file or directory
failed to load driver: sun4i-drm
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.

I am guessing that the graphics drivers do not work.

Also, crda is broken, had to replace with files found here.

Thank you for your comment. I did stop working on the images. Maybe I can take a look at it if I can fix it. Thank you for the log file by the way. I’ll let you know what I can do.

I wish you a nice day and thank you for your comments!