Armbian 23.8.1 on my Banana PI M2 Zero

Today I deiced to try a new version Armbian so I download Armbian_23.8.1_Bananapim2zero_jammy_current_6.1.47_minimal

I adjusted the first boot config file “/boot/armbian_first_run.txt”

Result … No WiFi and the keyboard didn’t work


I download an older image … Armbian_21.08.1_Bananapim2zero_hirsute_edge_5.13.12.img

I used the same first boot config file “/boot/armbian_first_run.txt”.

After first boot I could log in with ssh

What do I miss ?

There are several things you are missing:

  • Armbian is provided by non-profit driven project (not by Bananapi) and its not a commercial product. It comes without any warranty whatsoever.
  • feature armbian_first_run.txt for setting WiFi at first run was sent to OS about 8 years ago and is since then unmaintained. If it worked until 2021, it was by pure luck. Features, if not maintained, starts to fall apart. This is open source, sources = GitHub - armbian/build: Armbian Linux Build Framework = check if you can fix it for you and everyone else.
  • you are at HW vendor forum. They sold you a PCB with a chip while they have little to do with this software, even it runs on this device. Armbian is different project, but despite that, its impossible to verify if all features still works on kernel upgrade (valid also for 1st class desktop PC world). Only few are being checked - system was financed without any public help. Testing is often impossible also in professional development. Even problems is detected, who will pay to fix it for you? There is almost complete absence of your support to support you Sponsor @armbian on GitHub Sponsors · GitHub - armbian's profile - Liberapay Why would anyone even listen?

When you find where this code exists, proceed here:

Im using this: Bananapi P2 Zero and M2 Zero Armbian_bookworm

and for now, its working fine


Q: Did the WiFi work ?

Yes, did you configure it with armbian-config?

I did but the config I used for Armbian 21 didn’t work … I also tried to configure the WiFi from /etc/rc.local but it failed

Perhaps I should remove/disable the Network Manager …

I configure the WIFI from armbian_config command

I have reinstalled using Armbian_21.08.1_Bananapim2zero_hirsute_edge_5.13.12.img and added ubuntu updates

Wifi setup from armbian_config worked fine and after I added my ssh public key I could log in without any more problems.

With the newer version of armbian it didn’t work.

Try it first out of the box, do not update anything.