2020-04-26: Armbian Bullseye Testing (kernel: 5.6.5-sunxi)- Preview/Test-image - Lamobo R1

Hello everybody!

Here’s my new image: Armbian Bullseye Testing. This is the current testing image of Armbian/Debian and the upcoming stable release. I hope you enjoy it! You can always report what works and doesn’t works. Tested one night and day.

Kernel: 5.6.5-sunxi

For board: Lamobo/Banana Pi R1

Credentials: pi/bananapi and root/bananapi

Website: www.mhog.nl

Download link



1 Like

Does your image supports LCD 7" display? I’m looking for solution for my issue http://forum.banana-pi.org/t/lcd-module-dsi-rgb-with-touch-and-s070swv20hg-dc16-lcd-panel-mainline-kernel/11172

Official Armbian + https://forum.armbian.com/topic/7233-bananapi-pro-7-touchlcd-with-debian-buster-and-mainline-kernel-5xxxx/

Thx. but i’ve tried this already - not working :(. I have Lamobo R1 so i guess that pin layout is different (and it is rgb not lvds)

Oh - and i use gentoo not armbian (but if you know armbian image that works with this LCD on Lamobo R1 let me know :wink: i will try to pick differences and maybe … i will put them into my gentoo :wink: )

R1 pin layout = identical to banana. Use Armbian.


To be fair: I don’t know. But you can try it. This is because I don’t have a LCD screen by myself. Please let me know if you’re willing to test it!

Thank you for your question!

Wish you nice day!


So i will give it a shoot :wink:

I’ve tried all possible combination with Armbian(i have docker build enviroment), for bananapi and lamobo-r1 with lvds and without it … nothing works. I think it is related to driver(simple-panel) this driver - according to modinfo - doesn’t have support for my panel. I have s070swv20hg-dc16 not s070wv20-ct16(which is supported by the driver).

Here is some more info: LCD module(DSI+RGB) with touch and S070SWV20HG-DC16 lcd panel + mainline kernel

Made some progress - u-boot is displayed on screen but linux doesn’t :frowning:.

I have the Ralink RT5572 wifi hardware mod and cannot compile the drivers because of the missing linux header files. Remember having this problem many times before with older versions, but for this kernel I could not find any precompiled packages.Worst case scenario I will have to learn to compile armbian myself (currently reading the info found on the github repo).

UPDATE: the wifi works fine, it has one of those predictable names.

Knowticed that my device crashes after a bit, ussualy if I restart it after at least 20 mins. Turns out that “unattended-upgrades” starts in the background and breaks the device, had to power it on without an internet connection and apt remove that package. Also if you do an apt-upgrade after reboot all devices are broken, you get the login screen but cannot use any keyboard, no wlan, no lan for ssh…