Won't Power On - M64 v1.2

I tried to power on the Boot but it wont pass the boot screen passing control to the kernel.

then I checked the SD card /boot partition and tried to insert the card again in the boot to start it.

Next thing it wont even power on anymore. The red light just flashes very dim which is hard to even notice and no respond from the board at all.

It was only working over micro-usb connector for power, As DC power never helped in booting the OS. The board would power down during the process of staring the linux kernel over DC Power.

I don’t know what to do. Anyone else facing this issue please advice.


@sinovoip Any advice on this ?


3 days and no update on this?

It’s a bummer. Gladly never faced this kind of issue. Did you check the voltages on the GPIO pin header, if the voltages actually at least reach them? Did you check the board if ther eis any evidence of a burned through circuit, cold solder joint or messe up solder joint? How far into the booting process does it get on the UART? Did you try a different SD card with a different kernel?

Anyhow already strange that it only powered by micro-usb and never via DC power. Are you sure the DC power is actualy providing 5V inside, ground outside of the barrel and not reverse (Some universal power supplies can be switched)

Hello Dear, Thank you for the reply but I was expecting the BPI team to respond.

No I didn’t check any Voltage yet. There is no evidence of burnt circuit or any component. The last thing I remember, is it was working fine and I wanted to try a built with Lima and after that it never powered on.

There is not power on the board to check the UART Log All I see it the red light turn on very dim for like a millisecond and done, no response after that. Nothing on Screen or UART.

Yes I tested the voltage of my Power supply it is 5V,3A and also tested with it connected. I will do some more test tonight. And if the grounds were reversed then it wouldn’t even power on and read the UART when the board was in working condition.

I hope BPI team can advice which points to read voltage at to pin point the issue, As I had some problem with other SBC who adviced me to do a voltage readings and short readings to understand what is wrong with the board.

Thanks again for the response.

Hey. Try using the battery connector or the power input port other than the micro-usb. The micro-usb is intended for data transfer and not for power input. Regards.

Hello thanks for the idea, I will try that. But my device is working fine with micro usb power only. If I use dc barrel pin it does in kernel boot while the same works on micro usb power.