Wicd don't work on the new Ubuntu 16.04 [2016-07-21]

Hello guys,

I have a big Problem… I try to install Wicd because I don’t like the Network-Manager, usually that always works fine but now I get the following error:

root@bpi-iot-ros-ai:~# wicd-client Traceback (most recent call last): File “/usr/share/wicd/gtk/wicd-client.py”, line 40, in import gtk File “/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/init.py”, line 40, in from gtk import _gtk ImportError: /usr/lib/arm-linux-gnueabihf/libgdk-x11-2.0.so.0: undefined symbol: XRRGetMonitors

I use the following Industruktion for the installation.

hopefully someone can help me

greetings root_Padi

Hi root_Padi,

I know your question wasn’t from yesterday, but I can’t leave it unanswerred. I’ve faced the same error message yesterday trying to run bleachbit and youtube downloader gui on ubuntu 16.04.

My solution was (maybe there are better ones, but didn’t found any others):

$ ldd /usr/lib/arm-linux-gnueabihf/libgdk-x11-2.0.so.0 | grep libXrandr
libXrandr.so.2 =>/usr/local/XSGX/lib/libXrandr.so.2.0
$ cd /usr/local/XSGX/lib
$ sudo mv libXrandr.so.2.0 libXrandr.so.2.0.bak

Source: http://askubuntu.com/questions/769258/problems-with-libgtk-after-upgrading-to-16-04

Cheers, tng

1 Like

Hi tango,

thanks for your answer ! :slight_smile: But at the moment im done with BPI…

I just wait fot the mainline kernel because I want to use my external USB-WIFI-Adapter TL-WN722N and not that ‘$#@%!’ Onboard-Wifi :zipper_mouth:

Have a nice day,

greetings root_Padi


having much time for hacking, you can give it a chance:

On the other hand I do understand postponing it. :slight_smile:

greetings tng


first sorry for my bad english :smiley: Is that driver from github really working ? I tested so many drivers but nothing works, or you need things like mainline kernel or other, at the moment unsupported things…

But thank you, I will try it… :slight_smile:

You know, I’m angry because all the new BPI-Boards, the M3 costs me 90€+ and the Images are so old, that nothing works good… You also need one day to update the Image, and and and…

greetings back

:skull_crossbones: SHAME ON ME !!! :skull_crossbones:

My Adapter TL-WN722N is WORKING !!! :heart: :heart: :heart: It was not the driver, I only miss one line at /etc/network/interfaces !!!

I’m so $#@%! stupid !!!

I can’t believe it I am so sorry

Jesus I tried everything so long and now it’s because one $#@%! line.

:skull_crossbones: SHAME ON ME :skull_crossbones: