Where is the BPI_B2Z raspbian image?

Hello everyone, I need help. I see the official user guide from Getting Started with M2 Zero - Banana Pi Wiki which uses the BPI_B2Z raspbian image. But where can I download that image? I can’t find it in the official image. Thanks for your help.

Hello, I will upload the image later.

Great! Thank you. At present, I am using the 2017-09-19-ubuntu-16.04-mate-desktop-preview-bpi-m2z-sd-emmc.img. But I can’t connect the wifi. I can search the wifi but can’t connect it. I am confused .

Hello,please see here:

Hello Jackzeng, Thank you very much for uploading the raspbian image . I have downloaded and burned it into my SD card. But I have two questions:

  1. How can I connect the wifi? It says that No wifi interface found.
  2. I want to test the function of camera. I use a OV5640 camera with the same interface as the official’s but not the official camera, when I use the guvcview, it says that error no found the video device. I don’t know why when I run sudo lsmod, I can see the v4l2 driver. Can you explain that in detail for me? Do I have to use an official OV5642 camera?

Thanks for your help. Looking forward to your reply.


  1. if you use raspbian, please wpa_supplicant to connect wifi,Here is the way to connect Wifi: http://wiki.banana-pi.org/Getting_Started_with_M2_Zero#WiFi_Client

  2. We support ov5640,I have no idea about OV5642,probably need to add driver to it.


Thanks, I have connected the wifi through the command. I am using the OV5640 camera not OV5642. Sorry for my error write. After I run ‘ls /dev’, I can’t see the video device. I have installed the V4L2 driver. Any ideas?

How did you connect 5640 with m2z? could you show me the picture?

it’s better, if you show me your 0v5640.

Now,we only support our own module,so if you use other manufactures’ ov5640, m2z probably don’t support it. you may need to change the gpio pin in driver to support it.


Thank you very much. The below picture is my hardware connection jpg and after I run lsmode command I can see as below shows: lsmode

Hello Jackzeng,

The interface of the camera I am using is the same as the official OV5640 camera, I don’t know why it can’t find /dev/video0.


I think it’s probably our modules’ gpio pins are different with yours, you may need to change gpio pin in driver to support it.

Hi, This is our camera’s pin definition pinDef

Hello, this is for ov5640 interface on M2Z(CSI), it looks like it is right



OK. Thank you very much. After I burned the raspbian system to the SD card, I connect the camera. Do I need do others? Do I need to install other drivers or just run the shell files which is in the user/local/bin? In the shell file, I see you have modprobe the v4l2 and OV5640. I think I don’t need to do any other operations but just run the shell command. Right?

Hello,I think you just need to do /user/local/bin/ , we have v4l2 driver in image.


I think so. I don’t know why. Maybe the camera interface of the bpi board is defective. I have tested two cameras and none of them work.