Using ft232 on banana pi r2

Hello I use deb_strech 4.14.80 on BPI R2 . When I plug in FT232 I see the information of USB driver under lusb but I can not see ttyUSB0. Please help me Best regards

You need to add driver to kernel like you tried here…why a new topic?

I upload image deb_strech4.14.80 to my sd card then I insert SD card to my banana pi after boot I follows steps in your repo , I select FT232 and pl2303 driver in config menu and i select SD card . I did not got error. but i did not work.

you have to change uEnv.txt to your new file (kernel=filename)

you should at least see your new kernel-version when execute “uname -r”

compiling on r2 is terrible slow so compile on x64 linux (e.g. ubuntu) and install to card

i’m not sure install works when compiling on device itself (compilation should)

1 Like

Hello I did it just like you sad and it works. At my first try my old computer which has ubuntu 22.04, I got BPI-ROOT not mount ERROR. But after i set up ubuntu 22_04 on my new computer and repeat process , it worked .