Adding usb2serial module kernel 4.14.80

Hello I have a BPI R2 and i am using 4.14.80-bpi-r2-main kernel. I want to use FT4232 but when i plug in the ftdi i only see usb device, I could’nt see usb to serial i search about this problem and in the blog i saw there is no usb module in the kernel. Could you help me for adding usb module? I tried sudo apt install linux-modules-extra-$(uname -r) but i got error of

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: Unable to locate package linux-modules-extra-4.14.80-bpi-r2-main

E: Couldn't find any package by glob 'linux-modules-extra-4.14.80-bpi-r2-main'

E: Couldn't find any package by regex 'linux-modules-extra-4.14.80-bpi-r2-main'

The kernels for bpi devices are self compiled from my github repo and not available in ubuntus apt repository.

So just clone my repo,switch to the kernel branch you want,import defconfig, add your options you want in defconfig,compile and install

i do not know anything about linux kernel compiling . Should i install your repo to my sd card?

No clone repo to an x86 linux system if available compile there with crosscompiler…more information in readme of my repo

i did it it creates BPI-BOOT and BPI-ROOT what should i do now?

You mean the folders in the tar.gz archive? You can install kernel/modules directly to card. The folders in tar.gz file stand for the partitions on card…there is a fat partition named BPI-BOOT (copy contents of this folder there => kernel-binary) and an ext4 partition (rootfs) named BPI-ROOT. Here the content of samed Folder (modules) have to put here.

Have you got any documentation about adding kernel. I always got BPI-ROOT not mounted errot when i tried to install sd card. and how can i edit uEnv.txt

Which host system do you use? I use ubuntu and there the sdcard partitions are mounted automaticly. If not you can try “./ mount”

The partitions need to be mounted to /media/User/BPI-[BR]OOT (default in ubuntu,maybe with underscore)

Documentation as far as available is in repo itself ( of default branch) or in my wiki

uEnv.txt is on bpi-boot partition where uImage is (bananapi/bpi-r2/linux),if none is there just create one and use


Where uImage is your filename without path in same folder as uEnv.txt

Thank you but I did not run it

A bit more information will be useful.

Make sure your sdcard (with my image already flashed to it) is correctly mounted (/media/$USER/BPI-BOOT and BPI-BOOT). If not mounted try “./ mount” after card is inserted. command “mount” shows your mounted filesystems. If any error is printed post it.