Using Debug UART

Yep, it is the correct device. If it wasn’t, I wouldn’t even see garbage. ttyAMA0 ist the device on Raspi.

But now I might have found something. I googled “prolific serial to usb garbage” and found a bunch of articles talking about poor hardware and even poorer drivers. Let’s see if I have something different in the workshop :slight_smile:


I just remembered the usb2ftdi cable which I used to program mini arduinos. fetched it from the workshop and without any further doing I get a login screen.

Thank you very much for your patience with an old man. Problem closed :smiley:

nice to hear that, strange that it works with rPi i’m using an CP2102 USB2Serial-adapter (circuitboard)

obviously those Prolific Chips are somwhat … buggy!

beginning with my own wiki about Bananapi-R2, here the Page about Debug-UART:

suggestions welcome :wink:

Ok thx its works, :slight_smile: but i get weird characters… have you seen something like that? could not start the image from sd, 2018-01-04-kali-xfce-desktop-v1.0-bpi-r2-sd-emmc.img also with other images no success, need help, thanks for that. i read in the forum and hope to have understood a lot burton

Some chips are not stable enough (e.g. profilic) thats why i suggest cp2102-chipset my adapters with that working stable.

your screenshot is hard to read…but the textoverlay says right options…

maybe you can another gnd…id don’t know if all GNDs are connected in these strange DB9-connectors

Adapters with prolific Chips do not work at all! I also had that problem until i tried a ftdi-to-usb adapter. :wink:

Maybe I’m incorrect here, but is that digitus device providing TTL lines? A serial port on the back your PC for example is a different electrical interface from the one on the PCB. Usually something like a MAX232 is used to convert from TTL to RS232… but I would get a device that converts TTL UART to USB directly.

these do i use currently:

small (i will build in my case), cheap and working fine :wink:

w:16mm x l:20mm x h:5mm (30mm long with my angulated pins) paired with a magnatic micro-usb-cable (ät-Kabel-Kabel-für-Android-Handy/302441586097 ) perfect for case

For this reason I have ordered a couple of MAX232 modules with 9-pin standard rs232 jacks. No banana without a Max any more :slight_smile: With this you can use a simple RS232-to-USB adapter

Look here:

Hi I tested it on my Linux notebook again. This one has a COM port, with the same result. @frank i can buy one, but it seems strange. Otherwise you have tips for me…thx burton

:warning: please do NOT :no_entry_sign: use a real Com-Port!!! RS232 has 12V you damage :zap::fire: your board TTL=5V

you can use my reg-file from the another thread, there are all settings included (also the character-processing) which can be a Problem. or using minicom with the settings from my wiki

used icons so that this line is found easier when scrolling through (not for playing around :slight_smile: )

I measured it = 5,6V :slightly_smiling_face:

Well to keep it simple: the UART on the R2 boart are NOT compatible with any RS232 converters. Okay?

thanks for the information (frank & ntech, I have a compatible CP2102 ordered and wait for the delivery… I hope that brings me closer to my goal :sunglasses: By the way, a great forum for me and my BPI-R2-V1.1. Many Thanks

This is for !! BANANA PI M3 v1.2 !!

After a lot of searching, reading etc. I managed to connect to the serial console using a usb to serial adapter that has the FTDI - FT232RL chipset.

The cabling is like this: [WINDOWS PC]----[USB2Serial Converter]----[SERIAL CABLE]----[OLD DB9 PLUG]----[3wires][BANANA PI M3]


  1. From the old db9 plug I got 3 wires connected to the pins on the Banana Pi M3 board on those 3 pins located near the LAN. From the DB9 pins I connected them like this: -Pin5 on DB9 which is the GND to GND on Pi -Pin3 on DB9 which is TX to RX on the Pi -Pin2 on DB9 which is RX to TX on the Pi

  2. I connected with Putty on the Windows machine using these settings: Bits per second: 115200 Data bits: 8 Parity: none Stop bits: 1 Flow control: none

  3. At this stage when powering the bannapi I would get a lot of scrammbled (garbage) chars on the screen…

  4. [THE FIX] To fix this I had to rewrite the EEPROM of the usb2serial converter. This was easy and everything went as expected. Rewriting the EEPROM: I installed this program: I saved the current state of the EEPROM and then I reprogrammed it to use inversion like this: inversion-applied I wrote the EEPROM and VOILA!!! proof Now I have a console on my BPI M3! Hope it helps someone else!

ps: maybe a moderator can suggest a better place for my post in the BPI M3 section…

Hi MrFulop – Madness this information, thanks for sharing this with me. I tested it but unfortunately it does not seem to work on the BPI-R2-V1.1… the same result as before, i hope amzn will send me the TTL adapter soon. but thanks anyway



Hi @burtonhill!

From my understanding Banana M3 is quite different from M2 so what worked for me (on BPI M3), might not work for you on M2… If I would be in your place I would try this:

  1. reset your usb2serial converter (EEPROM) to its original state - no inversion.

  2. recheck the 3 pins on the BPI and be sure you have them plugged as disscussed: Pin5 on DB9 which is the GND to GND on BPI Pin3 on DB9 which is TX to RX on the BPI Pin2 on DB9 which is RX to TX on the BPI

  3. Connect your serial, recheck putty settings: Bits per second: 115200 Data bits: 8 Parity: none Stop bits: 1 Flow control: none

  4. see what you get… If you still get scrammbled chars try to apply the inversion on the converter

  5. go to step 3 and see if you get a better output…

Good luck!

first of all, thanks to all :slight_smile:

all problems solved with the adapter, great thanks :blush:


my steps to the running system, maybe it helps someone
image–> 2017-11-28-ubuntu-16.04-mate-desktop-bpi-r2-sd-emmc.img
preloader–> BPI-R2-EMMC-boot0-DDR1600-0k-0905.img

Hello, I try to boot from SD card a new BPI-R64. USB-Serial log output just: “System halt!” after buttons: Reset or 10sec Power/Recovery. F0: 102B 0000 F5: 4801 0000 F5: 480A 0031 F3: 4000 0036 F2: 300C 0000 00: 1005 0000 F5: 480A 0031 F5: 480A 0031 F3: 4000 0036 F2: 300C 0000 01: 102A 0001 02: 1005 0000 BP: 0000 00C0 [0001] T0: 0000 0357 [000F] System halt!

Also no any light on Ethernet cable connected to 1Gig Wan. Any suggestions, is this a problem with the device?