Using Debug UART

The R2 runs like a charm, I’m connected via ssh. :slight_smile:

The setup works with Raspi’s, Oranges, Arduinos and my Banana pro as well.

On the other Side of the serial2USB I have an elderly Notebook with Debian Wheezy

Is there any serial configuration about the Bootloader? I could take a look?

maybe you can/haveto re-flash bootloader…have done this before?

but be careful,this step can brick your device.

As i said, my r2 works out-of-the-box regarding debug-uart

Nope, never did that before, and I don’t think it is a good idea. A serial console certainly is nice to have but I would’nt go any risks for having it. Maybe future images have a different serial behaviour :slight_smile:

But anyway, Thank you very much for your help. I really felt like a complete noob in this case (which I’m normally not) :smiley:

again, the image on SD is independent from debug-UART on R2…later you set env-Vars to change this behaviour, but uart should work at least till first read of SD-card to debug Problems before that

bpi-r2 has a nice boot-menu you can select emmc-start (empty on my r2 so i did not tried it out).

now i’m out of my knowledge, maybe some tech (gary,sinovoip) can give an hint

That sounds interesting but I’m afraid I won’t ever get to see that menu :frowning:

In the meanwhile I tried a different Notebook (just to make sure) and i played with stty. It seems to me that something in the background works as if it was a login prompt (not readable however) but i can enter something and there is some kind of response.

I just started the r2 without SD-Card and without harddisk and ttyS0 didn’t do anything.

you use the right usb-device? as i remember some systems (rpi outgoing) create a ttyAMAx/ttyACMx-device which is same HW, but different driver. but if rpi works…i use same cable/settings/application

Yep, it is the correct device. If it wasn’t, I wouldn’t even see garbage. ttyAMA0 ist the device on Raspi.

But now I might have found something. I googled “prolific serial to usb garbage” and found a bunch of articles talking about poor hardware and even poorer drivers. Let’s see if I have something different in the workshop :slight_smile:


I just remembered the usb2ftdi cable which I used to program mini arduinos. fetched it from the workshop and without any further doing I get a login screen.

Thank you very much for your patience with an old man. Problem closed :smiley:

nice to hear that, strange that it works with rPi i’m using an CP2102 USB2Serial-adapter (circuitboard)

obviously those Prolific Chips are somwhat … buggy!

beginning with my own wiki about Bananapi-R2, here the Page about Debug-UART:

suggestions welcome :wink:

Ok thx its works, :slight_smile: but i get weird characters… have you seen something like that? could not start the image from sd, 2018-01-04-kali-xfce-desktop-v1.0-bpi-r2-sd-emmc.img also with other images no success, need help, thanks for that. i read in the forum and hope to have understood a lot burton

Some chips are not stable enough (e.g. profilic) thats why i suggest cp2102-chipset my adapters with that working stable.

your screenshot is hard to read…but the textoverlay says right options…

maybe you can another gnd…id don’t know if all GNDs are connected in these strange DB9-connectors

Adapters with prolific Chips do not work at all! I also had that problem until i tried a ftdi-to-usb adapter. :wink:

Maybe I’m incorrect here, but is that digitus device providing TTL lines? A serial port on the back your PC for example is a different electrical interface from the one on the PCB. Usually something like a MAX232 is used to convert from TTL to RS232… but I would get a device that converts TTL UART to USB directly.

these do i use currently:

small (i will build in my case), cheap and working fine :wink:

w:16mm x l:20mm x h:5mm (30mm long with my angulated pins) paired with a magnatic micro-usb-cable (ät-Kabel-Kabel-für-Android-Handy/302441586097 ) perfect for case

For this reason I have ordered a couple of MAX232 modules with 9-pin standard rs232 jacks. No banana without a Max any more :slight_smile: With this you can use a simple RS232-to-USB adapter

Look here:

Hi I tested it on my Linux notebook again. This one has a COM port, with the same result. @frank i can buy one, but it seems strange. Otherwise you have tips for me…thx burton

:warning: please do NOT :no_entry_sign: use a real Com-Port!!! RS232 has 12V you damage :zap::fire: your board TTL=5V

you can use my reg-file from the another thread, there are all settings included (also the character-processing) which can be a Problem. or using minicom with the settings from my wiki

used icons so that this line is found easier when scrolling through (not for playing around :slight_smile: )

I measured it = 5,6V :slightly_smiling_face:

Well to keep it simple: the UART on the R2 boart are NOT compatible with any RS232 converters. Okay?