Update of BPI-WiringPI2 for M2-Zero

As pull-up and pull down resistor and the wiringPiISR library call did not work for Banana M2-Zero I modified the BPI version and (partly) fixed the problems. More details in the README file on my github. As stated in the README I did not test every command, just the ones I needed myself.

If you need a command or library call which is still buggy ( for M2-Zero) let me know and I will see what I can do … wish you fun

example of (corrected) gpio readall: grafik


Im getting this error when building:

GPIO Utility
[Compile] gpio.c
[Compile] pins.c
[Compile] readall.c
gpio.o: In function `doEdge':
gpio.c:(.text+0x7d4): undefined reference to `bpi_translate_towPi'
collect2: error: ld returned 1 exit status
Makefile:55: recipe for target 'gpio' failed
make: *** [gpio] Error 1

Im trying to investigate why this happen, and how to solve it. Which inage do you use to buid it?

[SOLVED] I needed to uninstall the original WiringPi of the image

1 Like

Worked like a charm. Thank you very much!!! :smile::smile::smile:

I measured up to 8 khz which is the same as Rpi.

I tested it in the 3 pins of the example isr2, on a BPI-P2 Zero that is very similar to a M2 Zero.

This is the example I used to test it, if you want to add to the examples folder isr3.c (2.9 KB)