Tiny Image with no source no desktop BPI-M3 only

Here is another image. This one is the smallest so far it has enough on it to boot and assemble your own images.

user pi pass bananapi


thank you share this image .

I have installed this image and is now in the process of finetuning it via putty. It is on a 16GB SD card. AFAI can see the image takes about 6-7GB? How do I expand the filesystem up to the maximum available on the SD card?

When doing a lsblk I get this:

sda                8:0    0 232.9G  0 disk
└─sda1             8:1    0 232.9G  0 part
mmcblk1boot0     179:32   0     4M  1 disk
mmcblk1boot1     179:48   0     4M  1 disk
mmcblk0          179:0    0  14.9G  0 disk
├─mmcblk0p1      179:1    0   256M  0 part /boot/firmware
└─mmcblk0p2      179:2    0   800M  0 part /
mmcblk1          179:16   0   7.3G  0 disk

How do I know which one to expand, can I do it via command line, and how?

edit: I found this http://www.armhf.com/expanding-linux-partitions-part-1-of-2

  • looks like it worked. Only thing is I am not sure how to see if I actually have the whole SD card available.

I’ve managed to make everything work, so far. Still w/o GUI and doing everything via CLI, the last thing I need to do is mount the external SSD (via the SATA port). When doing a mount -a (as root) I get this:

# mount -a
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
   missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.

Any idea what to do about this?

edit: I have given up, for now, on the SATA port. I plugged the SSD into a USB port and now everything works.

I suspect there is something wrong with the board that mess up the SATA port? Unless someone can lead me in the right direction on how to make it work - in a not too cumbersome way?

Just too bad, as I’ve bought 4 M3s that I wanted to run with SSDs to SATA for good R/W speed, but now I’m only able to use the USB port.

Hi Henri to see How much space on a drive use “df”

Odd that the USB worked and not the Sata as the Sata port is just an USB to Sata chip not true processor Sata.

I have seen similar issues with fat32 and exFat formatted drives. The most often I see the issue with fat32 formatted on Apple Macintoshes. I assume from use of Putty you are using some color of Windows.

UDEV will mount post boot fat in FUSE so I would guess that is why you are able to use the USB.

To see if you have a bad port use lsusb while the drive is attached. Also absolutely imperative to provide enough power for these boards.

I am using a separate supply for a 2TB 3.5 drive with no issues.