System halt! BPI-R4

I followed the instructions in the “Getting Started with BPI-R4” document and downloaded the BPI-R4-mtk-bpi-r4-SD-20231030 image. I used Balena Etcher to flash it onto a 64GB SD card, set all the jumpers to 1, and successfully booted the system from the SD card. Later, I downloaded the bananapi_bpi-r4-sdcard.img.gz, flashed it onto the SD card, and attempted to reboot. However, I was unable to successfully boot the system again. I tried replacing the SD card and re-flashing the BPI-R4-mtk-bpi-r4-SD-20231030 image, but I still couldn’t get the system to boot successfully.

I don’t know what happened. The only suspicious reason is that my motherboard once fell off the table, but it didn’t hit the ground because the power cord caught it.

F0: 102B 0000

FA: 1042 0000

FA: 1042 0000 [0200]

F9: 1041 0000

F3: 1001 0000 [0200]

F3: 1001 0000

F6: 380E 5800

F5: 480A 0031

00: 1005 0000

FA: 1042 0000

FA: 1042 0000 [0200]

F9: 1041 0000

F3: 1001 0000 [0200]

F3: 1001 0000

F6: 380E 5800

01: 102A 0001

02: 1005 0000

BP: 0200 00C0 [0001]

EC: 0000 0000 [3000]

MK: 0000 0000 [0000]

T0: 0000 0123 [0101]

System halt!

Have you unpacked the image before flashing?

But i guess something got broken,maybe remove and reinsert the card.

Yes, these are the two images I have used.

Hi,This problem is discussed in a topic for BPI-r64. I always use img. for sd card from OpenWRT

I have tried many times. I have tried using different SD cards, deleting all partition information from the SD card and then formatting it, and using both Balena Etcher and Win32 Disk Imager to flash the image. Before this, I successfully used the original image and the OpenWRT image, but now, no matter what I try, it doesn’t work, the console only prints the above information. Perhaps my SD card slot is broken.

I think you can only look for visible damage…bootrom output looks very long

BPI R4’s built-in NAND (at least in my sample) comes pre-flashed with MTK firmware. Switch to NAND boot and see if the system starts up. Then check if SD slot still functional once in Linux.

Unfortunately, it didn’t work.

That’s what drives me crazy the most. I have no idea where the problem is.

Perhaps the blue DIP switch is broken…

EDIT: Personally I found the DIP switch feels flimsy…and fragile, and hence I handle it very carefully. Perhaps it’s the weakest link on otherwise a very sturdy board.

Everything seems fine.

It appears to be working correctly. When I toggle different switches, the console output changes appropriately. I suspect that my SD card slot is broken, but I don’t know how to verify this. I will seek help from my dealer.

If you had run stock OpenWrt once, the factory image inside the built-in NAND is likely damaged. It happened to me and I haven’t spent time to understand the cause. But it may explain why NAND doesn’t work for you.

If your SD slot is also broken, then your R4’s virtually bricked.

What you may try is apply little pressure on the SD slot cage…then power on and see if it helps.

Someone may be able to de-solder the NAND chip and flash an image. Then if your SD slot is broken & can’t be fixed, you will still have a usable board.

There is a way to boot via uart in case of sd and nand are broken

It needs additional tool and a bl2/fip prepared for ramboot

it should help to at least flash emmc and then boot from this

A great success! I would like to call you “YYDS”

After I completed this step, I successfully booted the system from the SD card. However, when I rebooted the device, the same initial error occurred again. @frank-w

Wasn’t aware of this. Very interesting to know. I also apparently forgot the serial console is still functional.

needed to google this acronym, but thanks :slight_smile:

As i said you can try accessing emmc / nand from uboot and maybe flash it if it contains an invalid system…

It is only a way to boot system for diagnostics and software repair,wonder why booting system from sd work once

Sometimes I cannot boot sd also on R3/R4, have to re-insert the sd-card. Not sure this is tje same thing though.

Thought this is an uboot issue you have fixed by loading kernel via atf…

But based on Output above it does not find bl2 on selected bootdevice. Or was the reboot in another bootphase (different output)