Sunxi-mmc 1c11000.mmc: error


I own a BPI M2 Ultra board running debina buster on Armbian on SD card, but while trying to boot form eMMC i always receive the folowing errors that stops the board

sunxi-mmc 1c11000.mmc: data error, sending stop command sunxi-mmc 1c11000.mmc: send stop command failed

I already disabled the mmc2 (1c11000) on dtb file, and now the board boots and works perfect from SD, but of course, i don’t wan to losse eMMC flash memory

Is it hardware failure? is there any way to fix it? i saw on olimex forum, that the manufacturer answered a similar question telling the customer that the problem was a capacitor that they soldered for eMMC 5.0 performance. “The capacitor that was over U10’s pads was needed at some point, it was soldered on purpose as a hardware fix that improved boot reliability when using 5.0 eMMC. It adds delay to EMMC_CLK that improved. It is 15pF in 0603 package (we used 50V one but the voltage shouldn’t matter as long as it is 15pF in 0603). This fix doesn’t work for newest 5.1 eMMC memories, however. If you need more details please contact me over [email protected]

Nevertheles the board boots form eMMC original BPI image (legacy kernel), so, i’m not sure about the hardware problem.

Any help will be appreciated.


Mauricio F.

Isn’t a hardware problem but i face the same problem with a SINA33 board using the mainline kernel. Without the capacitor the eMMC give errors but, with the capacitor works!! I added a capacitor 10pF between the CPU EMMC_CLK output and the resistor that is in series with the eMMC CLKM pin. That worked only for the 5.0 eMMC. I give the same try with eMMC version 4.41 and didn’t worked. With the provided firmware the eMMC works without any change, the problem only was presented on the mainline kernel. I haven’t find any solution or the reason why this happening.

hello, did you use the debian image from google drive, seem I have same issue for boot from emmc, but my boot screen always stuck on waiting the mmblk0(sd card) device to mount, but I was plug out, I don’t know if same way can change the bootboader…

@sinovoip seem we have some issue with debian buster image, do you have idea for this kinds of issue?

I haven’t find any solution to that problem yet. The problem is present mostly on the Micron eMMC chips. It has to do with the clock phase .output .sample inside the sunxi-mmc.c driver on the sunxi_mmc_clk_delays structure.