SSH unresponsive BPI-M2+ Zero

Having tried several of the images on this forum including Rasbian, Debian, Ubuntu server, I am unable to establish a solid SSH connection over wifi on any image.

I receive a password prompt, but the connection will either time-out before connection, or after more than 1 minute appear, but extremely slow, unresponsive.

I’m running on a good PSU with 5V/2A. Serial terminal over the UART debug terminal is solid. Wifi connection seams solid (wavemon says link quality is around 97%) and apt package installation progresses at good speeds. No errors appear in the boot output. systemctl status ssh indicates the service is running. Restarting the service has no effect on the lag.

Can anyone provide some advice? Could there be a hardware issue? I have tried many things and I am at a loss.

  1. try the latest image 2020-04-, 2019- image have wifi connection issue.
  2. connect wifi atenna.

If wifi connection quality(speed and stability)test is well, it may not be a hardware issue.