[solved] Upgrading Fedora Kernel

I’m using the Fedora 23 image (2015-12-10-Fedora-Mate-armhfp-23-10-bpi-m3-sd-emmc.img.zip) provided by http://www.banana-pi.org/m3-download.html, that ships with kernel “3.4.39-BPI-M3-Kernel”, but I cannot find any kernel-modules under /lib/modules/3.4.39-BPI-M3-Kernel/kernel/fs.

After doing an “dnf update”, it installs kernel “4.4.6-301.fc23.armv7hl” and some modules, but I’m unable to boot into the new kernel.

Is there a way to install modules on shipped kernel, or to upgrade it?


Yes there is an way. Compile the BSP (https://github.com/BPI-SINOVOIP/BPI-M3-bsp) and copy the Modules and the Kernel… I hope it helps a little :smiley:

Thank you @Philipp! :smiley:

I’ve just realized that the kernel from the shipped image is built without nfs support. :sweat: Recently they have enabled it: Enable NFS feature config

I’ve followed @tkaiser instructions from here, and got nfs working now :grinning:

It’s even more easy. SinoVoip provides updated u-boot and kernel packages on Github. For whatever reasons they package the stuff as Debian .debs which is close to moronic since essentially it’s just a container for some files and they don’t use any of Debians package management features.

Here you find the .deb for the M3 https://github.com/BPI-SINOVOIP/BPI-files/tree/master/debs

The whole payload is just another archive that will has to be written using their bpi-bootsel tool to the image/SD card. So instead of doing it right they provide the whole stuff as a Debian package (making it harder to use this stuff for users of non-Debian distros) but don’t use the Debian architecture.

Since when I provide a .deb for this, then I can also do the install from within the package installation and put the whole thing in an online repository. Then all the M3 Debian users could simply do an ‘apt-get upgrade’ to get the latest fixes. So they limit the usefullness of the provided stuff since users of non-Debian distros are kept out (like you) and their Debian users can’t also benefit from since they have to manually call bpi-bootsel all the time to get the real updates.

BTW: In this thread I tried to explain how to use the new uEnv.txt/script.bin feature (they implemented it a while ago but both implementation as well as ‘documentation’ is broken): BPI-M3 new image:bpi-m3 Ubuntu 16.04 Beta Mate

1 Like