[SOLVED] Problem with connecting HDD to BPI-M1

Hello everyone!

I recently tried to connect a WD WD10JFCX hard drive to the SATA port of my BPI. However, when I run fdisk -l, the device doesn’t show up. The only device I see is the SD-card with the OS on it. It even seems like the HDD doesn’t even start up after being connected to the BPI, because I can’t hear any noise from it. Both the BPI and the HDD are new products.

Here are some things I already tried:

  1. I tried to use another SATA-cable. I also ensured all cables are connected correctly.
  2. I already tried another power supply. The first one had an output of 2 A, the one I use now has an output of 3 A.
  3. I ran dmesg and grep-ed the output for things like sd and sata.
  4. Using Google, I found this link about a SATA-related issue inside of bananian linux. But the ticket says it should be fixed with bananian 15.04. I use bananian 16.04.
  5. I tried to find a helpful thread with a quick search in this forum, but haven’t found anything that might help me.

Am I getting something wrong? Do I miss something? Or am I just stupid? I’d be grateful for any help!

Best wishes!

Hallo I come from austria my english is sclecht Have you connected the sata power connection correctly https://forum-bpi.de/viewtopic.php?f=30&t=205#p401

1 Like


Kein Problem, ich spreche auch Deutsch:

Wolfgang, ich komme mir gerade so dämlich vor! Tatsächlich habe ich das Netzteil - wie in dem von dir verlinktem Fred gezeigt - an den falschen USB-Port angeschlossen, sobald ich es an den anderen angeschlossen habe, hat die Platte sofort mit einem leisem Geräusch ihre Arbeit aufgenommen. Zu meiner Verteidigung muss ich allerdings auch sagen, dass ich in meiner Vorfreude auf die Banane den zweiten USB-Port gar nicht bemerkt hatte!

Ich bin zwar kein HW-Experte, aber alles in allem erscheint mir das auch recht unintuitiv zu sein - warum muss ich denn bei gleichzeitigem Betrieb einer Festplatte einen anderen Eingang verwenden? Muss ich jetzt noch irgendetwas zusätzliches tun, oder bin ich mit dem Setup Strom -> Banane -> 2 Kabel zur Festplatte richtig aufgestellt?

Vielen vielen Dank dir jedenfalls für deine Hilfe! Seht her, das passiert, wenn man keine Doku liest! :slight_smile:

(I’m not sure whether speaking german is allowed here, so here’s a short summary of what I wrote:)

Indeed I used the wrong USB-port, as shown in the picture at the bottom of the first page of Wolf’s link. As soon as I connected my power supply to the correct USB-port (The one between SATA-port and the SATA power supply…), the HDD started up. However, that seems quite confusing to me - why are there two ports for the power input? After all, it’s a great example for problems that can easily be solved by reading the documentation. :wink: :blush:

Best wishes!