[Solved] BPI-R2 blocking router internet access

Hi! Recently I’ve been trying to set up my Banana Pi R2. After successfully flashing the latest Banana Pi Ubuntu version onto my SD card I connected my BPI-R2 to my router via Ethernet.

Every time I connect it the router internet access gets blocked. As in, the router can not connect to the internet via the modem if the BPI-R2 is connected. As soon as I unplug the BPI-R2 the router connects to the internet perfectly. My computer and phone internet gets blocked as well when the BPI-R2 is connected. I think the R2 is blocking the internet somehow. How do I fix this? My router is an ASUS RT-AC68U

edit: I’m way overdue on this edit but I found a solution to my problem. The R2 would create a new MAC address for every boot. This would eventually overload the router which would then result in the loss of internet, but upon removing the saved addresses and setting a static MAC the issue was swifly resolved. Thank you to everybody who took time out of their day to help!

you have connected r2 as normal client to your existing router?

ASUS-Router    (Co handy (connected to asus via wifi)
 |        |
R2        PC

(top is wan/uplink down is lan)

you try to access internet from your PC? or is PC connected to r2? which is “latest” ubuntu-version? can you access r2 via ssh?

Yes. The R2 is connected as a normal client just like my PC. Nothing special. But it’s more like this;

  |        |
Wifi    Ethernet (PC connected to router via WiFi, R2 connected directly to router via Ethernet)
  |        |
PC         R2

I tried to access the internet from my PC, my PC is connected to WiFi from the router My R2 is running on Ubuntu 16.04 V1.3 2018-3-30 I haven’t tried SSH. I will try it now.

Also, just in case this is relevant. The R2 boots normally but it wont output anything to my monitor via HDMI. It gives a blue screen then no signal.

i don’t know if hdmi should work in official images. hdmi is only working with some kernels and imho 4.4 does only support 1080p. Purple screen is from preloader which only initializes hdmi.

Can you ping r2? Have you logs on your asus-router? Maybe you have a duplicate ip-address and got arp-floading. Do your wifi and ethernet uses same ip-subnet or different?

More needs logs from r2 and/or your asus-router


  1. can you tell me the lan port ip of ASUS-Router, and check your R2 router 's lan port ip too, if their are the same, then may be an ip conflict in LAN 2)or please check another situation, which port of R2 is connected to ASUS-Router, you 'd better try to use wan port.

Do you have access to your network services, if the R2 is connected? There are many many reasons for your problem.

Can you show me your routing informations from R2 and your PC? (route -n) Maybe the R2 overwrites your routers DHCP. Do you tried static IPs?