BPI-R2 New Image Release : Ubuntu 16.04 V1.3 2018-3-30

Banana Pi BPI-R2 New Image Release : Ubuntu 16.04 V1.3

ubuntu 180330

1.About this release

  • This release is for banana pi R2 board which is based on MTK7623N, and it is based on Ubuntu 16.04 Operation system.

2.What’s new in this release

3.Known limitations

  • Bluetooth is unstable

  • Wifi Ap is unstable

  • SPI is unstable

4.Image link:


  • Q1:How to use BPI-4G module with R2?

    A1:How to use BPI-4G LTE module with BPI-R2

  • Q2:How about the performance of BPI-4G module with R2?

    Use ppp:


    Use qmi-wwan:


    Qmi-wwan is faster than ppp,so we recommend qmi-wwan.

  • Q3:How to use mmc-util?

    A3:Here is quote from Frank-w,“write emmc-partition-config with mmc-utils”

    [18:02] [email protected]:~# ./mmc extcsd read /dev/mmcblk1 | grep PARTITION_CONFIG
    Boot configuration bytes [PARTITION_CONFIG: 0x00]
    [18:02] [email protected]:~# ./mmc bootpart enable 1 1 /dev/mmcblk1
    [18:03] [email protected]:~# ./mmc extcsd read /dev/mmcblk1 | grep PARTITION_CONFIG
    Boot configuration bytes [PARTITION_CONFIG: 0x48]

    You can find more infos from here:eMMC partition information, mmc-tools on a live system

1 Like

sorry,password??? root/bananapi?

1 Like

hello , username: root , password: bananapi

thank you very much!!!

Any where else to download this image?

hello, I will post image to Google soon, thanks.

Sweet. Thank you. I look forward to giving it a go.

Hello,you can download image from google drive now,


a new quesion: now this image works well, but lsusb cannot display anything about my 4G miniPCIe card. lspci is the same: no information displayed. in other linux embedded system, lsusb works with this card.

so what should I do next? to make a new kernel with BSP? or some steps wrong? thanks

USB D+ and D- pin aren’t connected to mPCIe slot, so card detection fail if you use mPCIe form factor USB 3G/4G card.

Ok, Got it, thanks for your anwser :slight_smile:

Hello Guys,

my ap0 seems to be gone… No change to reload or bring it back, any idea ? Nothing worked, nether the steps from garywang, frank-w

Have you tried

echo 0 >/dev/wmtWifi
echo A >/dev/wmtWifi



more than 10 times, nothing seems to bring it back…

@Jackzeng Continuously testing this image. So far so good except the MMC booting process is locked in maintenance mode when the board is NOT properly shutdown. It forced us to use the root password, check the memory error check by manually and reboot the system. This is a crucial step, wont allow the hardware bring back until the mmc error check should be fixed by manually. Is there anyway we can make this step done automatically during the bootup time or skip this step?.


I just use “ctrl+D” to ignore this problem when met it before, but maybe we could try to fix it in the next few days.

Hello,Can you post your logs here?I checked wifi and ap,it could be created.

@Jackzeng assume, BPI-R2 is a gateway/router product. It dont have display/keyboard. In such case it is not possible for the user to solve this issue.

if using SD-Card you can remove it, put it in external pc, read logs and check filesystem

if using emmc, booting bpi-r2 with SD-Card, and then read logs via ssh

not for every user…but network-admin should be able to do this :wink:

you are right,I will try to fix this in next few days.

@frank-w,we could find a better and easy way to solve these problem,if R2 stuck in booting progress.